7 Replies Latest reply: Jan 14, 2012 7:03 AM by Parneix
Parneix Level 1 Level 1 (0 points)

Hi,

 

I'm just looking for some tips/advice. I'm using Reeder 1.1.3 and recently I've noticed that it makes the AuthBrokerAgent run wild (over 50% of the total process run by my CPU).

 

I was simply wondering what could be the issue here and if there is a way to fix it. I started a couple of hours ago. Since then I've restarted the computer, restarted the app and reset it.

 

I know this could be a problem on the app's end. But if there is anything I can do from Lion's end, I'll be glad to try it.

 

Thanks for your time and attention,

 

P.


Macbook Pro Unibody Core 2 Duo 13, Mac OS X (10.7.2)
  • Parneix Level 1 Level 1 (0 points)

    UPDATE: I did try a couple of things.

     

    1) I've uninstall the app (along with its preferences files), restart the computer and re-install the app.

    2) I repaired all permission on my Mac.

     

    It didn't fixe the problem.

     

    P.

  • Parneix Level 1 Level 1 (0 points)

    UPDATE: This problem is NOT related to the Reeder application. It's seem to be a system wide problem in Lion (at least for me).

     

    The AuthBrokerAgent ran wild again today, but this time it was triggered by Mail. It started consuming over 80% of the CPU and fans ran amok at 6000 rpm (the Reeder app was not running at the time). The only way to make it stop is to quit Mail. Killing the process in the Activity Monitor doesn't work since the process restart itself as soon as it is stopped.

     

    What I'd like to know is what this process is doing, what is triggering it and is there a way to kill it?

     

    In the meantime, I'll need to launch Mail whenever I want to use it and quit it as soon as I'm finish with it.

     

    Thanks for your attention,

     

    P.

  • Parneix Level 1 Level 1 (0 points)

    CORRECTION: The problem I encounter in Mail was indeed related to Reeder. The process AuthBrokerAgent was triggered in Mail because I received an item sent via Reeder (in Reeder there's a function that allow the user to easily share an item via email). As soon as I deleted the email sent via Reeder, the AuthBrokerAgent process stopped completely.

     

    It will not run until I launch Reeder again.

     

    P.

  • 0xBA5ECA5E Level 1 Level 1 (10 points)

    It sounds like you may be configured to use a network proxy that requires a username and password, but your stored username and password are incorrect.

     

    Can you try this:

     

    1) Delete any credentials (username/password) stored in your System Keychain for the proxy using the Keychain Access app (/Applications/Utilities/Keychain Access.app)

     

    2) Re-enter the correct username/password for the proxy in:

         a) System Preferences -> Network -> Advanced -> Proxies -> Web proxy (HTTP) and/or Secure Web Proxy (HTTPS)

         b) Safari when it prompts you for the proxy username/password. Check the box to save in your system keychain

         c) In the AuthBrokerAgent prompt for the proxy username/password

  • Parneix Level 1 Level 1 (0 points)

    Hi,

     

    Yes, that's what I came to think while reading the this thread (where you participate too).

     

    A couple of things:

     

    1) I am indeed configured to use a network proxy that requires a username and password. The only time I'm prompted to enter those credentials is 1) when I'm browsing a protected website on Safari; 2) Also, incidently, when I'm tring to read an article in Reeder (my RSS feed reader) that is protected.

     

    However, since the problem began with the AuthBrokerAgent process, I was not once prompt by Reeder to enter my credential.

     

    2) From your instructions, I can easily do 2a and 2b. However, I was not once prompt by the AuthBrokerAgent process to enter any credential (nor, as I said, by Reeder which is the app that triggers this process).

     

    While we're at it, and in the interest of troubleshooting this thing, could I first disable my proxy and see how it goes (if the AuthBrokerAgent is still triggered by Reeder)? If so, do I need to reboot after I disable the proxy AND do I need to remove (in order to force its recreation I guess) the com.apple.cfnetwork.AuthBrokerAgent.plist file ?

     

    Thanks a lot for your suggestions.

     

    P.

  • 0xBA5ECA5E Level 1 Level 1 (10 points)

    Oops, I'm sorry 2a, 2b, 2c are all mutually exclusive. Please only do one of them.

     

    After doing 1) and one of the items from 2), do you still see the issue?

     

    To disable your proxy you will not have to reboot. Once you do so, AuthBrokerAgent should not run since it is only associated with proxies.

     

    Removing com.apple.cfnetwork.AuthBrokerAgent.plist will definitely stop AuthBrokerAgent from launching, but it is overkill. There are other, simpler and more appropriate ways to handle the launch of AuthBrokerAgent.

     

    Let me know if you still see the issue after doing 1) and 2) and we'll take it from there.

  • Parneix Level 1 Level 1 (0 points)

    That's it: problem solved. Reeder has been running for twelve hours and the AuthBrokerAgent never kicked in.

     

    All I did was 2b: I went on a site requiring my proxy credential and, when asked, enter my proper credentials and check the option to store it in my keychain.

     

    Good thing to know. Those credentials changes two time a year. I'll need to make sure to properly update my keychain in order to avoid the runaway process again.

     

    Thanks a lot for the tip: I've been looking for info about the AuthBrokerAgent process for the past two months.

     

    Hopefully, this thread could help others with a similar problems.

     

    P.