Skip navigation

Your computer's clock is set to a date before March 24th, 2001. This may cause some applications to behave erratically.

3240 Views 3 Replies Latest reply: Nov 13, 2012 10:11 AM by je55icadc RSS
dimitar103 Calculating status...
Currently Being Moderated
Nov 2, 2011 11:33 AM

Hi,

I keep on getting this message each time I start: "Your computer's clock is set to a date before March 24th, 2001. This may cause some applications to behave erratically." When I go to SysPref and try to reset the time&date, the computer stucks and I have to force quit SysPref.

Help please,

THX

PowerBook, Mac OS X (10.4.11)
  • Texas Mac Man Level 8 Level 8 (44,270 points)

    Appears that your internal PRAM memory battery has died & needs replacement. What model PowerBook do you have?

     

    Here's something to try. Startup in Safe Mode (depress the Shift key at startup). The startup may take a while while some "ficxes" are being made. After you are booted, open the Date & Time preference window. If you are connected to the internet, be sure to check Set date & time automatically. Now the time should be correct. Then you can restart normally.

     

     Cheers, Tom

     G4 1.25HGz MDD, PB 12" G4 1.5GHz, Mac OS X (10.5.8), (10.4.11, 9.2.2) iSight,iPad2 
  • old comm guy Level 4 Level 4 (2,230 points)

    How are you connecting to the Internet?  Normally, the system will look for time from a time server like time.apple.com at boot and you wouldn't see a message like you are getting.  However, if, as noted above, the backup PRAM battery has died (not unusual at all for a PowerBook at this point in time) and you are not connected to the internet at boot, then the default Mac OX X time will be set, which is as I recall midnight, January 1, 1970 GMT.

     

    If you are not connected to the internet when bringing up Date & Time in System Preferences, and the "Set Date & Time Automatically" box has been checked, then the Date & Time preference will hang trying to set the time.

     

    So, there are two answers to your issue here.  In no particular order of importance, they are:

     

    1. Make sure you are connected to the internet at boot (not always possible with some TiBooks when using AirPort) or when bringing up Date & Time preferences; or
    2. Replace the PRAM backup battery (some PowerBooks do not have same).

     

    I am trying to find the preference file that contains the set time automatically flag and have been so far unsuccessful.  If found, you could possibly trash it or move it to the desktop to at least access Date and Time.

    TiBook G4 1GHz/ G5 2 GHz DP GF Ultra 6800, Mac OS X (10.4.11)
  • je55icadc Calculating status...

    If possible try going into preferences for time and date and uncheck the box for automatically setting the date, then set it manually.  This helped me.  Hope it helps

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.