Skip navigation

Lion - Address Book Duplicates

32754 Views 39 Replies Latest reply: Jul 20, 2013 10:03 AM by Csound1 RSS Branched to a new discussion.
1 2 3 Previous Next
kdeemer Calculating status...
Currently Being Moderated
Nov 2, 2011 3:10 PM

Almost every one of my address book entries is duplicated. Some are identical and most of the others simply have the phone numbers in a different order. I went through a Card/Look for Duplicates. It said that it found about 2,000 duplicate entries. I told it to merge them, and it crunched for a while, but nothing seemed to change. Running it again doesn't find any duplicates, however.

 

I still have about 2,000 duplicate entries. If I try to manually merge two identical entries, by highlighting them both and clicking Card/Merge Selected Cards, I get the message 'The cards could not be merged because they came from different accounts'. I would really like to know *** that means.

 

Any help appreciated.

  • 2 Time Olympian Level 1 Level 1 (55 points)
    Currently Being Moderated
    Nov 4, 2011 12:17 AM (in response to kdeemer)

    If the "Look for Duplicates" feature did not work for you, you are not alone.  Here's another solution.  Open Address Book Preferences and view the accounts.  In all likelihood you have 2 iCloud Accounts.  This would have happened if you joined iCloud early without setting up a free "me.com" e-mail address like myself.  When I finally decided to change my Apple ID to my "me.com" address to benefit from iCloud Mail, my entire address book and Birthday's in the Calendar duplicated.  So the solution to to simply delete the old iCloud Account which is for all intense and purposes a duplicate of your actual iCloud account.  Problem solved.

  • --russell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 12:58 PM (in response to kdeemer)

    I posted this in another thread on Address Book duplicates and iCloud. Did this start after the iCloud hoopla? After I tried iCloud, I ended up with duplicate contacts on my computer. The "Look for Duplicates" command in Address Book gave me soemthing to the effect, "No duplicates found," which raised my blood pressure as I could see them right there.

     

    Going to System Preferences did the trick for me. Click on iCloud under Internet & Wireless. Untick the checkbox for Contacts. You'll then be given a choice of keeping your iCloud contacts on your computer, with the options of Delete from Mac or Keep Contacts. No, you don't want to delete the contacts from your box, so choose Keep Contacts. Let it do its thing, then re-tick the Contacts checkbox.

     

    Like I said, at least for me this solved the problem with no more duplicate entries on my box or my iPhone.

  • Matt Baume Calculating status...
    Currently Being Moderated
    Nov 12, 2011 7:08 PM (in response to --russell)

    This worked for me too! I think it was triggered when I set Address Book to sync with Google. Suddenly I had two of everything. So I followed russell's instructions, and now all the duplicates are gone. Interestingly, when I look at my list of accounts in Address Book, the "On My Mac" category is now gone. All of the contacts now live in iCloud. Previously, one set of duplicates lived on my Mac and the other set lived in iCloud.

  • Csound1 Level 7 Level 7 (32,495 points)
    Currently Being Moderated
    Nov 12, 2011 7:21 PM (in response to --russell)

    --russell wrote:

     

    I posted this in another thread on Address Book duplicates and iCloud. Did this start after the iCloud hoopla? After I tried iCloud, I ended up with duplicate contacts on my computer. The "Look for Duplicates" command in Address Book gave me soemthing to the effect, "No duplicates found," which raised my blood pressure as I could see them right there.

     

    Going to System Preferences did the trick for me. Click on iCloud under Internet & Wireless. Untick the checkbox for Contacts. You'll then be given a choice of keeping your iCloud contacts on your computer, with the options of Delete from Mac or Keep Contacts. No, you don't want to delete the contacts from your box, so choose Keep Contacts. Let it do its thing, then re-tick the Contacts checkbox.

     

    Like I said, at least for me this solved the problem with no more duplicate entries on my box or my iPhone.

    You realize that your contacts will now no longer sync between your Mac and your iPhone right?

  • Matt Baume Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2011 12:24 AM (in response to Csound1)

    I followed Russell's instructions and contacts do appear to be successfully syncing between Address Book on my Mac and on my iPhone. Changes that I make on one device are reflected on the other. According to iTunes, my contacts are being synced over the air.

  • Csound1 Level 7 Level 7 (32,495 points)
    Currently Being Moderated
    Nov 13, 2011 6:51 AM (in response to Matt Baume)

    Put a new contact on your Mac, call it test, see if it appears on your iDevices

  • chr2 Calculating status...
    Currently Being Moderated
    Nov 13, 2011 8:44 AM (in response to --russell)

    Thanks, this does seem to be resolving the issue for me.  Should just amplify these steps by saying I was able to use "Look for duplicates" command right after unchecking Contacts in System Preferences, which then found and allowed merging something like 2300 dups for me, thank goodness.  Probably reclaimed a cpl terabytes of space on my iPhone that way.

  • tridebri Calculating status...
    Currently Being Moderated
    Nov 17, 2011 6:58 AM (in response to chr2)

    Worked for me too...thanks

     

    bw

  • njseth Calculating status...
    Currently Being Moderated
    Nov 17, 2011 3:07 PM (in response to kdeemer)

    Had the same problem, this fixed it, thank you. Unclicking and reclicking the iCloud Contacts preference forced a  merge of the local and server accounts, resulting in a single data set.

  • PaulNottm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2011 5:43 PM (in response to kdeemer)

    Awesome Russell - had the same problem just forced the resynch between the macbook pro and Icloud and no duplicates.  Cheers dude

  • richardhlucas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 5, 2011 12:58 AM (in response to kdeemer)

    hi

     

    Apple newby here. I know have Apple everything Pad, Phone and Macbook air, but still suffer terrible migration pains..

     

    I managed the deduplication, but now when I add a new test address in Address book it doesn't synch to the Ipad or Iphone or my Icloud if I login via the web,,

     

    Using Lion

     

    in Address book accounts I have Icloud ticked

    in System prefereences internet Icloud I unticked and ticked Contacts

     

    Any ideas

     

    thank

     

    Richard

  • RobertNichols Calculating status...
    Currently Being Moderated
    Dec 8, 2011 2:07 PM (in response to kdeemer)

    I am eager to try the fix described above when I get to my office tomorrow. Sounds too easy...but at this point, I'll try anything. Sounds like others have had success.

     

    I suspect my trouble with duplicates upon synching has to do with Lion clients connecting to a Snow Leopard OS X Server. My collection of devices includes 2 iPhones, 1 Lion iMac running stand-alone, and 2 Lion iMac's connecting to Snow Leopard Server. The client machines aren't using the Server's address book implementation, but have the users home directory located on the server.

     

    I can get things going so that the 2 iPhones, the standalone iMac, and the Cloud all report the same number of contacts, with no duplicates. This config will remain stable indefinitely (have tested 2 days). But the moment I try to include in the sync one of my office iMacs configured for user home directories on the Snow Leopard Server, the duplicates appear...just minutes later.

     

    Does anyone else share a similar setup?

  • Dan Bryant1 Calculating status...
    Currently Being Moderated
    Dec 13, 2011 9:28 AM (in response to --russell)

    --russell wrote:

     

    Going to System Preferences did the trick for me. Click on iCloud under Internet & Wireless. Untick the checkbox for Contacts. You'll then be given a choice of keeping your iCloud contacts on your computer, with the options of Delete from Mac or Keep Contacts. No, you don't want to delete the contacts from your box, so choose Keep Contacts. Let it do its thing, then re-tick the Contacts checkbox.

     

    This did it for me too.  If you have a lot of contacts, you may need to wait a minute or two for the change to take effect before you re-tick the checkbox.  Thank you Russell!

  • kathryn sassall Calculating status...
    Currently Being Moderated
    Dec 13, 2011 12:55 PM (in response to --russell)

    Thank you so much. This has been annoying me since upgrade at last I have one merged iCloud address book.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.