Previous 1 5 6 7 8 9 Next 153 Replies Latest reply: Oct 6, 2014 1:56 PM by ryanfox50 Go to original post
  • Bizacca Level 1 Level 1 (0 points)

    i also entered in the sort album field, the album name.

    when you look under album it has songs listed seperately but if you click a song it will THEN show the album...

  • r34v3r Level 1 Level 1 (0 points)

    Ah, I tried Sort Album the first time around and it didn't fix the problem for me. Manually changing the tags with another program than iTunes seems to do the trick though. Either way, if Sort Album is working for other people, then great coz this is such an annoying problem.

  • elhombrealto Level 1 Level 1 (0 points)

    About a month ago, I noticed that my iPhone had a similar problem to what the original poster has.   I finally got around to researching the trouble, and have tried most of the suggestions provided in this discussion, but nothing seemed to work.

     

    I stumbled across something yesterday that to my surprise seems to have fixed the problem, but I don't yet know if it is only a temporary fix or not.  Only time will tell.

     

    Let me give you a little background on the matter.  I live in Japan (this will be important to the story later).  After fooling around with so many settings in both iTunes and on my iPhone, I became really, really frustrated by this silly matter. Keeping things in alphabetical order shouldn't be this difficult.

     

    As I said, I live in Japan.  My iPhone is setup to use the English language for the operating system.  My wife's phone is set to the Japanese language.  I thought I would check her music organization to see if she was having any trouble with her ordering.  Nothing seemed wrong with her playlists and artist/song title ordering on her iPhone, however being in the Japanese language it wasn't set to organize from A-Z.  The Japanese have a different organization based on the Japanese Kana system. They have their own Kana ordering and her music was correctly ordered. (The Japanese titles were listed first in their correct order, followed by the English titles also listed in their correct order).

     

    On a whim, I decided change my iOS over to Japanese just to see what would happen. Since I didn't have any Japanese titles on my phone, instead of listing the Japanese Kana titles first, it listed the English titles first, and lo and behold most of the titles/artists were listed under their appropriate heading.  This got me excited.

     

    I then reverted the language back to English, and again the most of the artists/song titles were still showing up under their appropriate field.   I say most, because it wasn't correct for all of them.  There were a few that were still misplaced, but the fix was enough to make me happy.  I put the phone down and forgot about it until about 6 hours later.  I wanted to check it one more time to see if the changes had stuck, and even better all of the artists and songs were now properly categorized.  It's only a guess on my part, but perhaps the library needed more time to update all of the tracks and put them in their correct order.  I really don't know for sure.

     

    As of today (more than 24 hours later) everything is still in its proper place.  I have yet to add any new music to the phone, as I am a bit afraid (read as chicken) to mess it all up again. 

     

    PLEASE NOTE:  if you do follow this pattern, before you actually change the language be sure you take note of all the menu's and step's needed in order to change the iOS language. Once you change over to the Japanese language, it may be hard to find your way back into the language screen.   

     

    I also don't know if this is strictly associated with the Japanese language, or if it will also work with other languages as well.   If you try it out, please let us know your results. 

  • rubberchicken17 Level 1 Level 1 (0 points)

    Ooooohhh we may be onto something here!!! Finally!!

     

    I switched over to Japanese and chcked my music library and yes, they were all listed in the proper English aphabetial order! Everything was perfect. I then switched the lanaguage back to English and all artists are still in the correct order. However, the alphabetical headings are wrong:

     

    For instance:

     

    K

    Andrew Bird

     

    L

    The Black Keys

    Bob Dylan

     

    M

    The Cure

     

    ...and then at the bottom of the list

     

    123

    The Veils

    Violent Femmes

     

    123

    The Weepies

     

    123

    Yael Naim

     

    But the artists are in order which is a HUGE improvement, they were starting to get really really confusing because I've added more music lately. I will check it again later, maybe it will be completely fixed like the AWESOME person before me that came up with this idea. Thank you!

  • rubberchicken17 Level 1 Level 1 (0 points)

    This totally works! About 10 minutes after my previous post I was leaving the office so I went to Music+ app (which I've been using exclusively for playing music the past few months because it scrobbles to last.fm) and all of the artists were listed in order with the right alphabetic indexing!

     

    I then checked the regular, stock Music app (which is where I initially checked the music library after switching the langauges) and it was still all sorted properly but with the wrong alphabetic index headers or whatever you call them (as explained above). So I then skipped through an album using the Music app. Left the app and went back in and the last of the wonkiness was totally resolved!

     

    I haven't synced any new music yet, I'm going to enjoy having things in the right order for a while before I try that out. In any event, many thanks to elhombrealto for your clever thinking and sharing this here! Thank you thank you!

  • WhelkWhelk Level 1 Level 1 (0 points)

    5.1.1 seems to have fixed this issue (so far) for me.

  • rubberchicken17 Level 1 Level 1 (0 points)

    Oops. I spoke too soon! Last night I woke up in the middle of the night and went to put on Dark Side of the Moon and I realized that Pink Floyd was totally missing from the music library. It turns out that changing the languages hid all of the "old" music on my iPhone (the music that was synced to my 3GS when I restored upon getting the 4S) and sorted properly only those artists that were added once the problem started. Weird right?

     

    What follows is more interesting than helpful, I don't recommend you bother reading if you are in a hurry.

     

    First thing to note is that the phone knew the files were in the filesystem somewhere as it accurately reported the amount of available space on the phone. However, in the About menu it reported a the total number of songs on the phone based only on those that were visible.

     

    So anyway, I tried an experiment, I unchecked a single song from one of the artists that was "hidden" in the artist list. Synced my iPhone. And then I checked it back to add it back to the phone. And synced again. And voila ALL of the previously hidden albums by that artist magically appeared. Weird right?

     

    I also noticed that there were a few "old" artists that did not get hidden after switching the langague back and forth. I determined that these were artists for which I had added an album or song for after my initial restore from the 3GS. For instance, Bruce Springsteen...I've had Born to Run on my iPhone from back when I had the 3GS and I recently added his new album Wrecking Ball. I determined this is why Bruce was not hidden from my list of artists after I switched the languages.

     

    Final point...after resyncing all of the artists that were "hidden" reappeared and I compared to my Nano which is synced to the same comupter/iTunes and the total number of artists now matched. However, the total number of songs is still off by about 20 and I can't explain that since I don't see any missing individual tracks when I go through albums (but it's probably easy to miss that when searching for 20 missing songs out of 2000). But it does seem like those 20 songs might only be "hidden" in the song list and song count. Not sure about that.

     

    So what does all of this mean? I have no idea. I think my best advice based on my experiences would be that when you get a new iPhone to unsync all of your music before you restore to the new device. Or unsync evertyhing after restoring and then resync (which is essentially what I'm going to have to do in the end anyway). What this means for me going forward is still unkown...I will be intersted to see if artists start getting out of order again after unsyncing everything and resyncing. And I will not be happy until my song count on my iPhone reconciles with my Nano so I'm going to unsync everything from both devices and resync all music to both from scratch tonight. Ugh! This is the sort of nonsense I was going to try to avoid (don't have time for this!) but now I'm down the rabbit hole and there is no turning back until both devices show the same song count.

  • elhombrealto Level 1 Level 1 (0 points)

    Just an update - It has been over 48 hours and everything is still in its place.  I even went so far as to remove one album.  When that looked successful, I went ahead and added an additional album to my iPhone, with as much success.

     

    rubberchicken17:  Before I changed the language on my phone (I too have the 3GS), my listing was pretty much exact to yours.  I had most of my tracks already in alphabetical order, yet they weren't falling under the "A" heading.  Instead, the "A" tracks started under the "K" heading, "B" tracks were under the "L" heading, and continuing down from there.

     

    It was only after I played with the languages that it fixed everything.   As far as I know, I don't believe that I have any missing or hidden tracks from my phone, however I too have over 2000 tracks so I don't know if I would notice anything missing right away.

     

    I wonder what would happen if you tried changing the languages once more?

  • WhelkWhelk Level 1 Level 1 (0 points)

    I spoke too soon. 5.1.1 merely made the problem go away for a short while. As I add more music, everything shifts down out of place.

     

    Come on Apple, this is pathetic. Have you guys even acknowledged the problem? Not doing so shows complete disrespect for your customers.

  • lathicentropy Level 1 Level 1 (0 points)

    elhombrealto:

     

    Your suggestion finally clued me in to why I was also having this problem. I have iTunes match with around 17,000 being synced through it and the same thing was happening to me. A few days ago I switched my phone for a minute over to Japanese language to show a coworker something and then switched back to English. Later I noticed the appearance of the "All A artists under K" issue. I didn't associate the previous event with the latter issue but do now. I solved it by going to languages and switching to Japanese. While still in this language I turned iTunes match off and made sure all music had disappeared from the musc app. I then switched back to English and turned iTunes match back on. Success.

     

    Thank you for tipping me off to this issue.

  • brad296 Level 1 Level 1 (0 points)

    my problem resolved itself after clearing all artist info in the composer section,

  • CaptPicard Level 1 Level 1 (15 points)

    Temporary chaning the language worked like a charm for me (iPhone 3GS)!

    I have to add that I had to manually stop and restart the Music app in order to let the correct sorting take place! You can do that by going to the home screen, double-clicking the home button, hold the Music app icon in the lower bar until a red sign appears in the corner of the app icon, click on that to close the app (and any other apps that otherwise remain resident and possibly active in the memory). When I then did restart the Music app everything was fine.

     

    Thanks a lot! A very good workaround for this bug.

  • MxxC Level 1 Level 1 (0 points)

    Hey everybody.

    I was able to find a fix(workaround?) to this problem.

    For me changing language or album grouping did not help.

    Here's what I did to get it sorting correctly http://apple.stackexchange.com/a/53079/23665

  • MarcAlecAndrew Level 1 Level 1 (0 points)

    Go onto your ipods settings, then music, then turn 'Group By Album Artist' Off, solved it for me!

  • MxxC Level 1 Level 1 (0 points)

    MarcAlecAndrew wrote:

     

    Go onto your ipods settings, then music, then turn 'Group By Album Artist' Off, solved it for me!

    Did not solve it for me, that's why I posted above.

Previous 1 5 6 7 8 9 Next