1 12 13 14 15 16 Previous Next 367 Replies Latest reply: Jan 28, 2014 5:14 AM by Pfb14 Go to original post
  • 195. Re: iPhone 4s location wrong... Why?
    sorinfromdraganesti Level 1 Level 1 (0 points)

    I update to ios 501(9a406)last night no change

    But in the morning i try this

    Turn on airplane mod

    Turn on wiifii

    Turn off location service and back on

    And go to maps

    The lication was right

    ....you have to make this outside not inndors

    Until now it works for me.

  • 196. Re: iPhone 4s location wrong... Why?
    flavius andrei Level 1 Level 1 (0 points)

    well, looks like this is not a software nor a hardware issue, just a carrier who needed an update from apple

     

    location errors are gone, everything's fixed for me without doing a single thing.

     

    though there's still a bug... siri doesn't know where i am, automatic date & time doesn't work right...

  • 197. Re: iPhone 4s location wrong... Why?
    Fairlady_Z Level 1 Level 1 (0 points)

    I have found the way to fix this, simply by calibrating the compass:

     

    http://support.apple.com/kb/TS2767

     

    Hopefully this helps you all out.

  • 198. Re: iPhone 4s location wrong... Why?
    flavius andrei Level 1 Level 1 (0 points)

    ugh... what?

  • 199. Re: iPhone 4s location wrong... Why?
    nishanthrao Level 1 Level 1 (5 points)

    After trying out a couple of solutions including the calibrating compass, enabling disabling airplane, wifi, location services mentioned some where in the discussions over the last couple of days, I can only conclude it is a software bug and apple needs to fix it. I don't think it is a hardware bug, that would really be bad especially for users in India where we had to pay the highest for getting an iPhone, a 16 gb costing almost 45k Indian rupees and be stuck with a dud and the phone behaves like Steve Jobs would say behaves like crap. My local weather varies from riyadh to come where in the fields of china, that would be a couple of thousand miles apart not a couple of miles. Now acting for iOS 5.1, trying out anything else is just a waste of time.

  • 200. Re: iPhone 4s location wrong... Why?
    Patrick G. Level 1 Level 1 (0 points)

    I had this issue. GPS worked, but if it couldn't get GPS it would fallback to LAC, which is like a 3-4km radius accuracy, which *****. It would never even try to use WiFi. Anyways, "Reset Network Settings" fixed this for me.

     

    Good luck.

  • 201. Re: iPhone 4s location wrong... Why?
    rphunte42 Level 1 Level 1 (10 points)

    If you are getting a location from WiFi, then it is very likely the local office of the WiFi service.  My WiFi always tells me I am in Arlington, which is about 15 miles from here, as does my cell phone bill.  It's a database issue.

  • 202. Re: iPhone 4s location wrong... Why?
    markfrompoole Level 1 Level 1 (0 points)

    I have the same problem and have a few observations.  I have a 4s 16gb.  Location was very accurate until 14 dec, when it put me in China and occasionally in Texas, I was in the south of England.  The location was shown as very stable.  I was inside and in a location where traditional gps would not work and I had no 3G coverage and no active wifi, so it appears that the location was being calculated by using the Edge/GPRS triangulation method.  When I moved outside and used a mapping app that allowed me to switch on the gps the phone correctly gave my position, but it took a few minutes to gain the position, this is understandable as the gps can be confused if it thinks it is in a different part of the world.  I then set up my iPad wifi only model, and connected this by tethering it to an other mobile (n97 mini) to the 3 mobile network, this gave me the right position, I then connected the iPhone to the same mobile and it continued to give the wrong location. I conclude that the iPhone prefers to use the edge/GPRS triangulation.  Where I get 3g the location is correct.  So it appears that the issue is the GPRS/edge system that is causing the problem.  Having read through the posts here I see that a lot users with this gross error are on the O2 network, which I am on as well.  I suspect that problem may because of a software change in either the O2 or apple's system about 3 days ago.  I have passed this onto apple through the issues reporting portal.  Hope this helps.

  • 203. Re: iPhone 4s location wrong... Why?
    denisefromnz Level 1 Level 1 (0 points)

    I haven't made any changes at all to my iPhone 4S yet apart from briefly this morning, my location has remained stable all day too.  Hmmmm ...

  • 204. Re: iPhone 4s location wrong... Why?
    denisefromnz Level 1 Level 1 (0 points)

    Ahh so a carrier update fixed it then?  Good.

  • 205. Re: iPhone 4s location wrong... Why?
    jmgg0025 Level 1 Level 1 (0 points)

    Same problem here.One time changing my location to Shangai.I´m in Seville (Spain)

  • 206. Re: iPhone 4s location wrong... Why?
    jmgg0025 Level 1 Level 1 (0 points)

    I have had this problem of incorrect time zone and incorrect location the 14th Dec and today.

  • 207. Re: iPhone 4s location wrong... Why?
    Kerrlos Level 1 Level 1 (0 points)

    Dont think its fixed yet.

     

    I tried the Maps App this morning and it worked perfectly. Seemed a lot faster too. Its been working fine all day until a few minutes ago when I noticed the time had shot forward 3 hours and I'm back in Baghdad.

     

    I have reported the issue with Apple feedback too.

  • 208. Re: iPhone 4s location wrong... Why?
    jmgg0025 Level 1 Level 1 (0 points)

    When my location changing to Shangai I tried sygic and it works fine but maps located in Shangai.

  • 209. Re: iPhone 4s location wrong... Why?
    denisefromnz Level 1 Level 1 (0 points)

    You're right. My location is back at Osh International Airport, Kyrgyzstan this morning sigh.

     

    I know of 2 other local 4s owners who have this same issue, but not one of the 4, 3Gs or 3G owners I know.

     

    Bah!  

1 12 13 14 15 16 Previous Next