3 Replies Latest reply: Nov 4, 2011 6:59 PM by red_menace
Saxman Level 2 Level 2 (175 points)

Despite my selecting what files I want to see in the results, and deselecting those I don't (like email messages), they always show up anyway! No big deal IF there weren't always so many more of them, than anything else. Anyone have an idea to get it to work correctly?  Calling Apple was useless, the woman answered all my issues with "well, you can try upgrading to Lion"!   Big help.....


iMac, Mac OS X (10.6.8), 21.5" ,3.2 GHz i3, 8GB Ram
  • baltwo Level 9 Level 9 (61,945 points)

    When I filed a bug report for this:

     

    I've set Spotlight's Search Results to not show webpages. However, webpages are depicted in Spotlight search windows in the Finder.

     

    I got this back:

     

    …the behavior you reported is as expected/designed.The spotlight preferences set in the prefpane only apply to the spotlight menu in the menubar, not in the finder.

     

    When I responded:

     

    Makes no sense whatsoever. How can selecting not to see webpage results, but seeing them be expected/designed?  If the former, it's a bold face lie; if the latter, then the selection needs removing from the show results panel.

     

    I got this back:

     

    I understand your frustration and can definitely see where you're coming from, but the fact of the matter is that Spotlight preferences no longer apply to the Finder search. They do, however, still apply to the Spotlight menu.

     

    Bottom line, then, is LIVE WITH IT.

  • Saxman Level 2 Level 2 (175 points)

    Ain't that something? Sheesh, Apple's customer support, & some other stuff, has sure taken a big slide downward, how absurd an explanation....

  • red_menace Level 6 Level 6 (14,845 points)

    It's been that way for as long as I can remember.  The Spotlight menu bar is a different search tool with different preferences - they both use the Spotlight database, but the Finder has its own set of search criteria that you set in a Finder window.