5 Replies Latest reply: Jul 28, 2015 1:29 AM by Erbsenroller
Scott Adelman Level 1 Level 1 (15 points)

I was wondering if someone could help with me with my ical feed from my icloud calendar. At work I use Lotus Notes 8.5 and it has the capability of letting me add a icalendar feed from a source. With some searching I found that on the right of the calendar list in icloud.com you can share your calendar. By creating a public calendar I can see a URL. This URL begins in webcal: and will not work in Lotus Notes. After reading I saw where you can just change the webcal: to http: and that should work. It does not. Whatever change I make I get a message saying that there are incorrect characters in the URL. The URL that I am given is:     webcal://p03-www.icloud.com/ca/subscribe/1/lWK58a2abm8l7Dh.................... (rest of long string of alpha numeric removed for security). The string ends in a numeric character. Any ideas how I can get this to work at all? Thanks in advance.


MacBook Pro, Mac OS X (10.7.2)
  • urthgurl Level 1 Level 1 (0 points)

    Change webcal:// to https:// and then create a cross-certificate when prompted.

  • LeftyInNC Level 1 Level 1 (0 points)

    Sorry for digging up an old thread -- This works as long as my iCloud calendar is Public.  Notes allows me to include username and pw -- but it doesn't seem to work when I restrict access.  Notes complains that it can't access the URL.  How do I get this to work without letting all y'all stalk my calendar?

  • ganymed Level 1 Level 1 (0 points)

    Any news on this? As LeftyInNC stated this works only if the calendar is public, no good idea e.g. for a family calendar.

     

    So how can an iCloud private calendar be at least viewed from Notes?

     

    Here is what I tested:

    I opened an iCloud calender to another iCloud user, and looked at the URL in the generated invitation mail.

    (I had to remove the redirect and replace these HTML characters like "%2F" to "/")
    so that the URL looked nice.

     

    Then I tried to include it to IBM Notes Social Edition (V9.0)

     

    Notes:

    Add a Calendar -> iCalendarFeed

    - A private calendar

    Label: my Icloud calendar

    - URL: https://www.icloud.com/calendar/share/#st=e&i<THISISUSERSPECIFIC

    (This URL shows the calendar when inserted into a browser window)

    - Username: myicloud@mybla.bla

    - Password: bla

     

    This leads to the error: calendar unavailable: The content of this URL does not conform to the icalendar parsing specification.

     

     

    If the calendar is Public the URL gets to:

    webcal://p04-calendarws.icloud.com/ca/subscribe/1/5z4r8gRyVU2IEQpIyxvvJ1K7ah_tv2 Pu-WJeR8iAxm1-rBLABLABLAJ4z--dt6EIdAySI

     

    and if you replace webcal with https in Notes it works, so you can see the iCloud entries.

     

    So the problem is solved for public calendars, but what about private?

  • BenztownF Level 1 Level 1 (0 points)

    Hello,

     

    is there a chance for a solution to this topic as I face the same problem. I would also be fine with viewing only-capability of a private ical-calendar in Notes. Thank you.

  • Erbsenroller Level 1 Level 1 (0 points)

    I have the same issue. Please Apple-Team help!

     

    A workaround would be via Google-Calendar but I haven't found a way to 'Share' or synchronize my iCloud-Calendar with Google.