Previous 1 2 Next 29 Replies Latest reply: Jun 14, 2015 2:59 PM by x_Caitlyn_x
rosswillsimpson Level 1 Level 1 (0 points)

Over the past few days I have realised that no sound comes from my iPhone 4S, whether it is the sound from an app, the noise it makes when you plug it into a power suply or a ringtone when I get a call, To get the sound back, I have to restart my phone a few times which is very annoying as it takes it's time! I have had to do this twice today and wondered if anyone is experiencing this problem or has a soulution or what not, thanks you!

 

iPhone 4S - Black 32gb

iOS 5.0

O2 UK

 

Ross


iPhone 4S, iOS 5
  • kadec Level 1 Level 1 (0 points)

    I am having the same problem with my iphone 4s.  My phone rings when I get a call but that is the only reliable sound.  Text messages and other notifications do not make sounds most of the time.  When I restart the phone sound comes back temporarily. I have checked all the sound settings and I know the button on the side is not switched to silent. 

  • rosswillsimpson Level 1 Level 1 (0 points)

    Exactly the same but not even my ringtone works! help anyone?!

  • NeverHelpedByApple Level 1 Level 1 (0 points)

    I am having the same problem.

  • Jingapple Level 1 Level 1 (0 points)

    I have the same problem!! Can anyone solve it??

  • wcs2 Level 1 Level 1 (0 points)

    currently I have no sound for music or video.  Otherwise sound is ok.

     

    But..since day 1 the 4s would not shut down - go through the steps to shut down, the screen goes black for 5-6 seconds and then the phone restarts!

     

    And to make it interesting - I have sound when I have the restart problem.  No sound when  it shuts down properly.  Currently no sound!

     

    Also 5.1 did not help the battery life.

     

    Waiting for BB to get next shipment for replacement

  • John Sanders1 Level 1 Level 1 (15 points)

    I'm having the same problem with a 4S purchased last week.  No sound when trying to play music.

  • jms465 Level 1 Level 1 (0 points)

    My phone fell in a very small quantity of snow a couple of hours ago. I kept getting the "This accessory is not optimised for this iPhone" (you may experience noise caused by mobile interference and a decrease in mobile signal strenght) message error.

     

    I restarted my phone by pressing the On/Off button and the home button at the same time for a couple of seconds until the screen turned black and the white apple logo came up. After I did this, I noticed I didn't get any sound through the speakers. I could hear music/sounds with my earphones plugged-in but not without having them pluged-in (not even the clicks from the lock screen). The only sound I could hear without the earphones was the ringer when I would receive phone calls.

     

    I searched on the internet for a fix and none of the solutions worked for me like cleaning the headphone jack with a Q-tip, cleaning the doc connector with tissue or paper, inserting a needle in the top microphone whole etc... until I found an easy solution:

     

    1 - Plug-in your earphones

    2 - Open the "ipod/itunes" app on your phone

    3 - Play music

    4 - Unplug your earphones

     

    5 - Repeat these 4 steps about 3 or 4 times on a row. If after doing this you don't hear sound, don't freak out! It's normal. Don't forget that your iphone automatically pauses your music when you suddently unplug your earphones while the music is still running. Just press the "PLAY" button and voila!

     

    I hope this helps!

     

    Jaqueline

  • wcs2 Level 1 Level 1 (0 points)

    Jaqueline

     

    Gave it a try - still no sound.

     

    Found one thread with same problem - https://discussions.apple.com/message/16583703#16583703

     

    Cleaning didn't work either.

     

    Disappointed at Apple -  phone, IOS, lack of stock in stores....etc.

     

    Forgot to mention re battery life that mine does not charge to 100% best I get is 92%

  • Calihagen Girl Level 1 Level 1 (0 points)

    I had the exact same issue. No sound on my iPhone 4s except for incoming calls. I have had an iPhone for a loooong time and I ofcourse checked and made sure the mute button was off. I swiped it, reset - you name it- nothing. So I  made an appointment through the "apple store" app for the following day. And they didn't have ANY clue as to what the problem was and immediately switched it to a new one. Sounds like they might have an issue on hand with the volume...

  • John Sanders1 Level 1 Level 1 (15 points)

    I finally got my sound back after trying practically everything.  What worked for me was re-syncing my iPhone 4S to my iTunes music library TWICE.   I've had every iPhone model from the start and have used iTunes with iPods and iPhones and never had this happen.  Strange....but it worked.

  • scousky Level 1 Level 1 (0 points)

    https://discussions.apple.com/message/16968699#16968699

     

    TRY CLEANING THE DOCKING PART OF IPHONE WITH A TOOTHBRUSH!!..was pulling my hair out but it worked a treat!

     

    (thanks tankie)

  • wvisbeen Level 1 Level 1 (0 points)

    YES!!!!

    This worked for me!

    Thanks!

     

    Wim

  • raja1 Level 1 Level 1 (0 points)

    I got my iPhone 4s on Nov 19, 2011. 2 days ago the sound stopped working on videos, you tube, apps and keyboard clicking. When you manually use the volume buttons on the side, it read "ringer" but there were no bars. And when I checked the volme in the settings, I could see the volume buttons wouldn't affect the sound despite "buttons on". It would still ring for alerts and phone calls. I didn't have it in a dock.

     

    I searched forums for answers. When I rebooted, the first time, the sound came back - for a brief time. Rebooting again didn't bring the sound back the other times. I saw where Verizon told someone to switch off the Bluetooth and Wifi, then back on and it worked for some. I didn't try that b/c my husband wasn't home and I didn't know how to get back onto the network. But it worked for some who tried it. I have an old MacBookPro (2006) and I can't sync my iphone with iTunes, so that was not an option for me. I also read where someone connected to apple tv with his iphone and the sound returned. It just so happens my husband bought one last week and he was showing me how to connect to the apple tv using the ipad and his iphone. The apple tv is on a different wifi network. When the iphone was switched to the apple tv network I heard the keyboard clicking again. I told my husband that the sound works again. He didn't believe me b/c it didn't make sense that doing that would fix it. But it did. Now I know most people won't have an apple tv, but try switching the wifi or switching it off for a bit then going back to the wifi. Doesn't make sense that that would fix it, but it worked for me.

  • jeweles311 Level 1 Level 1 (0 points)

    I'm having similar issues.  Sometimes no sound on outgoing calls.  And now no ringtone sounds, alert sounds, music, etc.  I've tried several things, but it is still not working.

     

    When I try to adjust the sound level on the side of the phone, there is no bar to adjust on the screen.

     

    What sounds do work?  Alarm, music works only with headphones.

     

    So frustated!!!!

Previous 1 2 Next