5 Replies Latest reply: Nov 14, 2011 5:56 PM by elikness
mynameisearl Level 1 Level 1 (5 points)

Hi,

 

So I have been working on an iMovie project continuously for a number of years now. Never had an issue really - all it is is an uncomplicated mix of videos, photo's, transitions and music - basicly my life in one movie covering 12 years.

 

There is the background - so today - I went to add some new photo's and clips from events - again no issues but then out of no where strange things are happening to the last few photo's I added.

 

Basicly if I go over one of the photo's instead of the photo being displayed I get part of one of the movie clips. Very strange, rolling over the photo in the timeline plays part of a movie clip from somewhere else in the timeline - it even has the ken burns effect applied.

 

Some of the photo's are just black - but they are there in the timeline.

 

All very odd - been searching everywhere on the web to no avail - the only thing that comes close is several comments about clearing cache files - which I can not find - or using Onyx to clean things up - which I did but it did not change anything.

 

Thanks for your help in advance!

 

iMovie11, OS X Lion (Fully Updated)

  • mynameisearl Level 1 Level 1 (5 points)

    Ok - latest update on this, I'm now not convinced this is actually an issue with iMovie 11 but a problem with iPhoto.

     

    What I have discovered is that I have an event with circa 500 photo's in - what ever photo I use from this event seems to behave oddly in the iMovie timeline - as per my description above. However - if I go into iPhoto and edit a photo in this event, do something to force a save, then use this photo it works fine.

     

    I'm not having the issue with any other photo's or events. They only work around I can find is as above. I have tried creating a new event and moving all the photo's in there but the behaviour is still the same.

     

    Any idea's most welcome.

  • mynameisearl Level 1 Level 1 (5 points)

    Ok - for anyone interested, after doing a library rebuild on iPhoto which did not resolve the issue the only thing I have found is a work round. As mentioned above if I add one of the photo's from the one event that appears to be the issue it does not display correctly in the timeline. If I go into iPhoto and edit the said photo, a simple crop or straighten, the photo is saved and I can then insert into the timeline with no issues. Any photo's in the event I don't touch still seem to have the problem but I guess at least I have a work around.

     

    Hope that's of some use to others.

  • SonofWayne Level 1 Level 1 (5 points)

    Hey,

     

    I've been having issues with photo in iMove '11 that so far appear to be resolved by clearing the cache.

     

    I did create a test project with photos both before and after emptying the cache that  worked fine.

    Yet as I am sure you know, this problem is often not consistent!

     

    Here are the steps and how to find the cache!

     

    1 Open finder

     

    2)on the left of finder window  click on "home" or your user name in finder near the icon of a house.

     

    3) open the library

     

    4) drag the ENTIRE cache folder to the trash (no need to find any specific cache folders)

     

    5) quitting all apps/software excect Finder

     

    6) Restarting the computer

     

    7) Empty tash (optional)

     

    8) reopen iMovie

     

     

    Apple Phone support told me that if the problem continues after this process that it may remain only in my porject and that  it could be might be that I need to manually recreate my entire project.

  • mynameisearl Level 1 Level 1 (5 points)

    Hi Sonofwayne

     

    Thanks for the tip - I'd read similar on the web also but for the life of me I can not find my cache folder. Very odd - do everything you say but I just dont have a library in my user folder.

  • elikness Level 4 Level 4 (2,635 points)

    If you want to find the Library, look no further than these directions:

     

    1. Go to the Desktop
    2. Hold down the Option key
    3. Click on the Go Menu
    4. Choose Library
    5. Look for Caches Folder
    6. Follow SonofWayne's directions