Previous 1 2 3 4 Next 50 Replies Latest reply: Dec 25, 2015 8:33 AM by raffib
Tony Brave Level 3 (635 points)

Lion 10.7.2. When I plug a headphone into jack it does not shut of speakers and sound does not go to headphone. Went to prefs set output to internal

  • TeenTitan Level 4 (2,410 points)

    Hi Tony,


    Have you verified the speakers are plugged into the headphone jack and not the input Jack?

    Have you tried a different set of headphones?

    Have you tried Restarting the computer?

    Have you tried a SMC Reset?

    Have you tried a NVRAM Reset?

  • Lodoss Level 1 (10 points)



         Make sure the jack is securely put into the headphone input. Dont be affraid to push it in all the way. I thought my headphone was in all the way and found that you have to almost force it in and hear the click.

  • earthgirl2 Level 1 (5 points)

    my headphones aren't working either!  I contacted Apple Support and they insisted it was a hardware issue - and it's SUPER FRUSTRATING because this only happened after I upgraded to Lion.


    I've searched online and several others have this problem - some have fixed it by changing their output to 32-bit Float in the Audio MIDI Setup.


    But that solution does not work for me.


    Does ANYONE have a clue?


    Apple Support wants me to pay to have my computer shipped off somewhere and "fix" my hardware when that's NOT THE ISSUE.


    This is so frustrating. I'm beginning to hate Apple, and their "geniuses."   I should have never updgraded ....   as a student who studies in the library, headphones are crucial! And now I'm SOL because Apple refuses to acknowledge they have a serious software issue.     

  • TeenTitan Level 4 (2,410 points)

    Did you try the troubleshooting steps I asked about? Do you have access to a Genius Bar at an Apple Store? It costs nothing to have a genius look at the computer.

  • earthgirl2 Level 1 (5 points)

    Yes, tried all those steps.


    I've talked to apple support online. 


    Apple "geniuses" refuse to acknowledge that this is a Lion issue. Yet, there are SEVERAL posts on this website alone that have audio issues after a Lion upgrade. 


    Basically my solutions, according to Apple "geniuses," are: 

    1. Pay $$$ to get hardware fixed. Be without a computer for two weeks. (Even though it's not a hardware issue).

    2. Revert back to Snow Leopard. Spend time removing all your files and apps off your computer, and then spend hours putting everything back.


    I have to choose option two, I guess. I'm not going to pay for something that is NOT A HARDWARE issue. And since I have to revert back to Snow Leopard,  I asked Apple for a refund on Lion. I'm going to have to deal with this after my finals.  I'll let you people know what the outcome was.


    I'm seriously, seriously upset with Apple refusing to acknowledge they put out a faulty product. It's really upsetting. It's even more upsetting because they pretend to be the "good" guys of the computer world. And really, they're just like everyone else. THEY CAN'T EVEN ADMIT that there's a problem! They immediately say it's a hardware issue  - and they refuse to acknowledge the hundreds of posts all complaining about the same issue.



  • earthgirl2 Level 1 (5 points)

    Further proof this is not a hardware issue....



    I fixed the problem.  I found a solution on one of the MANY discussions about the headphone jack failing after a Lion upgrade.


    Under Sys Pref> Sound > Click on Internal speakers.  Then at the bottom set audio port for "sound output."


    And here is the original post w/ that solution: 


    That simple. I wonder why the "Geniuses" refused to check my sound/audio options.... I guess they were so brilliantly trained to blame everything on hardware instead of saying "I dont know, let me do some research for you."

  • TeenTitan Level 4 (2,410 points)

    I'm glad you found a solution. It might be worth reporting the issue to Apple as a bug. You could do so via Apple's Feedback page.

  • assassinave Level 1 (0 points)

    Well the question to ask is what is up with the software? I noticed this problem a few weeks ago when I was syncing some things with Spotify. I went to turn down the overall system volume and it wouldn't work unless I turned down the application volume. After changing some things in Sound, i got it working again.


    BTW, I'm running Snow Leopard.


    Prior to that incident I could plug in my headphones and speakers without incident. The system would recognize it and pipe the sound through either of those and eliminate the internal speakers.


    Now when I listen to music and unplug the headphones, the sound does not revert back to the internal speakers, unless you use the solution above and switch the "Use audio port for". (Though in doing some basic testing I got it to work smoothly again, at least once).


    I've only notice it with third-party apps, in particular Spotify and Rdio. They may be the culprits perhaps?


    Long story short is that the system has and should continue to understand when headphones are inserted, switch to that and switch back when they are not. This is what seems to be happening to most people.

  • iMilletos Level 1 (0 points)

    i had the same problem. this is not a glitch!

    i made a video on how to fix this:

  • BethLeianne Level 1 (0 points)

    I am furious! Not only does my headphone jack doesn't work, but my usb ports got messed up too!  Shame on Mac!  ;(    Ive tried everything on this list, so far no luck, about to do resets.  ;(

  • pmstrain Level 1 (0 points)

    I had this same issue - no sound from my headphones.  Hadn't taken the time to really look into it, but then it got annoying and I decided to.  1. I found I had not pushed the connection in far enough.  If the sound continues through the computer, then it seems that is step one - keep pushing the plug until the computer no longer has sound coming out the internal speakers.  2.  At that point I opened up PREFERENCES>SOUND, OUTPUT tab and found the Headphones volumes was at 0.  I raised up the volume and violá, sound.  I hope you all have as much ease solving this as I did. If not - sorry.

  • vinadium Level 1 (5 points)

    There is some confusion here. I think it is important to note which version/year you have. Some of the earlier versions have the option of selecting your audio output. In my case (2011 macbook pro) that option is run automatically when you plug your headphone in. I have to reset the laptop with the headphones plugged in for the output to switch to 'Headphones'. There might be some root priviledge that is required to do the switch and the problem may be a conflict between the logged in user password and the root password. Make sure they are the same and reset your PRAM/NVRAM. That seems to have fixed the issue in my case. Again, this is only for the case where you have no option in the sound utilities panel to select Audio output.

  • Bart1977 Level 2 (285 points)

    For all others checking this thread, a possible workaround would be to use a Bluetooth headset.


    I'm very happy with my Creative WP-300


    (first link I found, not affiliated).

  • Vin1998 Level 1 (0 points)

    To pmstrain - Thanks!


    I tried what you said and when I plugged in my speakers I found the volume was set to mute.  It happend, for some reason, right after I set up my bluetooth headphones. Everything is working now.

Previous 1 2 3 4 Next