Previous 1 2 Next 19 Replies Latest reply: Nov 16, 2011 7:41 PM by Pondini
Ron Voss Level 1 Level 1

Immediately after upgrading from 10.6.8 to 10.7.2, my existing Time Machine backup to external USB began to fail with this message.  Really, nothing else changed.  Is there no solution?  I've tried all the suggestions I see, nothing helps.  Please don't respond unless you have a real fix or work-around for getting USB drives to accept Time Machine backups again.  It does no good to post that you're not having problems; MANY of us are!

 

We are 25-year Mac users, both former Apple employees, love Apple and Mac, but Lion/iOS5 has been a disaster with so many things failing.  Even an Apple engineer I know won't upgrade his home system until serious problems are ironed out.  Usually the 10.x.1 release fixes the worst problems, but we're already at 10.7.2 .


iMac, Mac OS X (10.7.2)
Solved by Pondini on Nov 7, 2011 10:10 PM Solved
Reply by Pondini on Nov 8, 2011 12:36 PM Helpful

Tell Apple all about it here:  http://www.apple.com/feedback/timemachine.html

All replies

  • Pondini Level 8 Level 8
  • Ron Voss Level 1 Level 1

    Thank you!  http://web.me.com/pondini/Time_Machine/A4.html did the trick!

     

    So now I wonder why Apple doesn't do this automatically after updating to Lion makes Time Machine fail this way.

  • Pondini Level 8 Level 8

    Great!  Glad it's sorted out.

     

    Like a lot of other things, that doesn't happen very often.  In your case, the preferences file was apparently damaged; if it can't be read properly, it would be rather difficult for Apple to automate replacing it.  In other cases, of course, the backups themselves may be damaged.

  • Ron Voss Level 1 Level 1

    Well, my case sounded like the other vanilla cases, where Time Machine was working perfectly just before the upgrade to Lion, and then failed due to upgrading.  If the preferences file was damaged, the Lion upgrade caused the damage that made it fail, or is not prepared to handle all versions of a working 10.6.8 preferences file.  Apple should do exactly what your excellent instructions said to do: delete the preferences file and put up an alert that tells us to reconfigure Time Machine; that would be far better that doing nothing and giving a useless error message.  It is so unlike Apple for it to behave like it does now.  I hope Apple doesn't lose its way, lose Steve's concern for the user.

  • Pondini Level 8 Level 8

    Tell Apple all about it here:  http://www.apple.com/feedback/timemachine.html

  • Ron Voss Level 1 Level 1

    Thanks, good idea, done!

  • AnnieAnnieAnnie Level 1 Level 1

    I had success with http://web.me.com/pondini/Time_Machine/A4.html too.  Thank you!

  • Ron Voss Level 1 Level 1

    Sadly, after a few successful backups, the same old folder message came roaring back. 

     

    Console says:

     

    11/8/11 11:39:48.506 PM com.apple.backupd: Starting standard backup

    11/8/11 11:39:48.632 PM com.apple.backupd: Backing up to: /Volumes/VERBATIM BU/Backups.backupdb

    11/8/11 11:39:49.456 PM com.apple.backupd: 2011-11-08 23:39:49.431 FindSystemFiles[97145:f07] Looking for system packages

    11/8/11 11:39:58.046 PM com.apple.backupd: 2011-11-08 23:39:58.045 FindSystemFiles[97145:f07] Using system path cache v`56'.

    11/8/11 11:39:58.454 PM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/VERBATIM BU/Backups.backupdb/RonViMac3h size:37

    11/8/11 11:39:58.501 PM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/VERBATIM BU/Backups.backupdb/RonViMac3h size:37

    11/8/11 11:40:08.530 PM com.apple.backupd: Backup failed with error: 2

     

     

    Google says that lots of people are having this problem after upgrading to Lion.  Clearly not everyone, but those of us HAVING the Lion problem must have something in common!

  • Pondini Level 8 Level 8

    Ron Voss wrote:

    . . .

    11/8/11 11:39:58.454 PM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/VERBATIM BU/Backups.backupdb/RonViMac3h size:37

    Similar, but not the same.  A problem setting an extended attribute to the folder represening your computer on the backup drive.

     

    How old is it? 

     

    It doesn't sound like the connection/cables, but that's possible.  Make sure all connections are snug and secure;  try different port(s), cable(s), and different combinations of the two (a plug that works fine in one port may not make good contact in another).

     

    Do you have another drive you can try?

  • Ron Voss Level 1 Level 1

    I'm sorry, but I can't get beyond the fact TM worked perfectly in 10.6.8 the hour before I upgraded to 10.7.2, and failed within two hours of upgrading, nor that the same thing happened to others in the same way.  I have no reason to think this failure is any different than the previous "folder" error TM threw; the symptom is identical.

  • Pondini Level 8 Level 8

    I agree.  It sounds like a problem with the drive, port, or cable.

  • vossron Level 1 Level 1

    A problem that multiple users developed  just at the moment they upgraded to Lion?

  • Pondini Level 8 Level 8

    Considering how many folks upgrade (Apple sold a million copies on day1), yes, it's possible a drive that was about to fail . . . did.

     

    Also, for some reason, Time Machine backups are re-indexed after the upgrade to Lion - putting that much extra stress on the drive.  If it was marginal before . . .

     

    And it's far easier to rule out than reinstalling Lion.

     

    What's your suggestion?

  • Ron Voss Level 1 Level 1

    Disk Utility repeatedly finds nothing wrong with the external disk hardware, and after running it, TM succeeds at least once (which I had previously had found before trying your Preferences suggestion), and then fails predictably.

     

    I think there is a class of users (with something as yet unknown in common) whose disk contents (internal or external) are causing a change in Lion to trigger this error.  I think we'll eventually get a fix from Apple, or someone will find (and post!) a workaround that removes the trigger.  E.g., I have not yet repaired my internal HD; perhaps Lion is more sensitive to corruption than was SL, and the corruption is being written out by TM, but Lion TM can then not handle it at the next backup.  Maybe SL caused corruption of the backup, and SL could handle it but Lion cannot, and the problem would go away if I would delete the old backup completely (I'd rather not!). 

     

    I think scenarios like this are more likely than a hardware problem.

Previous 1 2 Next