Previous 1 2 Next 22 Replies Latest reply: Jun 30, 2014 3:46 AM by Koolugo Go to original post
  • seforajanel Level 1 Level 1 (0 points)

    Thank you Game Center!!! Whew! I had tried everything else!!

  • sadrobot Level 1 Level 1 (0 points)

    Thank you for this!


    I had some stuck downloads in the iTunes download queue and removing them resolved the issue.

  • oertorer Level 1 Level 1 (0 points)

    I have been reading many postings related to this issue!


    In my case, there is no "stuck podcast" or an option to remove the app (so i can't see X).


    The problem started when I tried to update 2 of my apps. I mistyped my apple password and they gone to a waiting status..


    Since then:


    - I downloaded and updated other apps without any problems.

    - I shut down and hard resetted my iphone many times.


    But those 2 apps are still waiting.


    Well! I have not tried connecting it to my computer, yet. But I think there should be another solution. Otherwise, this is a big bug in iOS.

  • mdmoran Level 1 Level 1 (0 points)

    Thanks to all the great advice. My problem was a little different, so I thought I'd share what worked for me:


    * My problem was a stuck APP update (NOT an iTunes download).

    * I COULD NOT just delete the app, because it had a spreadsheet that I had not backed up anywhere

    * I COULD NOT restore from backup, because the backup was corrupted.


    However, I thought if I could kill the APP download, it might work like the solutions proposed by others.(Thanks.)


    Here is the only way I found to do it:


    * I downloaded a trial version of the DiskAid application for the Mac.

    * It did NOT allow me to transfer the files, because the app (Numbers) apparently does not store files that way unless you explicity say you want to copy the file to iTunes

    * HOWEVER, I went into the "File System --> "Media", then "Downloads", and deleted everything in the "Downloads" folder.

    * Shut down the iPhone and when I started up again, the Numbers app was no longer "waiting". I could get my file backed up and try again!






    P.S. Sorry for all the emoticons. I've been worrying about this file for 2 days!

  • blake_uk Level 1 Level 1 (0 points)

    I had the same problem No stuck downloads etc


    Simply used the 'Reset All Settings' option in 'Settings' and apps now download and when prompted on the restart of the phone I set up as new iPhone.


    Tested and works.


    Try it

  • Ryan Manno Level 1 Level 1 (0 points)

    I encountered the same frustrating problem this morning and tried most of the suggestions listed here (and in other forums). Oddly enough, the fix happened on its own. After roughly 2 hours, my Apple ID sign-in box just reappeared and asked for my password -- the way it normally pops up when installing or downloading. I know it's not practical or an actual, traceable solution.. but my advice would be to wait it out for a few hours and see if the issue will resolve itself. My best guess is that there was an Apple / app store server issue, causing slow or no activity. Good luck!

  • bigbadrobbo Level 1 Level 1 (0 points)

    I had this same problem. I signed out of my Apple ID on my iPad, (settings, store) and then signed back in straight away. That fixed it for me.

  • Koolugo Level 1 Level 1 (0 points)

    Numbers in my ipad is also greyed and labeled waiting. I can't delete it of move it. But i know that it is installed because when I access the app store and go to purchased it is there and has the open sign same as those other apps installed. When I tap open the app also open.



    I tried restarting the ipad (off and on) but nothings works.

    It still remains in waiting.

    * FIXED IT

    - I tried to download Numbers in my MAC itunes app store. Then suddenly its label became "downloaded" then I synced it. When I went back on my ipad the waiting label is gone.


    Now I am having difficulty downloading Keynote. It seems that iwork apps are buggy (maybe because they offered it free???) Microsoft Office worked flawless on my ipad... =)

Previous 1 2 Next