11 Replies Latest reply: Apr 19, 2014 4:29 PM by Cplang94 Branched to a new discussion.
subfish Level 1 Level 1 (0 points)

Just set up my new Apple TV which I'm using in conjunction with OSX 10.6.8 / iTunes 10.5, and the menu screen only shows the Movie, Internet, Computers & Settings options, no sign of TV Shows or Music. I have Home Sharing selected in iTunes and can stream music and video from both my Mac and iPhone, but can't seem to access my library from the Apple TV menu. Why? Thanks.


MacBook Pro, Mac OS X (10.6.8)
  • Winston Churchill Level 10 Level 10 (84,855 points)

    The TV show menu is only available in locations that have TV Shows, are you in such a location and if so is your iTunes Store location set correctly. There is no Music menu on the Apple TV.

     

    Have you turned homesharing on, on the Apple TV.

  • SeanMcCoy Level 1 Level 1 (0 points)

    I am experiencing the same issue...

     

    I have an Apple TV 2, with latest firmware was working fine.  Today when I turned it on the TV, Music and Photo menus were gone.

     

    I have reset it, restored it, rebooted it, and still no change.

     

    As there are some smartass coments sure to be fired out... I am in a region (Canada) that has TV shows.  I have turned on and off the home sharing options both on the Apple TV and my macbook... Still no change.

     

    This is the first Apple product that I can not seem to find a fix for.

     

    Someone please help!

  • Axlaiden Level 1 Level 1 (0 points)

    I too am having this issue, and from Canada. Seems there are a lot of issues with this popping up in Canada.

  • watnotte Level 1 Level 1 (0 points)

    I have an Apple TV 1 and have always had a "TV Shows" menu - I live in Canada.  I assumed that it was just the Apple TV 2 that didn't allow for TV Shows - either because there was no where to store them on the device and rentals were never supported. 

     

    However, a couple of days ago, I lost all the menu items under "TV Shows" except for "My TV Shows".  In other words, I can't browse for new shows or do searches etc. but I can still watch the ones that I have already purchased.  I can also buy them on my desktop and then watch them on the Apple TV.

     

    I'm a little upset that there's no official word on this.  It seems my Apple TV, which was working perfectly fine, has been caught up in whatever "failed update" mess has occurred.  I'd like to know the official story and, more importantly, when I might expect to get my original functionality back.

  • studiogalatea Level 1 Level 1 (0 points)

    The official word on this is: http://support.apple.com/kb/TA25193?viewlocale=en_US

    Modified last on Feb 20, 2012 as of March 31, 2012.

     

    It mentions after upgrading to Apple TV software 2.0 that those menu items may disappear.

    The solution as mentioned above in the previous responses is what is cited in the KB link.

     

    I live in Tokyo and have been using my US based account to view MLB and NHL Game Center. And much to my surprise when the menu items disappeared today, I was pretty bummed. No hockey, no baseball??!!?! As everything is tied to my US Store account, I didn't want have to deal with Japan iTunes store account, so I pulled the plug on my Apple TV2 and the menu returned.

     

    Try at own risk. Good luck.

  • DougMcLean Level 1 Level 1 (0 points)

    I've just had similar things hapen with my Apple TV (2). Suddenly every menu option other than Computer and Settings has disappeared. Until today everything seemed fine. Again, in Canada

  • StephenNg Level 1 Level 1 (0 points)

    Like DougMcLean, same thing happened to me. With every other version of iOS in my AppleTV 2, I had YouTube, Radio etc items in the menu. Now after updating to the latest version everything is gone except for Computers and Settings. FYI, I am in Malaysia where the AppleTV is not sold. I got mine in Oz.

     

    I tried Settings to see if this is simply a setup issue, but there is nothing that I can see that relates to this problem.

     

    I have not tried studiogalatea's solution. By pulling the plug, do you mean that I simply remove power?

     

    Still I wonder what Apple is doing? Even if I am not able to buy movies in Malaysia (I guess its because of IP rights and piracy) I don't see why Apple has to cripple the device and only allow me to share my computer's content and nothing else! This is quite ridiculous. I can view anything on YouTube, Internet Radio etc on my computer anyway, since these sites do not prevent anyone in the world from viewing. So has Apple become everyone's conscience?

  • studiogalatea Level 1 Level 1 (0 points)

    Yes, Stephen. I did a hard shutdown by killing the power. After repowering, it came back. Good luck!

  • WinwinLau Level 1 Level 1 (0 points)

    Stephen, Select General/Apple Store: change location to USA. All will come back.

  • DougMcLean Level 1 Level 1 (0 points)

    I have also tried setting the store location to USA and that worked initially. Then changed it back to Canada and it still seemed to be okay, but a while later everything diappeared again.

     

    My problem now looks to be solved after I went into my wireless router and went to "Advanced Settings" of Wireless setup. I disabled MPDU Aggregation and enabled MSDU Aggregation. Everything came back and has not disappeared since then.

     

    Whether this was the solution or not I don't know. I have not had the problem occur since doing that.

     

    Don't know whether that will help anyone or why it would work, but it appears to have for me. I figured I had nothing to lose and could always just change the setting back if something else went wrong. So far so good...

     

    DMC

  • Cplang94 Level 1 Level 1 (0 points)

    I have the original Apple TV. I have kept it up to date. Just recently I tried to search for a movie and the search feature disappeared.  After looking at this forum I reset the box to its original settings, reconnected, updated after it asked me to and still I have no search function.  I also realize I have no search function on the TV shows menu either.  Any help would be appreciated..