Previous 1 2 Next 15 Replies Latest reply: Jul 1, 2015 4:45 PM by fixleg
Nanotechnology Level 1 Level 1 (25 points)

I've had this issue for a while now, and  I'm running the latest version of snow leopard on my 15'' macbook pro early 2011.  When I start up my computer I would have this problem where if I don't have my ethernet cable plugged in when it first starts up it won't be recognized.  So if I go to system preferences and go to network it'll say "not connected" even though my ethernet cable is connected. 

 

This problem would only resolve if I restart the computer (I've tried logging out and into another account, etc. but it still didn't work).  I've also tried using the diagnostics assistant but it wouldn't help.  This problem would also occur say if I unplugged my ethernet cable for a bit and plugged it back in.  The computer would say it is still disconnected even though it is not.  During this whole time I would have no problem accessing the internet from wifi, unless I turn it off (then I would have no internet connection even with the ethernet cable plugged in).  I'm also wondering whether this is a software/hardware problem or has to do with the internet  modem.


Macbook Pro (Early 2011), Mac OS X (10.6.8)
  • kostby Level 4 Level 4 (2,790 points)

    Welcome to the Apple Support Communities.

     

    Simple questions first:

    Have you tried another Ethernet cable?

    Have you tried connecting (the same cable) to another port on your Ethernet switch or router?

    Have you tried another computer with a wired Ethernet port using the same cable and the same port? (in case your Ethernet port is defective or damaged).

     

    Since your Mac less than a year old, a true hardware defect would still be covered under Applecare.

  • Don Archibald Level 10 Level 10 (101,285 points)
    When I start up my computer I would have this problem where if I don't have my ethernet cable plugged in when it first starts up it won't be recognized.

     

    That's normal with many, if not most, Mac models. It is not a hardware or software problem; it is in the design.

     

    The way it works is that if there is no live (powered on and ready) device detected by the Mac as being connected via ethernet during startup, the ethernet bus will be turned off.

     

    I don't know why it is designed that way.

     

    The result is that ethernet is not 'hot pluggable', at least not directly. If you have an intermediate ethernet hub, switch, or router in the connection scheme, then you can connect a device to the hub/switch/router after the Mac has been booted and have it be recognized. This is, of course, dependent upon the hub/switch/router having been on and warmed up and connected to the Mac before booting the Mac.

     

    WiFi uses a different port/bus, so is not subject to this restriction. Ditto for firewire and USB, both of which are 'hot pluggable' by design.

  • Nanotechnology Level 1 Level 1 (25 points)

    Though the thing I'm wondering about is how long it takes for the computer to recognize the ethernet cable after it's been plugged in.  With USB, when I plug it in it starts up, but at times when I plug in the ethernet cable nothing happens until I restart the computer.

     

    Thanks for the suggestions, if I have some spare time I might drop by the genius bar.   I will post updates if I encounter any.

  • Nanotechnology Level 1 Level 1 (25 points)

    I went to the Apple store today since I had time and the genius simply deleted the preferences for the locations I had accumulated in the network panel and reset PRAM.  Works fine now, thanks for all the help.  I was glad it didn't have to do with the actual ethernet adapter.

  • MikeDsr Level 1 Level 1 (10 points)

    RE: "simply deleted the preferences for the locations I had accumulated in the network panel and reset PRAM.  "

     

    Can we do that ourselves (and if so, how) or does it have to be done by a "genius" ?

  • kostby Level 4 Level 4 (2,790 points)

    Not sure what you're trying to accomplish.

     

    Resetting PRAM is easy to do yourself:

    http://support.apple.com/kb/ht1379

     

     

    Even if you aren't comfortable adding/editing/deleting the network locations, it's fine to LOOK at them.

     

    Deleting Network preference locations:

    (I'm on OS X 10.6 'Snow Leopard', so your screens might look a bit different)

     

    Start at , System Preferences, Internet & Wireless, Network

     

    Click on the 'Location' up/down button at the top to reveal a pop-up list...

    (full names obscured for security - yes I have MANY custom locations defined)

    The 'active' location profile is the one with the check-mark at the left.

    1Screen shot 2012-03-30 at 11.20.43 AM.png

    and select Edit Locations at the bottom of the list.

    2Screen shot 2012-03-30 at 11.21.10 AM.png

     

    Click the - (minus) sign to delete Locations, and the 'Done' button when you are finished, to confirm the changes/edits/deletions.

    The + (plus) sign adds new Locations, and the 'Gear' lets you duplicate or rename an existing Location.

    3Screen shot 2012-03-30 at 11.22.18 AM.png

  • MikeDsr Level 1 Level 1 (10 points)

    OK thanks.. I'm having the same issue that I've seen here and on threads all over the place.. Using my Macbook, the Ethernet connection is useless, even though it says it's connected..

     

    The same ethernet cable works in every other pc in the house, only the macbook has the issue.

     

    Seems that, from above:

    "I went to the Apple store today since I had time and the genius simply deleted the preferences for the locations I had accumulated in the network panel and reset PRAM.  Works fine now, thanks for all the help.  I was glad it didn't have to do with the actual ethernet adapter."

     

    resovled it.. so I was just wondering how we can do that without going to see a "genius"..

  • kostby Level 4 Level 4 (2,790 points)

    So you've determined that it's not likely caused by an Ethernet cable problem, since the same cable works on other computers.

     

    If you have not already visited these pages, here are Apple support guides to network troubleshooting:

    http://support.apple.com/kb/HT1714

    http://support.apple.com/kb/TS1317

     

    What does Network Preference diagnostics show?

     

    , System Preferences, Internet and Wireless, Network, select Ethernet from the left column, and click the Assist Me button at the bottom. Then select the Diagnostics button.

    Screen shot 2012-03-30 at 5.22.17 PM.png

    After you've reset the PRAM and edited Ethernet network Location preferences without resolving the issue, or if this seems beyond your level of comfort or expertise, then it's time to visit a Genius.

     

    Message was edited by: kostby

  • Jay in Detroit Level 1 Level 1 (0 points)

    I fixed this problem today.. If anyone else runs in to this, try:

    Click the Advanced... Then click on the Hardware tab. Make sure that it is set to be configured Automatically.

  • gaviero62 Level 1 Level 1 (0 points)

    I just got off the phone with apple and they wanted me to do the same and delete all of my preferences for networking, I was reluctant as I have many stores static address for different office locations. But given the idea of delete, I simply delete the one device from the troublesome configuration and added it back. It worked and much safer than going to delete a bunch.

     

    So again, my "ethernet" was saying connected as well, but from command line "ifconfig -a" was not showing connected. I deleted "ethernet" and then added it back in through the network preferences. All good now.

     

    I'm running 10.7.3. on a 15" macboo pro 2.8GHz Core i7


  • DanTheMan217 Level 1 Level 1 (0 points)

    My client has this exact issue on two MacBook Pros.  I've tried everything listed in this thread (and links) and more--and the problem persists.  I'll spare you my exhaustive troubleshooting steps but here's my workaround.  If I plug the MacBook into a small unmanaged switch--it works.  All other methods of connecting the Ethernet port do not work.  I've plugged directly into several of our managed 48-port gigabit switches, removed/readded the port, PRAM, SHIFT-CTRL-OPTION-PWR, delete Network Prefs, check for "automatic" settings, manual IP config, and on and on.  I did not try reinstalling the OS, taking it in or calling Apple (even though my client has support).  My end user seems to be happy with the local switch workaround--but I'm not.

  • sthibeau Level 1 Level 1 (0 points)

    okay, totally stumped. Can't get my LAN port working on my iMac. Reset Pram, made sure connections are set to automatic. Funny thing is it won't even light a port on my switch. My switch is handing out a lan IP address using DHCP. Funny thing is if I take my imac down the hall and connect to another drop in my office going through a router handing me a 192 address, it connects no problem. I can connect my windows based lap top in no problem as well as my macbook into my office drop. Just not the iMac. Wireless works fine. Need help.

  • KulHndLuk Level 1 Level 1 (0 points)

    I too am having som sort of network issues.  My late 2011 15" MacBook Pro has been working flawlessly since purchase.  Since the upgrade to OS X Maverics, I've had an odd networking issue.  My Mac is joined to a Windows Domain Network where the DC is a Windows 2012 Standard Server, again its never been an issue.  Now I am having local network issues and getting the following issues in the Network Diagnostics page:

    Screen Shot 2013-11-18 at 9.02.49 AM.png

    I cannot access network shares or other resources either.  BTW, my user account is a network admin. so permissions are not the issue.

     

    Any ideas?

  • MarkCousins Level 1 Level 1 (0 points)

    This is a very old thread but I want to share my solution.  Like the OP, if I connect an Ethernet cable after startup or resume from sleep, no connection is made.  I used to restart the system to recover, but then after thinking about it more, decided to try less drastic "resets."

     

    With the cable connected but no network connection established, I did the following from the command line (Terminal):

     

    markc-mbp:~ markc$ ifconfig en0

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

      options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

      ether a8:20:66:43:3e:13

      media: autoselect (none)

      status: inactive

     

    Note that it shows the interface as UP but that no media (cable) are detected.

     

    So I issued:

     

    markc-mbp:~ markc$ sudo ifconfig en0 down

    Password: <enter your password>

     

    Then

     

    markc-mbp:~ markc$ ifconfig en0

    en0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500

      options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

      ether a8:20:66:43:3e:13

      media: autoselect (none)

      status: inactive

     

    Now the interface is down (not UP).  Reversing this:

     

    markc-mbp:~ markc$ sudo ifconfig en0 up

     

    Wait a few moments, then:

     

    markc-mbp:~ markc$ ifconfig en0

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

      options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

      ether a8:20:66:43:3e:13

      inet6 fe80::aa20:66ff:fe43:3e13%en0 prefixlen 64 scopeid 0x4

      inet 10.32.80.102 netmask 0xffffff00 broadcast 10.32.80.255

      media: autoselect (1000baseT <full-duplex>)

      status: active

     

    Success!  Interface is UP, media is detected, status is active, and an IP address is assigned.  In summary:

     

    markc-mbp:~ markc$ sudo ifconfig en0 down

    markc-mbp:~ markc$ sudo ifconfig en0 up

Previous 1 2 Next