Previous 1 2 Next 18 Replies Latest reply: Jan 3, 2014 11:58 AM by Apple0987
ch222 Level 1 (0 points)

I've hunted high and low for an answer to this question, but cannot find an answer, so I'm hoping someone here can help me out. 

 

My new iPhone 4S will not vibrate when new mail is received when I have the "New Mail" sound set to "none" - even if I have both "Vibrate" and "Silent Vibrate" set to "yes", and regardless if I have the left toggle switch set to sounds or vibrate.

 

This didn't use to be the behavior in IOS4 and lower, and I just want to make sure it's the expected behavior in IO5 before I start wondering if I might have a defective device.

 

What I want to be able to do, and what I thought I used to be able to do, is set the phone so no sounds are played when mail arrives but that the phone vibrates, but it won't vibrate unless I have a sound selected.  Now, obviously, I can put my phone in silent mode and it will vibrate when mail is received, but I want to have sounds enabled for calls and voicemail - just not email.  But I do want the phone to vibrate in all cases.

 

Am I missing something here?

 

Pics attached.

 

vibrate-off.png newmail-none.png

 

Message was edited by: ch222


iPhone 4S, iOS 5
  • lojaconob Level 1 (5 points)

    I'm having same issue with my 4S.  This is my first iPhone so I don't know how it worked in the past, but I would assume if the vibrate settings are on for alerts, then it should still vibrate even if the sound alert is set to none.  Mine doesn't even vibrate on alert when I set the phone to silent from the side switch.

  • jrjdotmac Level 1 (5 points)

    Same problem here.  if anyone has a solution I am all ears.

  • divyafrombryan Level 1 (0 points)

    Yup same issue here on my 4S. Glad that its not only for me. Hopefully someone will post a solution soon

  • afhammerC Level 1 (0 points)

    Mine is doing the same thing. Glad to hear other people's are doing it too because none of my friends seem to be having any issues. I went to AT&T today and the only thing they could recommend is to send it to Apple.

  • ch222 Level 1 (0 points)

    afhammerC,

     

    So I understand: you have friends whose iPhone 4S's do vibrate when mail is received in silent mode, and no sounds are selected for new mail, but vibrate is selected for silent mode?

     

    Just want to be clear.

     

    My wife has an iPhone 4S 16gb, and it appears she has the same problem as well. 

     

    As an aside to the issue, I really wish there was a way to have a timer on the notification center so we could put one, many, or all apps' notfication to sleep during a specific time period (say, during the night).  V. annoying to have to disable notifications separately.  Would love a way to turn them off between, say, midnight at 6am.

  • afhammerC Level 1 (0 points)

    I forgot to add that my problem is that it doesn't really go off when I get a text message, no matter if it's on silent OR ring. It just doesn't make any noise or vibrate. The screen lights up and that's it.

  • afhammerC Level 1 (0 points)

    ch222 -- I'm not sure about the email part, but I know my friends aren't having any issues getting their text alerts.. Has your wife been having that problem at all? I haven't turned on the email alerts, but I will and see if the same thing happens.

  • afhammerC Level 1 (0 points)

    I found this about text messages -- it talks about having a sound selected. It might help: https://discussions.apple.com/thread/2477615?start=0&tstart=0

  • jrjdotmac Level 1 (5 points)

    To bring this thread back on topic if anyone knows how to get a new mail message to ONLY cause the phone to vibrate please let us know.  It is very disturbing to be in meetings with the phone constantly chiming.  Thanks in advance for your help.

  • ch222 Level 1 (0 points)

    @jrjdotmac - Select a tone for "new mail", make sure silent -> vibrate is set to "on", and then switch your phone into silent mode via the toggle switch on the left side.  Mine will vibrate this way when I receive new mail w/o playing the tone.

     

    However, to be clear: This is not this issue I'm describing at the start of the thread.  I want to have no tone play for new mail, but have tones play when I get text or phone calls, and feel like, logically, I should be able to do this by having vibrate set to "on" - but it doesn't work.  I suspect it isn't a bug but part of IOS5, and I think it was something poorly thought out, if it was given any thought at all.

  • jrjdotmac Level 1 (5 points)

    In my particular situation, when I configure the sounds settings exactly like you show them at the top of this thread (Silent Vibrate = On, Vibrate = On, New Mail = None) I get nothing when a new email arrives.  No sound, no vibration, nothing.  If I define a New Mail sound, such as "Ding", then I get a "Ding" plus vibrate.  I don't beleive this is the expected behavior and I am trying avoid physical intervention by using the left hand toggle switch.

     

    I understand your situation is slightly different but beleive the issues are inter-related. +1 on this being poorly thought out.

  • ch222 Level 1 (0 points)

    Definitely the same situation.  I'm just getting around it by toggling to silent and having all notifications (mail, text, phone) come through as vibrate-only.

     

    I'm definitely after the same setup you are: Toggle/silent = off; vibrate but no sound on new mail arrival.

  • Cleopatra10 Level 1 (0 points)

    I had the same problem, and this seemed to work for me:

     

    Go to Settings > Sound  & turn both vibrate buttons on. *If you have "none" selected for text messages as a tone under the Text Tone menu, it will not vibrate at all. You need to have a tone for it to vibrate, which wont matter anyway if you switch it to silent mode.

     

    Hope this helps everyone

  • missakins Level 1 (0 points)

    This is not the issue that is being described.

     

    What is being requested is:

     

    -Phone is NOT on silent.

    -Phone DOES make a noise when a call comes in.

    -Phone DOES NOT make a noise when an email is received but does vibrate.

     

    Please describe a scenario/steps in settings to make all three of these options available at the same time.

Previous 1 2 Next