Previous 1 2 Next 25 Replies Latest reply: Aug 13, 2015 2:49 PM by Grannie44
garys.macaccount Level 1 (0 points)

To set up my new printer as wireless, I need to push the WPS button on my airport.  But there isn't one.  Info:  The printer is a HP P1102w.  I can set it up with USB, but to then change it to pure wireless, need the WPS button.  Any ideas?

  • Bob Timmons Level 10 (95,500 points)

    Unfortunately, Apple devices do not support WPS, so your best bet is going to be contacting HP Support to see if there is a manual method to set up the wireless.


    This Apple Support document may provide some information as well:


  • joconor Level 1 (0 points)

    Airport base stations do support WPS, through the Airport Utility application. Open Airport Utility, choose your Airport Base Station, and choose "Add Wireless Clients…" from the Base Station menu.

  • Bob Timmons Level 10 (95,500 points)

    I have found that is not a realible method at all, but if it works for you....that is great.


    For the record, Apple Support says that WPS is not supported...but it may work for some folks. BTW, if you try a search for WPS in AirPort Utility Help, nothing comes up.

  • joconor Level 1 (0 points)

    Apple doesn't call it WPS, apparently preferring to use what I guess they think is more user-friendly terminology. They have a whole page in Airport Utility Help on "Adding a wireless client to your 802.11n network" that discusses the use of WPS, even though they never say "WPS". Airport Utility handles both Push Button and PIN methods of WPS. Apple refers to Push Button as "First Attempt".


    I'm not sure why you say Apple Support says that WPS isn't supported. Apple provides the capability in Airport Utility, documents it in their help file and on the Apple Support website.


    As for reliability, there could be many factors at play there. Off the top of my head, I'm aware that some devices only allow for a limited period of time to initiate the WPS procedure on the other end, but that period is usually measured in minutes, but I would expect this to vary by device.

  • Bob Timmons Level 10 (95,500 points)

    Well, despite the fact that it does not work reliably for me....and for other users that I've tried to help on the forums based on experience....I do agree that it does work for some folks.


    If it is supported, one might think that it should at least work reasonably reliably.


    Despite this, ff you want to say that WPS is supported, you can have the last word here.

  • Doc Larson Level 1 (0 points)

    joconor is absolutely correct.  It is the easiest way to setup this extender using the airport extreme.  Just open the Airport extreme utility.  A quick note:  You should be in the manual configuration mode while attempting this solution, then select base station menu, then choose add wireless client.  The first attempt option can then be chosen then hit the wps button on your wireless extender.  Then you should be good to go at this point.  Check and two new wireless access points should be available to your wireless devices.  Same password as your original access point. The first attempt option is the wps button equivalent when using the airport extreme.

  • Bob Timmons Level 10 (95,500 points)

    Now, if you could tell us where the WPS button is on the AirPort....which was the original question.

  • Doc Larson Level 1 (0 points)

    The first attempt option is not quite as simple as a button, but it is still the easiest way to setup a WPS button equipped device.

  • Helge Krabye Level 1 (145 points)

    This worked for me immediately when setting up my new Roland Integra7 sound module with the Roland wireless USB Adapter (WNA1100-RL) to work with the Inegra-7 Editor on my iPad and an AirPort Extreme:

    1. In the Airport Utility, I clicked on my AirPort Extreme, then chose "Add Wi-Fi Printer" in the Basestation menu on top of the screen.

    2. I turned off my other WiFi-printer and chose "First try" to connect to the USB Adapter without any PIN-number.

    3. After a minute's waiting, the AirPort Extreme found the WSB Adapter and allowed it to connect to my wireless network.

    4. If you are using the Integra-7 and WNA1100-RL like I do, be patient when the iPad app is searching for the Integra-7 (to make it search for it, go to the settings meny and choose "Midi Devices". After a few seconds, the iPad app will find and connect to the Integra-7.

    5. If you quit the iPad app, you will need to connect to the Integra-7 again, unfortunatly. The USB Adapter will remember and connect to your wireless network by itself the next time you turn on the Integra-7.

  • dailyja Level 1 (0 points)

    I had instant success as well, using Helge's method, to connect a Canon printer. In fact, it was incredibly simple considering I didn't even have to get up and push a button on the access point. Once I clicked Add Wi-Fi Printer from the menu, then followed the steps from Canon, I was connected in seconds. Thanks for the contributors to this thread.

  • Patricia Ryansmith Level 1 (5 points)



    Now, if you could tell us where the WPS button is on the AirPort....which was the original question.


    Wow, do I feel your frustration!  These posts were helpful to a point, but here is what I found in my printers online manual (  I have a wireless Canon MG6320 that wanted me to use the WPS button too.  I have an Aiport Extreme router that is not hardwired to my computer.  The setup process from the on-screen prompts were directing me exclusively to the WPS button nonsense.  The manual offered another option, and that was to configure my printer with "other connection methods", pg. 13.  Then, on page 14 it gives the option to use a "standard setup."  When I did this the printer displayed a screen that allowed me to enter the network (router) password, pg. 15.  After I did this my connection was established.


    I don't know if your printer offers alternatives to the WPS setup or if it has a touch screen and if any of this information will be helpful.  It took me 3 hours of reading posts and downloading manuals to resolve my problem.  I hope you find a solution!


    P.S. It also suggested to turn my firewall off during this process, which I did.  I did not try it with the firewall on.

  • Ron Doba Level 1 (0 points)

    There is no WPS button on the AirPort Extreme. Use the procedure identified by joconor and it should work. I was struggling trying to get my Yamaha YWA-10 network adapter connected so I could use the Airplay feature on a Yamaha RX-V673 receiver. Then I found this support community and voila! It works great!

  • betsy from oregon Level 1 (0 points)

    I just tried to set up a Pioneer A4 wireless speaker, using the procedure outlined above to add a wireless network to my 2009 Airport Extreme.  First Attempt seemed to work, and the settings show that the Pioneer has been added to the Airport Extreme network and access is unlimited.  But the Pioneer Network didn't seem to recognize this, and the network button keeps blinking blue.  What's the problem?  The computer running OSX 10.6.8?  the Airport Extreme settings?  the Pionner itself?  And what's the solution?  

  • Dcione Level 1 (0 points)

    well i had the same problem this is how u should do

    go to printer and use wps feature.

    then go to airport utility, click on base then select WPS printer, voila!

    they will syncronize.

    airport extreme has WPS feature for printer

    Screen Shot 2013-09-25 at 6.52.50 PM.png

Previous 1 2 Next