Skip navigation

Upgrade to 7.6 broke my network

34674 Views 162 Replies Latest reply: Sep 2, 2013 6:42 AM by Marv Richardson RSS
  • juanfromalgete Calculating status...
    Currently Being Moderated
    Nov 13, 2011 4:04 PM (in response to Jeroen Wollaars)

    i managed to solve my issue...

    i had 7.5.2 running in bridge mode with this topology:

    internet adsl router -> airport extreme 3rd gen (wan port)

    gigaethernet switch -> airport lan port

    various wired devices connected to eth switch (including imac)

    various wireless devices connected on 2.4ghz to airport (apple tv among them)

    time capsule expanding extreme wireless range

     

    this network was running reliably for more than a year.

     

    when the airport detected 7.6 was released by apple it went to orange blinking....

    everything kept running with a single exception: wired to/from wireless were not handling dhcp requests as before

    yes this happened without anybody touching anything on the net (it just stopped working)

     

     

    first thing i did to troubleshoot it was updating the airport to 7.6 using the imac (airport tool 5.5.3 on lion).

    after flash was complete... airport hanged and nothing worked (not even internet connectivity)

    factory defaults restore by holding reset button on powerup....

    tried again setting the aiport with initial values to allow simple internet connectevity.... no luck

    every time i tried to save the settings the airport hanged and factory rest was required....

    i thought it was 7.6 issue...... so rolled back to 7.5.2

    tried again and again (factory reset with button and setting basic bridge to get internet.... no luck)

    thought it was osx 5.5.3 airport tool... so downloaded (by connecting windows laptop directly to dsl router) the 5.5.3 airport tool for windows..... tried again all the process ... no luck

     

    then i tried factory resetting again and configuring basic setting with ipad... and it worked.... i had basic internet thru airport...

    so back to osx airport tool to configure the remaining settings not available on ipad simple tool (like enabling 5ghz etc)... and airport hanged.... rebooted and i noticed all changes were not saved (only the ones done from ipad were kept)... tried many times.. no luck...

    so i thought it was 5.5.3 tool that was faulty.....(tried 5.5.2 on snow leopard)... same thing...

    i then turned off airport extreme thinking it was hardware faulty and tried everything again on the timecapsule as main station... same results...

     

    solution:

    disconnected the lan cable from the airport (kept only the wan connection) and everything worked good over wireless (osx lion 5.5.3 with airport 7.6).. everything worked fine lastly...with one exception:

    dhcp requests are still not relayed between wired and wireless segments...

    it seems airport 7.5.2/7.6 and/or airport tool 5.5.2/5.5.3 has some kind of issues when having wired+wireless connectivity when configuring... if i connect the wired ethernet i can replicate the issue everytime...

    too bad it took me 2 days of testing all possible combinations to find out what apple did not...

    please apple fix this asap....

    hope it helps somebody out there ....

     

    good luck

  • Phyllis Sommers Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 13, 2011 4:08 PM (in response to Black MacLeod)

    It just occurred to me that I didn't even have Airport Utility open when my units started flashing-- and the option to monitor my Airport devices was not checked. In thinking about what others have written, I still think that some of the devices automatically recognize that there's an update and stop working properly until it's performed. I'll see if things change, now that I've un-checked the update option when opening AU. I hope this makes the difference. Thanks again.

  • juanfromalgete Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2011 4:25 PM (in response to Phyllis Sommers)

    yes i confirm this... my net started to work unreliably (no dhcp assignment to apple tv) as soon as the airport extreme detected the update was available...

    i think there is one of two possibilities:

    option 1 (unlikely): apple pushes something to airports over the net that forces users to update or have crippled networks

    option 2 (most likely): firmware has bugs that appear when the "update available" flag is detected (probably apple never tries new firmware with another newer firmware also available)

  • Phyllis Sommers Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 13, 2011 4:35 PM (in response to juanfromalgete)

    I just relived my whole nightmare through your description, Juan. I had very similar experiences and seem to have a similar network design. As I'd mentione earlier, once I re-installed, from scratch, the Extreme base station and ethernet-connected Expresses, the wirelessly-connected Expresses didn't need to be re-set. They retained their settings and worked fine, but everything on the Ethernet part of my network had to be completely re-configured. This was an absolute mess! I can't even imagine what the Apple techs must be going through fielding requests for help. I sure hope it makes them sit up and take notice before ever again releasing an update before it's ready. I completely agree with you: with all the complaints of similar issues, I can't believe that some of these problems didn't show up during beta testing!

     

    By the way, unless I missed it, you didn't mention ever re-setting your dsl modem. After re-installing my main Extreme base station, I disconnected my cable modem and disconnected everything from it. I then re-connected the co-ax cable and the power. This forced a new Internet signal and my entire network, wired to wireless, is working as perfectly as it was before this horrible update. If you haven't completely reset your DSL modem, that may just take care of your DHCP issues. Good luck.

  • juanfromalgete Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2011 4:52 PM (in response to Phyllis Sommers)

    hmmm i dont remember resetting the dsl router (as every time i wanted internet access i just connected a female-hemale rj45 adapter to bridge the eth switch to the dsl router and everything worked fine (of course with all wireless devices isolated from internet))

     

    what i did as workaround a few minutes ago was setting the dsl router in bridge mode and changing airport to "share a single ip address" mode....

    i now have to deal with the nat forwarding to airport itself.... but im happy to have all wireless/wired devices running happily again......

     

    btw.... too bad airport requires reboot to make simple changes (like changing a password, or adding/editing/deleting a nat port)...... my very cheap dsl router does almost everything over a web without ever rebooting unless i want to change core services like type of dsl line encapsulation and such....)

     

    hope we get TESTED 7.7 "dont reboot for everything" airport firmware sometime in the future

  • Phyllis Sommers Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 13, 2011 5:30 PM (in response to juanfromalgete)

    I completely agree about the more simple, "don't reboot for everything," update... only it had better be WELL-TESTED!  I now have cable Internet, but had dsl for years & years. I remember setting up my last dsl modem, which had a router built in, in bridge mode and deactivating the router component, allowing just aiport, alone, to manage the routing-- just as you've now done. This was recommended by both Apple and my isp. Although I can't specifically remember what they'd said, I believe they thought I'd get faster speeds and less network interference that way. (With DSL you can certainly use all the speed you can get!) I also remember being told by my ISP that everytime the Airport was rebooted, the modem should be re-booted as well. At the very least,  I'm pretty sure that if you haven't re-booted your modem, after going through all the re-configuring you've done, you should probably re-set it. However... if it "ain't broke," right? Now that you're completely happy with the way things are working, maybe you should just leave well enough alone. So long as your speeds are OK and your connectivity is stable, why bother? I'm a complete perfectionist and there have been too many times when I've messed things up by trying to make them more perfect. Just onemore thing for you to consider.... Glad you've got both wireless and wired working again! This was NOT the way I'd planned on spending my weekend, but at least everything's back to normal again!

  • RainMeister Calculating status...
    Currently Being Moderated
    Nov 14, 2011 1:09 AM (in response to Jeroen Wollaars)

    I tried to go back to version 7.5, but my system is still broken even after a complete refresh. I've abandoned the Airport Extreme/Express combination in favor of my DSL wireless router, which to my surprise I am finding has better signal strength throughout the house. I wasted several hours this evening trying to fix a system that was working perfectly fine until Apple mucked it up. Why Apple? It just doesn't work!

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 14, 2011 11:41 PM (in response to RainMeister)

    Have you guy's tried switching the channel on the AP to make sure it's not an interference issue ?

    For folks who are mentioning that 7.5.2 works better, note down the channel the wireless network is on 7.5.2.

    Upgrade the AirPort Base Station and check what channel 7.6 pick's and if it's a different channel, then try going back to using the previous channel.

    Also try physically unplugging and replugging the unit from the power supply if things don't go well after the upgrade.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 14, 2011 11:49 PM (in response to glynhughes)

    glynhughes,

    Can you post some screen shots of the wireless tab  on your AirPort Utility for the Base Station you are seeing issues with ?

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 14, 2011 11:50 PM (in response to Spotlights)

    If you connect a cable to the AirPort base Station, you should be able to see it in AirPort Utility. What error is it complaining about when you see the amber light's ?

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 14, 2011 11:51 PM (in response to Neil Cudmore)

    Neil,

    Can you post a screenshot of the wireless tab in AirPort Utility under 7.6 ?

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 14, 2011 11:53 PM (in response to WindyCityDave)

    Dave,

    Do you have auto channel selection enabled or are you manually setting the channel's  on your base station ? What security are you using ? Did you try unplugging and replugging the base Station from the power supply after the upgrade ?

  • glynhughes Calculating status...
    Currently Being Moderated
    Nov 15, 2011 2:16 AM (in response to wifiguru)

    Here you go. Note however that these settings haven't changed from those prior to the upgrade/downgrade debacle

    Picture 68.png

    Picture 69.png

  • swngcat Calculating status...
    Currently Being Moderated
    Nov 15, 2011 5:20 AM (in response to andrewfrombaileys harbor)

    How do you revert back to firmware 7.5.2?

     

    I only have 7.6 in this location:

    \Users\Brian\Library\Application Support\Apple\AirPort\Firmware\109\7.6.basebinary

  • mikeb70607 Calculating status...
    Currently Being Moderated
    Nov 15, 2011 9:12 AM (in response to wifiguru)

    wifiguru,

    The router is not even seen from the computer.  The utility does not see a router

1 2 3 4 5 6 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.