13 Replies Latest reply: Aug 21, 2015 8:25 AM by dallan1008
lefrank Level 1 (0 points)

I cannot remove old (over 1 year) expired movies from my iPad.  The only place you can see them is in the drop down when the ipad is synced to itunes. They are greyed out.  if you click on the down arrow on a movie it takes you to ITunes store to purchase or rent again.  You cannot see them on the ipad through the Vidoe app/movies and they do not show on the tabs that you use to choose what you want to sync.  This is just bothersome becasue i like to keep the ipad clean.  Here is a screen shot  - might be helpful.  I updated to IOS 5.0.1 but I am sure that is not the problem. I have already tried a hard reboot without luck.


Screen Shot 2011-11-11 at 8.21.23 AM.png

iPad, iOS 5
  • Pascal Bouvier Level 4 (2,880 points)

    i have the exact same issue. 

    set up is =>  ipad 2, ios5.01, itunes 10.5, osx 10.7.2.


    six old rental movies show up on the ipad's drop down menu.  all are greyed out.  the only way to delete them is to check, in the summary page, the "manually manage music and videos" option.  once i do that i can delete the six old rental movies.  alas, the next time the ipad is connected to itunes, the movies show up again.  i tried to restore original settings for the ipad several times and that did not work.  i restored from backup, that did not work.


    i should add that the rental movies do not show up on the ipad when launching the video app.  the only place they show up is on that drop down menu as described above.  to add insult to injury, i think the ipad is still trying to "download" the movies which is why now, and since i upgraded to ios 5, i can never complete the sync process (whether through the usb port or through wifi).  the sync process will always hang eternally at step 5 or 6 with the message "waiting for items to copy".


    i think this is an ios 5 bug.  i have seen other discussions here that point to the same error, but with different causes such as voice memos, photos...   i believe old rentals fall in the same category.  although other users have found solutions to the hang sync by making changes to settings for voice memos, photos... unfortunately i have not found anyway of getting rid of the old rental movies as of yet.


    any help out there?

  • patinchch Level 1 (0 points)

    I have this too. Cannot figure out at all how to remove this list of old rentals. I have found a few suggestions that mess around with sync settings, but whenever I sync my iPad again, or change my sync settings, the whole darn list comes back.


    Seems to be no reason tehse shoudl remain; I too suspect some bug in IOS 5 0. I dont know for certain, but do not recall seeing this before I upgraded


    Sorry I cant help - does Apple actually look at these posts?  Wojud be good if they acknowledged thisproblem, at least....

  • shecky39 Level 1 (0 points)

    I have this problem too.  Has anyone found a solution?  The movie shows up only on the "devices menu under rentals.  I don't see it on the iPad or iTunes.

  • Todd I Level 1 (5 points)

    I have this same issue.   For the most part, the old rentals don't cause much problem.  But, when I do a network sync, I always end up with errors "14 items could not be copied ..."


    I would like to clean out the old junk to avoid the errors.   Anyone figure out how?

  • Big j Boss Level 1 (35 points)

    it’s a simple fix that works the same way for iPhones and iPads.



    1. In iTunes with your iOS device connected, click on the device in the source list.
    2. On the summary page, scroll down to the Options panel, and make sure that the option “Manually manage music and videos” is ticked. Click Apply to make the change if it wasn’t ticked before.
    3. In the source list, click the disclosure triangle next to the device. A set of subfolders representing your device’s storage space will show up.
    4. Navigate to Rentals. The movies will appear in the main part of the window.
    5. Select the movie(s) you want to delete, then select Edit > Delete (or use either the Backspace keyboard shortcut, or right-click for the contextual menu). The movies will be deleted – take care that you don’t delete a rental movie that hasn’t yet expired.
    6. Once they’ve been deleted, go back to the device’s information summary page, and untick “Manually manage music and videos” if necessary. Double check that in doing so, iTunes doesn’t try and add new content you don’t currently sync – for me, it decided it wanted to start syncing up music tracks, which I don’t currently sync to my iPad.
  • lefrank Level 1 (0 points)

    This does remove the old expired movies, but as soon as you resync, they come back.

  • Pascal Bouvier Level 4 (2,880 points)

    i did try the "manually manage music and videos".  alas, at least for me that does not work.  once i unselect "manually manage music and videos" the old expired movies reappear.

  • Big j Boss Level 1 (35 points)

    i would say create a backup of your device iPad/iPhone and then once the backup has been created make sure u have removed the rental movies from your computer. to make sure u do not lose any data make sure u create a backup first then disconnect the device and put it in recovery mode

    then plug it back in and do a restore where everything gets erased from the device

    once you have done that restore the device from the backup you just created and that will get all your info back on the device but will not bring back the rental movies


    how to backup and restore




    how to place the device in recovery mode



  • Steven Shmerler Level 1 (75 points)

    in my case, if I select the title in the iTunes window and go to Edit, Delete is grayed out, so I can't delete it.


    Control clicking the title only brings up the contextual menu with:


    -Get info


    -Show Description




    Found the Problem. Needed to check the Manually manage vids and music and then the Delete button worked.


  • jrr1977 Level 1 (0 points)

    I have exactly the same problem. None of the solutions here work. I can delete the greyed out movie, but then when I re-sync, it comes right back. I have deleted the movie from my harddrive. It is nowhere on my computer.

  • Epabcal Level 1 (0 points)

    Did you fix the problem? Any update?

  • ernie NY Level 1 (0 points)

    On your iPad, go to settings, Videos, and turn off "Show All Videos". 

  • dallan1008 Level 1 (0 points)

    On your Ipad, ,go to Settings, Videos.. and Turn Off.. Show all Videos




    Go back into your Video's rentals.. on the top right there is an EDIT option.. Click this and small "X" will appear on all the videos. Click on this to remove the video's icons from your ipad.