1 Reply Latest reply: Nov 13, 2011 2:16 AM by Kevin Cowan
kara1234 Level 1 Level 1 (0 points)

Just bought the Canon MG5350 which accroding to apple and the printer, I should be able to print from my cell phone.  I have downloaded the App on my iPhone for Canon to print pictures, so that is solved. I can print from iPhoto, but if I am on a web page and I want to print a picture it does not wrok.  I click on the forward arrow to print.  Click the button to Print, go to Printer Options, touch  select Printer, then it says No AirPrint Printers found.

The printer is connect to my iMac wirerlessly, there are no cords connecting it to anything. 

 

I have updated to latest Canon softwear

IOS 5.0.1 for iPhone 4

Mac OS X 10.7.2

iTunes 10.5

 

 

 

This is what  have found on the discussions.

 

http://support.apple.com/kb/ht4356

  • Verify that your iOS device is running the latest version of iOS and the app you are printing from is the lastest version.
  • Verify that the AirPrint-capable printer has the latest firmware version installed.   See the printer documentation or contact the printer vendor for support.
  • Certain printer features or functions may not be available when using AirPrint (for example, duplex printing, selecting different paper trays, and so on).
  • Please read the printer documentation or contact the printer vendor  for details on how to connect your AirPrint-capable printer to your network.
  • AirPrint only works with a network connection to an AirPrint-capable printer. A printer connected using Bluetooth or to the USB port of your Mac, PC,  AirPort Base Station, or Time Capsule is not supported.

 

Thank you!!


iPhone 4
  • 1. Re: cannot find wireless Canon printer on my iPhone4
    Kevin Cowan Level 1 Level 1 (0 points)

    I can confirm that you can use AirPrint with AirPrint-enabled Canon printers, and yes, from other iPhone / iPad apps in addition to Canon's own Easy-PhotoPrint app.

    My printer was completely set up and working on a wireless network (when printing from a Mac) except for the "No AirPrint printers found" message on the iPhone when attempting to print from an app.

     

    The fix was to:

    - Download the "Printer Update Utility" software from Canon (which updates the firmware)

    - Turn the printer off and on (but don't worry, an instruction checklist is shown when you start the utility).

    - Connect the printer via USB to a Mac (updating the firmware won't work via the wifi connection)

    - Use Canon's "Printer Update" software to upgrade to firmware version 2.0

    - Turn the printer off and on again.

     

    Done. I didn't have to re-enter the wireless network information; printing from an iPhone worked automagically from that point onwards.

    Hope this helps!