7 Replies Latest reply: Aug 21, 2012 12:56 AM by MrBrillo
teddyfromhauppauge Level 1 Level 1 (0 points)

I am trying to rename ny external hard drive in Finder and I'm getting the error code 8076. I'm running OSX 10.7.2


iMac, Mac OS X (10.7.2)
  • Peggy Lynn Level 4 Level 4 (2,470 points)

    Go to finder and select the external drive. Type Command-I or go to Get Info in the File menu. At the bottom of the Get Info windowit reads, "Ignore ownership on this volume." if it is checked uncheck it. You might be asked to enter your admin password.

  • teddyfromhauppauge Level 1 Level 1 (0 points)

    I Tried it and I get a window that says "operation can not be completed" (error code -8076). Any Idea?

  • X423424X Level 6 Level 6 (14,215 points)

    I am not sure how dangerous this is but I found a MacNN NNForums thread which somewhat similar to yours and the fix there was to do the folliowing in terminal:

     

    sudo diskutil enableOwnership /Volumes/name_of_drive

     

    The sudo will cause a prompt for your admin password (won't echo when typed).

     

    As I said I never tried this personally so I don't know if it does any permanent damage to the owneship and permissions of the volume.

     

    I DO NOT RECOMMEND YOU TRY THIS UNTIL SOME FOLLOW ON POST CONFIRMS WHETHER THIS SHOULD BE DONE.

  • teddyfromhauppauge Level 1 Level 1 (0 points)

    I'm not sure I want to change settings on my imac that is just 2 months old. Frankly, I purchased an Apple imac to avoid annoying situations like this. I'm grateful for the Apple Support Community out there, I assumed it was an easy fix. I guess a call to Apple Support is in order. When I get the answer I'll post it.

  • teddyfromhauppauge Level 1 Level 1 (0 points)

    Apparently you need to restart the computer after you format the external HD in order to uncheck the "ignore ownership on this volume" box without getting the error code 8076.

  • Larry Israel Level 1 Level 1 (0 points)

    I restarted, but did not have any oportunity to uncheck anything. How did you get to that?

  • MrBrillo Level 1 Level 1 (0 points)

    Try repairing disk permissions using the Diskutil app - it worked for me.