Previous 1 2 Next 25 Replies Latest reply: Dec 24, 2013 4:58 AM by Peter1066 Go to original post
  • thejoce Level 1 (0 points)

    I've had this issue for months and figured out it was because of shared calendars. I removed the calendars & didn't have the issue, but I need to be able to see the shared calendars.

     

    I've tried multiple solutions - clearing the cache, removing iCloud calendar syncing, deleting all calendar information in my User/Library/Calendars, then re-adding it, remove the shared calendars & re-sharing them, etc... and the only thing that fixed it for me was logging into the shared calendars, temporariliy giving me read/write access to all calendars, then changing it back to read only.  After that, when opening iCal on my Mac, all is finally well!

     

    I hope if you've tried everything else and are still having this issue, this might work for you also.

  • West Oz Guy Level 1 (0 points)

    My issue seems to be resolved, but I'm not sure exactly what fixed it.  I un-shared all my calendars and left it alone for a few weeks.  Then came back to it to look at the issue again, and it all just worked.  So it might be a timeing thing?  Someone else might have some ideas.

     

    Cheers

  • scidoc666 Level 1 (10 points)

    hi,

     

    I have this problem too. How do I unshare all my calendars?

     

    thanks

  • West Oz Guy Level 1 (0 points)

    Hi Scidoc

     

    I don't think you can just unshare all your calendar.  But to unshare the calendars individually goto view / stop sharing.  Then select the next calendar and so on.

     

    Cheers

  • GadgetGuyTN Level 1 (0 points)

    Just to update folks on my own experience with this issue:

     

    I just spent well over an hour with an Apple second-level support tech. We did NOT fix the problem, but we did notice something interesting. If Safari is open before iCal is opened, the error message doesn't always appear. If the System Preferences>iCloud menu is open, and Safari isn't, the message doesn't appear.

     

    If neither is open first, the message appears every time!

     

    If I go to my wife's computer, open iCal, and select Calendar>Stop Sharing, then go to my own computer and delete the shared calendar, I don't get the error. As soon as we re-share her calendar, and I re-join it via the email invitation, the error reappears.

     

    Interstingly, the error does NOT appear when viewing my calendar online at iCloud.com, or if I have iCoud open via Safari, then open iCal on my computer.

     

    The tech finally gave up and said he would have to do more research. I suspect there is an actual bug that they will need to ferret out and correct. I will post more when I have an actual solution (unless a Software Update takes care of it).

  • dag911 Level 1 (0 points)

    hi there

    very latest Mac OS updates (10.8.2) applied tonight seem to at last fix this horrible problem. i hd constant 403 errors but after tonight's updates they seem to have gone ...

  • inked at dolltattoos Level 1 (30 points)

    I had the same problem.  I can tell you what started it and what I did to correct it.

     

    What started it:

    I changed the system time and date to future times/dates.

    During the time my Mac was, "in the future," I received calender notifications (I have a few recurring reminders).

     

    Correcting the system date/time did not correct the Calender issue.

     

    When Calendar was launched, I'd get the, "Ignore," Try Again," and "Revert" buttons.  It didn't matter what I responded, Calendar was still a little confused.

     

    What fixed it:

    System Settings

    iCloud

    I unchecked Calender - yes, delete the calendar from my Mac.

    Then, I checked Calender. 

     

    Everything was back to normal after that.

     

    I'm running 10.8.2.

  • Zhiming Wang Level 1 (5 points)

    I had the same problem with Mac/iPhone Calendar.app. But working directly on https://www.icloud.com/ seems to present no problem at all. So if your native clients fail, try to target the server side instead.

  • gchdrake Level 1 (0 points)

    My fix was a little more complicated but worked.

     

    I turned off ALL calendars and iCloud accounts.

    I logged into iCloud.com making sure I had no duplicates or added calendars.

    I then turned on my iCloud account on my Mac again which required restarting all IOS devices, this is the step that seemed to clear the issue up completely and then I added calendars back one at a time.

     

     

    This was a ridiculous issue and has taken me almost a week to resolve. While I had a constant issue on my Mac, ALL IOS devices functioned normally. Absurd.

  • NickFury Level 1 (0 points)

    I turned off iCloud for my Calendars and am leaving it off.

     

    I just had a metting rescheduled for another day and this error prevented me from being able to update it because of this error. @gchdrake's solution makes sense, but it's too much effort for something that should just work when you select Calendars in the iCloud System Preferences.

     

    The iCloud integration between MacOS and iOS devices has become an unintuitive and cumbersome mess. It should be.

  • Peter1066 Level 1 (0 points)

    Thanks for that gchdrake.

    This worked for me.

    I un-shared then re-shared calenders to complete

Previous 1 2 Next