2 Replies Latest reply: Nov 13, 2011 12:50 PM by KiltedTim
rgelb1 Level 1 Level 1 (0 points)

Currently my iPhone 3Gs is on iOS 5.01. I'd like to use it on the T-Mobile network. What are the steps required to make it happen?

I think it's obvious that I need to jailbreak the phone. However, googling around around it is unclear whether there is a reliable (untethered) jailbreak for 5.0x.

Do I need to downgrade the OS? If so, to what version and how? Any additional steps I need to take?

Thanks.


iPhone 3GS, iOS 5.0.1
  • wjosten Level 10 Level 10 (93,705 points)

    Sorry, you won't get any help here. The terms of use here prohibit support for jailbreaking or jailbroken iPhones. You'll have to go elsewhere. Good luck.

  • KiltedTim Level 8 Level 8 (43,110 points)

    Assuming you're in the US:

     

    1. Discussion of jailbreaking is forbidden here.

    2. You can NOT downgrade the OS.

    3. IF you were to find a way to unlock the phone, you will not get:

         3G data

         MMS messaging

         Visual Voice Mail

         Support of any kind from any official/legitimate source.

     

    If you are NOT in the US, contact your carrier to see if they offer unlocking. iPhones are supported on T-Mobile networks in many countries. The U.S. T-Mobile network is not fully compatible with the iPhone.