11 Replies Latest reply: Nov 14, 2011 2:38 PM by Gems_ca
Gems_ca Level 1 Level 1 (0 points)

Hope you can help. And I really hope I'll explain myself properly. I'm no good with computers.

 

Reverted from version 7.5.2 back to 7.4.12 today. Didn't realize that I'd updated anyway.

 

Anyway, last time I did that (yes it happened before, and that's why I didn't think I'd updated again) I was able to once again access the Internet on my Mac, as well as though my husbands Windows laptop.

 

This time, however, still no Internet, unless I plugged cable straight into back of computer, instead of Time Capsule. Funnily I was still able to use Skype when going through TC, although other Internet access was not happening at all!?

 

It seems that the only way to get on to the Internet through my Time Capsule now, is to change the 'Internet Sharing' option from 'Share a Public IP address' to 'Off (Bridge Mode)'. Mac and husband's laptop both work now.

 

My question is: Is this a good thing?

 

What is the difference between the two? Why does one setting work and not the other, when the 'Share a Public IP address' setting has always worked before!?

 

Sorry if I'm not making myself clear.


Mac OS X (10.5.8), 20" iMac, 2.66GHz , 2GB RAM
  • Tesserax Level 8 Level 8 (49,125 points)

    It seems that the only way to get on to the Internet through my Time Capsule now, is to change the 'Internet Sharing' option from 'Share a Public IP address' to 'Off (Bridge Mode)'. Mac and husband's laptop both work now.

     

    My question is: Is this a good thing?

     

    What is the difference between the two? Why does one setting work and not the other, when the 'Share a Public IP address' setting has always worked before!?

    You can think of the "Connection Sharing" option as a sort of switch that allows you to control both the NAT & DHCP services for your AirPort. When set to "Share a Public IP address," both NAT & DHCP are enabled. On the other hand, when set to "Off (Bridge Mode)," both of these services are disabled ... so it's not necessarily a "good" or "bad" thing.

     

    The reason things may be working now is that you may have another router upstream (before) the AirPort that is providing these services instead.

  • Gems_ca Level 1 Level 1 (0 points)

    Thank you for replying, Tesserax.

     

    I have an Internet tower in my yard (we are the highest point in this very rural area, and people can finally get decent Internet here with it). This is what it says on their website: ""...uses a network of towers to provide high speed wireless Internet to rural areas - Installation includes a radio receiver mounted on your roof and a cable that runs from the radio and into your house or building. The connection uses standard Ethernet cable, allowing you to simply use a router or wireless router to expand your Internet access to your other network capable devices.""

     

    Could this be the tower be 'acting' as a router?

     

    Will having the setting on "Off (Bridge Mode)" make my Internet less secure, although I have it password protected?

     

    Sorry for sounding dumb?

  • Tesserax Level 8 Level 8 (49,125 points)

    Based on the description, the router may still be something that is still being provided by the ISP. The NAT service allows multiple computers on a local network to simultaneously access the Internet using a single Public IP address. NAT, by the way it functions, prevents unsolicated inbound traffic from entering your local network as none of the devices on this local network can be "seen" from the Internet.

     

    With the TC in bridge mode, your ISP is providing that NAT function ... or, at least, I believe they are. One simple test is to see what IP addresses each of your computers are getting that can access the Internet. If these addresses start with either 192.168.n.n, 172.16.n.n, or 10.0.n.n, then they are getting Private IP addresses. If they start with something else (please don't post the full address), then they are getting Public IP addresses and they would be fully exposed to the Internet.

     

    For Macs, you can find this address using System Preferences > Network > AirPort or Ethernet (depending on how you connect your Mac to the router) > IP Address

     

    In the following screenshot, you can see that my Mac mini is connected by Ethernet to my router. It has a Private IP address of 192.168.1.114. Which is telling me that it is behind a NAT firewall.

     

    CapturFiles.png

  • Gems_ca Level 1 Level 1 (0 points)

    Apparently I'm connected via 'AirPort - Self-Assigned IP'.

     

    Under Ethernet it says 'Not connected'.

     

    Both, Mac and laptop have IP addresses starting with 169.254...

     

    When you say '...then they are getting Public IP addresses and they would be fully exposed to the Internet - I assume that's a BAD thing (yes, I know I'm sounding incredibly dumb again)!?

     

    If that's the case I am totally lost.

     

    What do I do to be 'safe' again?

  • Tesserax Level 8 Level 8 (49,125 points)

    Both, Mac and laptop have IP addresses starting with 169.254...

    If that is the case, neither device should be able to access the Internet ... except one at a time by using the Ethernet connection provided by your ISP.

     

    Would you mind providing some additional information about your ISP's service. I know that it comes in via a radio and the connector is Ethernet, but is there any additional box (make & model) number that you connect the AirPort to? Also, who is your ISP and I can try to research how they provide their service as this is a bit foreign to me.

  • Gems_ca Level 1 Level 1 (0 points)

    Well, up until now I was able to access the Internet on both Mac and laptop.

     

    Things have changed, though. My Mac is currently connected directly to the Ethernet cable.

     

    Now, trying to set Airport to 'Off (Bridge Mode)' I get the following message - 'Airport does not have an IP address + cannot connect to the Internet'.

     

    When I try and put it back in 'Off' Mode, it tells me that 'This Apple W-Fi base station doesn't have any DNS server addreeses and might have trouble connecting to the Internet' and 'the router address you have entered is not compatible with your WAN IP address.'

     

    I am pulling my hair out here.

     

    MY ISP is mcsnet.ca.

     

    Thanks for all your help.

  • Tesserax Level 8 Level 8 (49,125 points)

    Ok, they don't appear to have much information to be really helpful; however, the following caught my eye: "By default, the radio that is installed (on your roof) uses NAT translation to provide a hardware firewall which will prevent unrequested access to your internal network. The firewall on the radio (NAT) can be turned off if you have a router already (routers have their own version of NAT)."

     

    What we need to determine is if the ISP's radio has NAT currently enabled. I believe, based on this statement, that it does.

     

    I would like for you to reconfigure the TC so that Connection Sharing = Share a Public IP address. Please make the change and allow the TC to restart. Once it has restarted, we will use the AirPort Utility to verify a couple of things.

     

    First, note the IP Address provided to the Public (WAN-side) of the TC. ref: AirPort Utility > Select the TC. Note mine is a Private IP address and that's because I have my TC downstream (after) another router in my network. Again, Private IP address begin with either 10.0.n.n., 172.16.n.n., or 192.168.n.n. Anything else would be a Public IP address ... except an address that starts with 169.254 (which, as you know) is a self-assigned address. Just let me know if your TC got a Public or Private address. Please do NOT post the address if it is a Public one.

     

    CapturFiles.png

     

    Second, while still in the AirPort Utility, I would like for you to take a look at the TCP/IP tab to see if all of the fields on this tab got populated.

     

    Here is an example of mine. Again, note that my TC's IP address is a Private one. So is the Router Address. The DNS servers just happen to be those provided by OpenDNS and the values here would not necessarily match yours. That would be because your ISP would be providing the DNS server addresses. Also note that Configure IPv4 = Using DHCP. What this means is that your TC will query the ISP's router for this address information. If this query fails, that meant that the TC couldn't find the ISP's router ... and the TC would be give itself a self-assigned IP address instead.

     

    CapturFiles.png

  • Gems_ca Level 1 Level 1 (0 points)

    I really appreciate you taking the time to help me.

     

    I am just about to pull my hair out, though.

     

    I now can't access Airport at all.

     

    When opening Airport Utility I get the message  -   'AirPort Utility was unable to find any AirPort wireless devices. Make sure the AirPort wireless device you want to set up is plugged in and in range of your computer, and then click rescan to try again.'

     

    Well, I haven't moved or changed anything.

     

    I can't get to Manual Setup to check anything.

     

    HELP!!!

  • Tesserax Level 8 Level 8 (49,125 points)

    When opening Airport Utility I get the message  -   'AirPort Utility was unable to find any AirPort wireless devices. Make sure the AirPort wireless device you want to set up is plugged in and in range of your computer, and then click rescan to try again.'

    If not already, please connect your Mac to the TC using an Ethernet cable. You should be able to access it with the AirPort Utility now.

  • Gems_ca Level 1 Level 1 (0 points)

    No. Tha'ts not working at all now!   

  • Gems_ca Level 1 Level 1 (0 points)

    I guess I'm going to town tomorrow to buy a new router!

     

    I haven't been this peeved off in a long time!!!!!

     

    I guess, unless you have some more advice for me, I'd like to say thank you for really trying to help me!

     

    Still hoping you come up with a magic solution!  lol

     

    Anyway.....