6 Replies Latest reply: Nov 17, 2011 8:00 AM by alexandreh
TomFr Level 1 Level 1 (0 points)

I live in France and I'm a subsriber of the ISP "Free".

This ISP provides with a DSL router "Freebox ADSL" and an IPTV box "Freebox HD"

 

The link from the router box to the IPTV box is either Wi-Fi or Ethernet.

I choosed to use Ethernet.

 

I have the current setup:

 

DSL router ---- Airport Extreme (bridge mode) ---- Computers & a basic GE switch ---- IPTV box.

 

This setup worked just fine for years, until I recently updated to firmware 7.6 on the Airport Extreme.

The IPTV box would no longer start, if connected directly to the DSL router, it starts just fine.

 

After some tests and searching, I finally found that the two boxes are talking to each other over a dedicated VLAN (VLAN 100).

And it seams that version 7.6 is now filtering the ethernet packets with VLAN information.

 

Reverting to 7.5.2 solves the issue instantly.

Upgrade again to 7.6 brakes my IPTV immediatly.

 

Anyone has any idea ? Any hidden setting or tweak to restore VLAN bridging in 7.6 ?


Airport
  • Mel Beckman Level 1 Level 1 (40 points)

    Alas, that it worked before was a fluke -- Apple Airport should never have been bridging 802.1Q tagged VLAN packets. By definition an Ethernet bridge only bridges untagged packets unless it is explicitly configured to transport tagged packets to another 802.1q-capable device, and then it should only pass those packets to across an interface if the receiving device is programmed to expect and accept tagged packets..

     

    Ref: http://en.wikipedia.org/wiki/Virtual_LAN

    "By definition, switches may not bridge IP traffic between VLANs as it would violate the integrity of the VLAN broadcast domain."

     

    So Apple was just fixing a bug, and you have a network that depended upon that bug. The correct fix in your case is to add a router to your LAN that can route traffic between your native LAN VLAN and this VLAN 100. That will requires creating two separate IP subnets and attaching them to the router device. Fortunately, the cost of layer-3 switches that support both VLANs and inter-vlan routing has come down quite a bit, to aabout $2300 (e.g., the Cisco SG 300-10). You'll have to learn the techology, but it's pretty straightforward and the Internet is chock full of tutorials.

  • TomFr Level 1 Level 1 (0 points)

    I must had missed something in the statement of my problem/explanation...

    I am not expecting the airport extreme to bridge one vlan to another !!! (you are fully right this would be a bug).

    All I'm expecting is the airport to transport vlans as they are, like a plain switch would do: vlan 100 stays vlan 100, vlan 1 stays vlan one, default vlan stays the same (like it probably did before)

  • Mel Beckman Level 1 Level 1 (40 points)

    Not all switches will pass tagged packets. Because the tag adds four bytes to the packet length, large packets can exceed the MTU of the switch, resuiting in dropped packets and very strange behavior (only when large packets occur).

     

    From one VLAN info source (http://www.javvin.com/protocolVLAN.html):

     

    "However, it is important to ensure ports with non-802.1Q-compliant devices attached are configured to transmit untagged frames. Many NICs for PCs and printers are not 802.1Q-compliant. If they receive a tagged frame, they will not understand the VLAN tag and will drop the frame. Also, the maximum legal Ethernet frame size for tagged frames was increased in 802.1Q (and its companion, 802.3ac) from 1,518 to 1,522 bytes. This could cause network interface cards and older switches to drop tagged frames as "oversized.""

     

    In any event, it's not cricket to have tagged packets bouncing around on your LAN -- that definitely violates the broadcast domain sanctity of a VLAN. The Airport was wrong to transport tagged packets, and now they've fixed that bug. You have to implement a properly VLANed network to accomplish what you want.
  • alexandreh Level 1 Level 1 (0 points)

    Hello

    I'm in france too, II have the same problem with the 7.6 it break immediately the ethernet output port from the airport extreme. When I go back to the older firmare, everything works fine.

    So I can't upgrade to 7.6.

    for the record I have a freebox V6 router for free provider.

  • Mel Beckman Level 1 Level 1 (40 points)

    If 7.6 completely disables the Ethernet port, something else is wrong. Have you checked the configuration to make sure bridge mode hasn't been turned off?

  • alexandreh Level 1 Level 1 (0 points)

    Yes I check twice. I started the extreme confid from start, but nothing works. At the end I backgraded to 7.5.2, and magicly it works immediately??!!

    I tryed to tweak here and there, restart but everything failed.