5 Replies Latest reply: Dec 25, 2011 11:16 PM by yee lim
cxatter Level 1 (0 points)



When I download a PDF in safari and tap the open in iBooks button iBooks opens but the PDF does not download into there. I am running ios5.1 on an iPad 2. I have many books and some PDFs on there all open and work ok but it's when I try and add the issue arises.


Any guidance would be great.



  • ocsurfer411 Level 1 (0 points)

    I have encountered this same issue on iOS 5.0.1


    When I was running the earlier 4.x iOS, I could easily open any PDF that was within Safari or attached to an email and open that and manage it via iBooks. But now with iOS 5.01, when I select "Open in iBooks" the iBooks app opens, but nothing else happens.


    I can open PDFs in Adobe Reader as normal, but I really like to manage my PDFs within iBooks, so I hope there is a work around or this is fixed soon.

  • s1larson Level 1 (0 points)

    You posted this in November, and nothing?  This more or less makes my iPad usless since I primarly use it for research.  So, I am wondering if I can revert back to a previous version, if there is a work around, or if I should just pack it up and put it away, and go back to my PC till apple gets around to fixing this!!!  This is crazy frustrating...   Anyone know a workaround??

  • s1larson Level 1 (0 points)

    Thank you!!  I was also coming back to update this, I dont know how I fixed it, but its working now.  I installed the Opera mini browser, pdf free reader, cloudreaders, pdf-notes.  I tried to open it in Opera, but it opened the pdf in safari, and then in ibooks, and it is working...

  • bennym101 Level 1 (0 points)

    I had the exact same problem, and after reading your post s1larson I downloaded the Opera mini browser, and it worked exactly as you described. I can't explain why it worked, but now I can open PDFs in iBooks from safari as I was able to prior to the ios5 upgrade. So if anyone else has this same problem try downloading the Opera mini reader and it might help....

  • yee lim Level 1 (0 points)

    Tried the same thing by installed the opera mini browser.. It did open in safari but still couldn't open the PDF with iBooks.. Even I tried to download a book from apple store and it also cannot open in iBooks.. Pls help cos it's really frustrated me!!


    iPad 2 iOS 5.0.1