Previous 1 2 Next 15 Replies Latest reply: Sep 12, 2012 2:26 AM by mcg-
benwiggy Level 4 Level 4 (1,005 points)

I've  noticed several issues with PDF workflows in Lion that seem to have gone wrong. Whether deliberately or not, I don't know.

 

1. If you Export a PDF from Preview with a Quartz Filter, that filter is not applied to the copy of the PDF in Preview's window, though the file on disk does get the filter applied. If you close and reload the PDF, the effects of filter will be displayed.

 

2. If you create a new Quartz Filter in ColorSync Utility, it doesn't work.
Even duplicating an existing system filter, like "Gray Tone", doesn't work when you apply it to a PDF document in ColorSync Utility.

 

3. If you do have any user quartz filters, they don't show up in Preview's Export file dialog, unless you copy them from ~/Library/Filters to ~/Library/PDF Services.
There are several webpages about this.

 

4. Save As PDF-X has disappeared from the PDF button of the print menu.
I have seen other webpages that mention this.

 

All these issues are on both of my Macs, so I don't think it's a local problem, though I would be grateful for any confirmation.


iMac 2006 2Ghz, Mac OS X (10.6.7), MacBook 2008
  • John Blanchard1 Level 5 Level 5 (5,030 points)

    Have you sent feedback to Apple about this? Regarding 4, Apple probably removed this to simplify the dialog, thinking that something similar could be added with Automator.

  • benwiggy Level 4 Level 4 (1,005 points)

    I've sent bug reports about 1 and 2.

     

    Trying to create a Save As PDF-X PDF Service doesn't work either, as you don't get a file save dialog, if you construct an Action with "Apply Quartz Filter".

    I tried copying the Snow Leopard PDF-X workflow into Lion, but it fails to save with an error. (Can't remember what it was, but it wasn't helpful.)

  • benwiggy Level 4 Level 4 (1,005 points)

    I've now tested these problems on several Macs in an Apple Store, with exactly the same results.

     

    User Quartz Filters are BROKEN in Lion.

     

    I spoke to a "Genius" about it, and he "felt sure that Apple would be working on it". Although he didn't know what a Quartz filter was until I showed him, so I'm not over-confident.

  • benwiggy Level 4 Level 4 (1,005 points)

    Sorry, I should correct point 1 in the original post:

     

    If you Duplicate a PDF in Preview, and then Save it, applying a Quartz Filter in the save dialog, then the Preview window displaying the PDF does not have the filter applied to it. This even though the filename (and path) in the window title point to the newly saved file. Closing and opening the file displays it correctly, with the filter applied.

     

    Using Export keeps the original file in the window, not the exported version, which is what you would expect.

     

    However, I'm surprised by the lack of response.

     

    No one ever used the PDF-X workflow in Snow Leopard? No one uses Quartz Filters?

  • PJ'sPal Level 1 Level 1 (35 points)

    I have found the PDF-X workflow to be broke as well lately.

    It is something I used infrequenty with Snow Leopard to embed fonts into PDF documents.

    I never could figure out an easy way to embed fonts in Accrobat Pro and always went to Preview to do so.

     

    I don't work much with color so I am not using filters.  I just want the PDF-X workflow to work as it did in the past.

    I no longer see the save window pop up requesting a new file name for the PDF-x file.   Obviously there is a bug in Preview as I still have the pull down menu with the opition of a PDF-X file.

  • benwiggy Level 4 Level 4 (1,005 points)

    Err.. if you have Acrobat Pro installed, then you should have no need of Apple's built-in abilities. Use the "Save As Adobe PDF" workflow in the PDF menu, and you will be presented with a dialog to choose which PDF settings you want to apply.

    It should be easy to implement a PDF setting that embeds fonts and creates a PDF-X standard document.

     

    The bug is not in Preview, this happens in any app. The PDF-X workflow is removed in Lion. If you still have the workflow in your menu, then it may be left over from your previous OS installation, or something you've installed from somewhere else.

     

    I am working on trying to build a print workflow that will work on Lion, but this is something that Apple engineers are going to have to look at.

  • PJ'sPal Level 1 Level 1 (35 points)

    Thanks Benwiggy for that tip.

     

    I am still running Snow Leopard due to things dropped in Lion.

    I needed fax capability before I could move to Lion.

    I was also waiting for the bugs to get worked out because I will lose some time when changing over.

    I still have the menu item with Snow Leopard but the work flow for PDF-X is now broken as well.

     

    I have not always had Acrobat pro. 

    I am famialure with inserting, extracting, and typing information on PDF documents as one would need to do in an office.

    I had always used preview and the PDF-X "save as" feature to embed fonts. 

     

    I see there is a save as format to  "PDF/X" in Acrobat Pro v9.0.

     

    There is a settings button next to the save as box.

    It has four different settings or flavors of PDF/x:

     

    PDF/X-1a

    PDF/X-3

    PDF/X-4

    PDF/X-4p. 

     

    Then there is a conversion box that allows input of a "conversion profile".

    There there is a viewing or printing condition box as well. 

     

    As you can see I don't work with colors much.  It is all about preserving the text and images in a document as everything is usually black and white or grey scale.

     

    What setting for PDF/X would you suggest if "font" embedding was an issue and it was desirable to preserve the text and images as they were, without regard to color correcton.

     

    Thanks in advance for your reply.

  • benwiggy Level 4 Level 4 (1,005 points)

    This is straying off topic into "general techniques for using Acrobat" rather than "bugs in Lion".

     

    Almost all of the Acrobat supplied PDF settings should embed the fonts. If you are still having trouble I would suggest starting a thread on Adobe's discussion pages.

     

     

    I have worked out a way to get a "Save As PDF" print workflow in OS X.

    Copy the "Create Generic PDF/X3 Document.qfilter" file from /System/Library/Filters to ~/Library/PDF Services.

    Open it in a text editor, and change both the numbers in the "FlattenTransparencyResolution" key from 72 to 300.

     

    The filter will show up in your PDF button of the print menu and will save PDFs to the Desktop.

     

    Using ColorSync Utility will damage the filter and cause it not to work (the PDF will be saved, but it won't be X3).

  • Hotrodfil Level 1 Level 1 (0 points)

    So has anyone had any updates to this. Just moved to Lion - from Tiger! - and pretty much everything is fine apart from the lack of being able to use Quartz filters when printing. I used to be able to modify the Black and White filter to allow printing of CAD files. Now I get a hopeless Greyscale output where the text in yellow or green on screen becomes unreadable. The workaround of saving a PDF and applying the Quartz filter from Preview is quite frankly hopeless when I have around 100 files to process.

  • benwiggy Level 4 Level 4 (1,005 points)

    Quartz Filters are broken in Lion, and it doesn't look like they're going to be fixed. They have been fixed in Mountain Lion.

    The problem is that user filters are created incorrectly. You can duplicate the OS system filters from /System/Library/Filters, modify them in a text editor, then place them in ~/Library/Filters.

    Existing filters from earlier OS versions should still work.

     

    Hotrodfil, can you explain your workflow in more detail? Existing System filters should still work. How are you batch processing your files?

  • Hotrodfil Level 1 Level 1 (0 points)

    I use Ashlar Graphite. Typical CAD package with a black screen, I distinguish different line weights and styles with different colours. Outlines in white, hidden detail in cyan, thin lines magenta etc. Text typically in yellow, dimensions in light green. When I print I want the drawings with lines and text all in black for the engineers to read. Never used to be a problem back in the days of OS7-9 or in fact the early days of OSX. Black and white printing was just that.

     

    Anyway - a change of printer years ago gave me greyscale and I worked out that modifying a copy of the Quartz BnW filter gave me solid black lines. The stock filter just did a threshold losing the yellows and other light colours. Taking the saturation right down and modifying the brightness for the dark/mid/light worked a treat.

     

    Hard drive died on the old Mac so I doubt I have a copy of my old modified filter. Y'reckon they're fixed in Mountain Lion?

  • benwiggy Level 4 Level 4 (1,005 points)

    Are you talking about using a Quartz Filter in the print menu? This should still work. The problem lies in creating them in ColorSync Utility.

    You may be able to modify the filter usng a text editor.

     

    Yes, they're fixed in 10.8. I would be surprised if we see much more support for Lion for very long.

  • Hotrodfil Level 1 Level 1 (0 points)

    I've created the filter in ColorSync just fine. But it doesn't appear anywhere in the Print dialog. Moved it into PDF services as you suggested somewhere and it appears in the Export dialog box in Preview. Saving the file to the desktop and reopening it gives me the black and white file I need for printing so I know the filter is working OK - it's just I can't use it direct when I print which is a severe workflow handicap.

     

    I've just had a Zerox service engineer in here with Mountain Lion - still can't see where I can print using a Quartz filter? Screenshot anyone?

  • mcg- Level 1 Level 1 (20 points)

    10.8.1 and Preview version 6 :

     

    It's not working for me.

     

    I have tried all the combinations I can think of with a colour PDF to make it grey scale.

    Export, duplicate, save as pdf etc

     

    I have also tried opening the pdf in colorsync (4.8.0) and whilst I can get the greyscale to convert the doc on the screen, when I export or save as it doesn't stick.

     

    I've tried opening the converted pdf's in other apps to see if the settings have stuck but appears not (though I don't know enough about this stuff, maybe colorsync is used regarless of the app)

     

    Also with colorsync when I hit 'apply' (whilst having a greyscale version showing on screen) it actually changes back to a colour doc - just when I thought I may have found a work-around..

Previous 1 2 Next