9 Replies Latest reply: Nov 24, 2012 9:50 AM by jerrywz
lundejd Level 1 (10 points)

iTunes match is working well for me, including on my iPad.

However, on my iPhone 4S it did not sync my playlists correctly so I turned it off.. now it seems stuck between on and off. On the iPad if I turn iTunes Match off, it takes a little while but eventually its clear and only local music is shown.

Right now the iPhone won't sync up complete nor will it unsync itself.

I've tried setting "use cellular data" on, been on my wifi for hours waiting, tried resetting network settings, turning phone on and off....


  • Fredrrr Level 2 (150 points)

    You might try de-listing the iPhone as an approved device than re-listing? (Make sure you turn it off and on between those steps).


    Just a thought.

  • mkiitmr2 Level 1 (0 points)

    Where do I de-list a device?  I too am having issues disabling itunes match on my 4s. 

  • mkiitmr2 Level 1 (0 points)

    I think turning itunes match off while it is still trying to load something causes hiccups. So you need to start fresh again as best you can.


    Here is what I did.  First I went to Settings>General>Usage, then in the storage section, I tap on Music app, then hit the edit button and then delete(This will delete locally store music so be sure you have a backup in the cloud or on your computer first).  Now I turned ON itunes match on the iPhone while connected to wifi.  Then I opened the Music app and waited for the pinwheel to go away(loading album art etc).  So at this point, there is no physical music on the iphone, however I have access to and see all of my music in itunes match available for download.  Then I went back to settings and turned OFF itunes match on the iPhone.  If this has worked correctly and everything is gone, it should say "No Content, You can download music from iTunes"  when you open the music app.  If it does not or you see a playlist or genius or anything, then there is still something left over.


    From here, I chose to sync my music via itunes and leave itunes match off on the iphone.  You may want to try turning itunes match back on the iphone if thats what you are wanting.

  • leegottheimer Level 1 (0 points)

    This fix worked for me. Hopefully iTunes Match will get some serious TLC soon. I miss the genius feature, the ability to listen to my own songs when away from wi-fi, and just a general sense that my iPhone isn't mistreating me.

  • Burksey Level 1 (0 points)

    If that does not work, like in my case you can turn off your macbooks or pc's ituens match by going to the itunes store and click on turn off itunes match.( that is supposed to completly disable your itunes match account as per apple tech support) That helped a little bit more, but what totaly fixed the problem for me was to do a restore on my iphone 4s. Im sure itunes match will be great once they get it working properly, but for now I am going to stick to the tired and true way of manually managing my itunes.

  • Sloeberry Level 1 (0 points)

    I've had this problem too. Nearly ended up doing a restore, but managed to get the phone to realise that ITM was off by simply signing out of the Store (Settings > Store > Apple ID) then signing back in after a phone reboot. To be honest I'm not 100% that this will work every time, and I'm sure not inclined to try and recreate the mess in order to find out!


    ITM is a good idea poorly realised, or perhaps Apple have simply raised our expectations too high. My cellular data deal isn't good or fast enough to make it work on my 4S away from WiFi, and it's rare that I feel the need to download my own music away from home (where I can simply USB to my iMac, oh the effort of it). Time will tell if I mantain my subscription...

  • jcohoon Level 1 (0 points)

    mkiitmr2's solution appears to be working for me. thank you!

  • Al Swearengen Level 1 (75 points)

    I was having this same issue.  Nothing I tried worked.  I finally contacted iTunes support via email.  I got the following response and it worked like a charm!


    1) Quit App Store in multi-tasking.

    ***Please close all open apps on your phone***

    2) Tap Settings.

    3) Tap Safari.

    4) Tap Clear History.

    5) Tap the Clear History button.

    6) Tap Clear Cookies and Data.

    7) Tap the Clear Cookies and Data button

  • jerrywz Level 1 (0 points)

    thanks. this really works for me. KISS YA