Previous 1 2 3 Next 33 Replies Latest reply: Mar 10, 2015 1:00 PM by Meg4Roney Go to original post
  • francis154 Level 1 Level 1 (0 points)

    Hi thanks very much for the tip - I've been trying it - sadly, although I now have the options, for ever format I try I get the same message - that a protected file cannot be converted - and this applies to all of the files that did not transfer and almost all of those are from i-tunes - shucks.

  • jaretw Level 1 Level 1 (10 points)

    when did you buy them? maybe they still have drm? I'm not sure because I don't buy music from iTunes. Try burning them to cd and then importing again, see if that works.


    you should be able to access your itunes purchases on your other devices though. on your iDevice go to Settings>store and turn automatic downloads for music ON and you should be able to see all of that music that you've purchased on your device

  • davicondi Level 1 Level 1 (0 points)

    For what it's worth, I had one specific album that I really wanted in the cloud, but it refused to go.  After reading this article I converted all the songs in the album to AAC and deleted the originals.  Worked like a charm.  Never would have considered converting the files.  Obviously iCloud still has a few glitches.  Love it anyway!  So convenient.

  • ninnoichi Level 1 Level 1 (0 points)

    I am getting this error on Apple Protected AAC files (.m4p) files that I bought from Apple some years back and which the label has pulled them from iTunes, so I can not re-download them, despite my having purchased them legitimately through Apple. I am also getting the error, "This item was not added to iCloud because an error occurred." on selected tracks of ripped CDs I own; but only on one track out of the whole album.


    For example:

    1. Anatawo Omouhodo by MAX as part of the EP Anatawo Omouhodo, purchased on 29 December 2006 at 09:46 ET (01 Anatawo Omouhodo.m4p). The label is Avex Trax which no longer allows most, if not all of its acts to be in iTunes, possibly in protest of iTunes Match. I have this issue with all four tracks from the same EP.
    2. We Have All The Time In The World by Louis Armstrong as part of James Bond - 13 Original Themes (CD I imported into iTunes

    In all, I have 30 such tracks throwing the error, "This item was not added to iCloud because an error occurred."

  • spideylobster Level 1 Level 1 (0 points)

    The tracks I had that had the slash through them I converted to AAC in iTunes and it worked.  They uploaded immediately.  The tracks I had with an exclimation point next to them I converted the ID3 tags to the latest version (2.4 i think)  and then they immediately uploaded.


    This worked for me, hope it helps.

  • RiRi85 Level 1 Level 1 (0 points)

    It worked slightly different for me - i'm still having an issue of tracks added to my library until i have closed and re-opened itune - thats a whole other story . . that is relevent however ..


    I followed the suggested method of "creating an mp3" and then because of the above problem i closed and re-opened itunes so the newly created tracks would show. Because i had closed and re-opened the tracks marked with "error" try to upload/match again - i then hit "add to icloud" on the duplicate tracks and miraculously the original track matches all of a sudden! so i then deleted the duplicates.


    This is great because as previously mentioned by others some of these tracks are on playlists so i dont want to got through re-adding them etc, but this got the originals working for some starnge reason - and im pretty sure its not ust because i closed and re-opened itunes because i had already dont that a few times since my library finished matching so wouldve fixed itself before now.


    still, very annoyed that i am having to spend my time searching for solutions, havn't had the guts to enable match on my iphone yet for fear of royally screwing up my playlists - i go on holiday next week and would be very angry with no music with me, and dont have any time to mess around with it if it goes wrong! kinda trialling it on my ipad - my favourite playlists arent loading so not happy after taking the punt on paying the subscription.. dont get me wrong i will persist because i know in theory match is just needs a little time that's all!

  • Alex Wasserman Level 1 Level 1 (0 points)

    For those confused by the MP3 conversion, or reasons why some work and some don't, I think this is the answer:



    Also, is helpful.


    In short, songs need to be encoded at 96Kbps or greater. Typically, older MP3s, for people trying to save space might have been encoded at less than this. I found a bunch of mine were.


    As for converting them to MP3 again, iTunes will show a 'Convert to <format>' option where the format depends on your specific import settings defined in your "Import Settings" on the General tab of iTunes preferences. In terms of iCloud it really doesn't matter if you use MP3 or AAC, just as long as it's above 96 Kbps which all modern settings are.


    So, right-click on any songs that have a lower bitrate, upload the new versions and trash the originals. Worked fine for me.



    Now, as for those that were ineligible because they're protected, I found that I had a whole load duplicated, because iTunes had grabbed matched copies and left the original protected versions in place. Do a "Show Duplicates" and see if that's happened to you to. I trashed by original protected versions and kept the new purchased versions. The purchase date will show you the latest version. I found iTunes had already added them to my iCloud.


    The only things I can't upload to my iCloud are the songs from my kids purchased with their own apple IDs, not mine. Those are few and far between and can't be helped.


    As for "An error occured", I have no idea. I only have 4 out of over 6000 songs. A couple of those I bought from the iTunes store, so it not being able to match surprises me.


    Hope that helped.

  • andreaskmueller Level 1 Level 1 (0 points)

    select the ones that failed upload, right-click and pick convert to AAC. Once converted, delete the original songs that had failed, highlight the new AAC versions and click upload to icloud. That should work w/o problems - fixed all my issues.

  • Eric Welch1 Level 1 Level 1 (25 points)

    That must be correct. I just added Van Halen's "A Different Kind of Truth" from Amazon ($2.99 sale) and no problem. But I uploaded "The Orange Mountain Music Philip Glass Sampler" from Amazon and it was removed from iCloud. Obviously, when you pay, no problem, but freebies from Amazon are not eligible. Go figure.


    Message was edited by: Eric Welch1

  • meggiers Level 1 Level 1 (0 points)

    I had this same issue.  And I tried your solution and it didn't work.

  • Milkman76 Level 1 Level 1 (0 points)

    That was a helpful tip! It works! I've written a step-by step walkthrough with screenshots for those who might get confused along the way: m-was-not-added-to-icloud-because-an-error-occurred/

  • bubu92 Level 1 Level 1 (0 points)

    Does anyone find a solution for people who ripped their CDs in Apple Lossless format?

  • melonhead21 Level 1 Level 1 (0 points)

    I too have several songs from CD's i copied into iTunes in lossless format on my iMac. (i call that the master library) I have iTunes sharing service.

    95% of them are in the cloud fine. However there are 10 with cloud icons with no exclamation point inside them and 10 with with cloud icons with exclamation points in them. All of the rest of my songs have no cloud icon next to them and they appear in my iPhone music list fine. Those  songs that do have the cloud icons (either with or without the exclamation point inside) appear on my iPhone but are greyed out and CANNOT BE PLAYED from my iPhone.  They play on my iMac in iTunes however.  Have you discovered how to handle this? I even tried re copying the CD with the majority of the problems but it made no difference.

  • Turbopgt Level 1 Level 1 (0 points)

    New iTunes 11.0.3 today....hoping it brings a fix to uploading lossless.....

  • Turbopgt Level 1 Level 1 (0 points)

    iTunes 11.0.3 has fixed this issue for me! Hopefully for you all as well