11 Replies Latest reply: Jan 13, 2012 9:41 PM by rodolfosalgado
josh1015 Level 1 Level 1 (0 points)

After I turned on iTunes Match, all of my music was deleted off of my iPhone 4. Although it was inconvenient, I didn't see this as the biggest problem in the world. I went to sync my iPhone with iTunes to get my selected artists onto local storage again only to find that now I was trying to load my iPhone "over capacity." How did I go from having 9.3gb of free space left before updating to 10.5.1 and turning iTunes Match to being 3.3gb over capacity afterward. I haven't added any artists, I've kept my setting to convert higher bit rate songs to 128kbps. The number of songs that I tried to load onto my iPhone has remained the same as well. I tried removing unchecking all the artists names and then applying the settings and then rechecked them all only to find it still brought me over capacity. Any idea what's going on here?

 

Thank you


iPhone 4, iOS 5.0.1, 32gb
  • ColoradoDan Level 1 Level 1 (0 points)

    I have the same issue.  I turned on iTunes Match and then discovered that because the iCloud music is of higher quality I was unable to have as many songs downloaded on my iPhone so I turned it off.  Then when I tried to sync my iPhone with itunes the old way I was "over capacity"  As a result, I can now only synce a subset of my play lists until this issue is resolved.

  • klkenney Level 1 Level 1 (5 points)

    I found a way. In iTunes pull down the "store" tab on your menu bar and then click "turn off iTunes match." Once you do this you will be able to convert your songs to a lower bitrate when transfering to your devices. However, if iTunes Match is enabled on your mobile device it will not let you convert them. For you to continue to fit all your music on your mobile devices you will constantly have to toggle between turning on and off iTunes Match on your computer. Bummer.

  • John Dorsey Level 2 Level 2 (410 points)

    This seems like a bug to me - or at least, poor design.  In other words, if you have iTunes Match enabled on your computer,  iTunes will fail to honor the 128kbps downsample option for iOS devices regardless of the settings on the iOS device.  There is no indication that iTunes is doing this, other than the error message that your device, which previously held all your songs at the lower rate, is now overcapacity and can't be synced.

     

    iTunes should obey the settings on each device.  (Otherwise why bother with settings?)  That is, if I have iTunes Match turned off on the device then the device should behave as if it had never heard of "iTunes Match".  Failing that then the options screen in iTunes should grey out the 128kbps downsample option, because whether or not it is checked, it does not work.

  • Tom Dibble Level 1 Level 1 (20 points)

    I have the same problem as well.  Following klkenney's advice worked for me as well:  as soon as I turned off iTunes Match in iTunes, then clicked "Sync" on the phone settings page (I had the phone already plugged in; when I turned iTunes Match on the phone settings page still reported over-capacity) the thermometer guages again showed as accurate.

     

    Note:  with iTunes Matche turned on, music was downconverted to 128kbps.  I could verify this by clicking the disclosure triangle on the sidebar for my iPhone, then clicking "Music".  While things were syncing over, everything said the source iTunes bitrate (ex, 320kbps or 256kbps), but as soon as a song was copied over to the phone it said 128kbps across the board.  Looking at the phone itself, the Settings > General > Usage tab confirmed that I had much less on the device in music than iTunes was reporting.

     

    The problem was not that things didn't get downconverted.  The problems are:

     

    1.  The iTunes guage misreports the Music contribution

    2.  The Sync process only downconverts and copies over as much music as it thinks will fit, which is based 100% on the size of the music files on the computer, not on the device.

     

    Both of these IMHO indicate a poor software design which should be fixed.  The guage and the sync calculation should start from a direct report from the device regarding how much space is being taken up by certain items, then add in the space it thinks will be needed for the additional items and subtract the space it thinks will be saved by removing items.  Doing things this way wouldn't completely fix the bug (because iTunes would still overestimate the size needed for any added tracks), but would alleviate it significantly.

     

    This fundamental design flaw also explains the behavior I was seeing with my old 5G iPod, which would "think" that much less (about 0.1GB) would fit on than would actually fit on the device.  Given that I was maxing out the space on that old iPod, this bug in estimation was painful there as well.

  • Tom Dibble Level 1 Level 1 (20 points)

    Quick update:  I had thought that it hadn't copied over all my music when iTunes Match was on; it in fact had (I just had a lot of music "unchecked").  Looking at the size of the music it copied over in iTunes adds up to over 100GB; my iPhone is only 64GB, so iTunes obviously synced more than it thought would fit.  I was confused by the fact that the "Music" tab included the unchecked songs in its total, so the iPhone showed fewer songs than the "Misic" tab suggested.  Creating a smart playlist containing only the checked songs in my library, however, showed the real number of checked songs, which matched what was on the phone.

     

    So, the second "bug" above is incorrect.  While the guage complains that the phone will be over capacity when synced, the actual sync still includes all music.  So, this is a cosmetic issue rather than a functional issue.

     

    I'm turning iTunes Match back on on my iTunes and continuing to sync my phone.  I'll just ignore the gauge reading when I sync

     

    Also, I reported this as a bug using the iTunes Feedback form.  Hopefully that ends up getting to the right people.

     

    IMHO, it would be a nice feature on the iOS phone and for iTunes Match if the iPhone could have a setting where all music downloaded from iTunes Match would get downconverted to 128kbps.  This would have avoided this issue entirely for me and I think everyone else above; it is our "surprise" that such a feature didn't exist that caused us to stumble into this other bug in the first place.

  • josh1015 Level 1 Level 1 (0 points)

    What would be REALLY nice is if Apple allowed you to keep the music already locally stored on your device and then just download whatever else is in the cloud on an as-needed basis--exactly the way it works in iTunes. Very disappointed that iTunes Match replaces the entire library on my iOS device. It makes using shuffle near impossible.

  • Tom Dibble Level 1 Level 1 (20 points)

    Interestingly, on my iPhone (a 4S), turning iTunes Match on did NOT (despite the big red-button warning) delete my synched-over music.  I'm not sure why it happens on some but not others; I had thought (given my small sampling of reports from others around me) that the libraries were only being wiped out entirely on iPads from some reason, but it sounds like it's more than just that.

     

    In my case, after I saw the gauge say my music and apps wouldn't fit on the iPhone, I turned music synching off (which did wipe all the music off the phone).  Although, come to think of it, I didn't ever do a device sync to iTunes with iTunes Match on on the phone, so maybe it's that first synch after you turn it on that wipes all the old music off?

     

    In any case, there are definitely some areas where Apple should be working on applying some polish here.  It's far from the "just works" standard we (often unrealistically) expect from Apple!

  • ChicagoDevGuy Level 1 Level 1 (0 points)

    I'm having a similar, if not identical issue. I have a 64GB iPhone 4S and have enabled iTunes Match. Before re-downloading my music from the cloud, I made sure to remove all existing music from my device. Note that I *do not* want to have it converted to 128kbps - I prefer the higher quality files, which is why I have a 64GB device.

     

    So, here's the situation:

     

    1) On my device, it reports that it has 21GB of available space.

    2) When I connect to iTunes (either via a cable or over WiFi) ITunes briefly sees the correct amount of free space and displays it in the capacity bar.

    3) After attempting to sync, the sync stops and the capacity bar indicates that I am over capacity by 5.7GB.

     

    Would really know what is going on here since I can't sync my podcasts or video now.

  • lordeagle Level 1 Level 1 (0 points)

    Same exact issue (except of course the amount are different). Found a solution yet?

  • kirbyfromtrenton Level 1 Level 1 (0 points)

    This morning I figured out what causes this. When you use iTunes match, iTunes match manages the music on your iPhone. Problem is, if you have not deleted all the songs on your iPhone first, then iTunes still sees them as on your phone even if you've deleted them on your phone.

     

    Here is the fix:

     

    Turn off iTunes match in iTunes.

    Turn off iTunes match on the iPhone.

    Close iTunes and reopen.

    Connect your iPhone.

    Go into your music folder for the iPhone and delete all the songs.

    Turn back on iTunes match in iTunes

    Turn back on iTunes match on the iPhone

  • rodolfosalgado Level 1 Level 1 (0 points)

    Thanks mate, worked for me your solution!