6 Replies Latest reply: May 8, 2012 11:49 AM by mac-ct
slv1970 Level 1 Level 1 (0 points)

tell me how to configure the service. When the service starts, not all updates are downloaded from the site of apple.com.


Mac Pro, Mac OS X (10.7)
  • 1. Re: mac os x lion server service software update
    John.Kitzmiller Level 3 Level 3 (870 points)

    How long are you waiting? It can take several hours (or even a day or 2) to download all of the updates from Apple, depending on your connection speed.

  • 2. Re: mac os x lion server service software update
    slv1970 Level 1 Level 1 (0 points)

    Already two months. I have two servers 10.6 and 10.7. On the server service is running 10.6 seems to be OK, but only 10.7 of the pumped updates. At the same stroiki servers. And for some reason, there is no fileindex-leopard-snowleopard-lion.sucatalog.

  • 3. Re: mac os x lion server service software update
    eljonco Level 1 Level 1 (20 points)

    Same problem here. More specifically, the log seems to indicate that a list of available updates is downloaded, but the actual updates are not downloaded. The log is chockful wit this kind of errors:

    swupd_syncd[2108] <Warning>: *** Missing version string for product 061-6809

    and

    swupd_syncd[42687] <Error>: Download for "Deprecations.plist" failed (reason: The operation couldn’t be completed. (NSURLErrorDomain error -3001.))

    and

    wupd_syncd[42687]: Download for "iMacFirmwareUpdate.smd.downloading" failed (reason: The operation couldn’t be completed. (NSURLErrorDomain error -3001.))

     

    Is it because I messed up my DNS settings? Then I'd like to restore factory defaults for the server, trading the current setup with only a few users and confused server for a clean sheet. How to do just that?

  • 4. Re: mac os x lion server service software update
    buffalo-joe Level 1 Level 1 (0 points)

    I don't know if you've found the solution to this problem or not, but I just encountered it and appear to have solved it. The problem in my case was permissions, but according to Apple's documentation, this means that "

    [...] NSURLDownload was unable to open the downloaded file on disk." which implies that it could be permissions, not enough free space on the disk, etc.

  • 5. Re: mac os x lion server service software update
    Laurent Cole Level 1 Level 1 (10 points)

    I have the same problem since a few days.

     

    <Error>: Download for "Deprecations.plist" failed (reason: The operation couldn’t be completed. (NSURLErrorDomain error -3001.))

     

    So SUS doesn't download new updates.

     

    Everything worked fined, nothing has been changed.

     

    I repared permissions, I have enough space on my disks.

     

    Any ideas to solve this would be great.

     

    Thanx.

  • 6. Re: mac os x lion server service software update
    mac-ct Level 1 Level 1 (0 points)

    Hi Laurent,

     

    Check ownership of var/db/swupd folder (and all sub folders).

     

    They should be

    _softwareupdate:_softwareupdate

     

     

    If not (or to be sure), run this command (cd to /var/db first)...

     

     

    sudo chown -R _softwareupdate:_softwareupdate swupd

     

     

    Think this'll sort you out.

     

    Good luck.

     

    Ken

     

    Message was edited by: mac-ct