14 Replies Latest reply: Dec 16, 2011 12:37 PM by sidejob
synaesthetic Level 1 (0 points)

I recently purchased an iPhone 4s (upgraded from my 3G). Try as I might, I can't get it to join my main home wi-fi network. I never had any trouble conencting with my 3G. The 4s connects easily to other wi-fi networks; I've had no other trouble with the 4s. I have installed the most recent 5.0.1 iOS update without trouble.

 

I have an AirPort Extreme third generation (3 years old), and have also updated it to the most current firmware. I have the Airport configured so there's a main home network and a guest network.

 

Oddly, the 4s can join the guest network without a problem, but when I try to join my home network, the phone tells me I have either entered the wrong password, or that it simply "cannot join" the home network.

 

I am using WPA2 Personal security settings, and have let the Airport configure itself automatically. I haven't set anything manually in terms of channel, etc.

 

I have changed the password to my home network, thinking maybe I had it wrong, and I get the same messages on my iPhone 4s: unable to join network, or incorrect password. I am sure I am typing the password correctly.

 

I can connect to the home network via my MacBook without any problems. Connectivity to the web works fine.

 

So. I have walked through all the trouble-shooting ideas I've found on Apple's website to no avail. I've spoken to two Express Lane advisors, who gave me other tricks to try that have not fixed the problem. Now they advise that I simply restore the phone, but I am reticent to do so before asking questions here.

 

Does anyone on this forum have any ideas for me, or is it time to do a restore?

 

Please let me know if there's any other information you might need; I am new posting here, and not an IT professional (or even very familiar with Mac equipment).

 

Thanks for any help you might be able to offer.


iPhone 4S, iOS 5.0.1
  • tonefox Level 6 (9,160 points)

    Have you tried the oldest cure in the book?  Router: switch it off (pull the power), and switch it on again.

  • synaesthetic Level 1 (0 points)

    Hi tonefox, yes I have. I have powered down the router, the Airport, and the iPhone a couple of times. No luck.

  • Ric Stiles Level 1 (0 points)

    I'm so frustrated w/ apple on this.  I have the saaaaaame exact problem. All my other devices connect fine from blackberry to galaxy tab ,macBook pro, 2 MacBook Airs, MacBook & 2 iPads. Just my ip4S and ip4(my wife's) are "unable to join network". I've tried everything.

     

    Plzzzzz somebody help !!!!!

    Disappointed in apple

  • synaesthetic Level 1 (0 points)

    Ric: have you contacted any other support sources at Apple? What have they said?

  • synaesthetic Level 1 (0 points)

    Update: restore (not to new, to my backup) did not fix the problem.

  • kylefromirvine Level 1 (0 points)

    Having the same problem. 

     

    I reset my AirPort to "factory settings" (which have apparently been updated to 7.6, even though I bought the thing 6 months ago).

     

    In addition - printer can't connect either.  Very frustrating.

  • Siberian_Kiss Level 1 (0 points)

    Here is what worked for us:  Take your phone and make sure the top of the iphone is touching the antenae of your wireless router (if it does not have an antane, just place your phone on top of it).  Then, try connecting.  I know this sounds a bit weird, well it did to me, but it worked.

  • fromsouth Level 5 (4,430 points)

    "I am using WPA2 Personal security settings, and have let the Airport configure itself automatically. I haven't set anything manually in terms of channel, etc."

     

    I have heard that reset of the router, after firmware update and then setting it up again helps. Your wpa2 doesn't seem to want to play friendly. Unless you reset after update -not all of the features of update may be working.  JMHO and apologies if you have already done that.

     

    "I reset my AirPort to "factory settings" (which have apparently been updated to 7.6, even though I bought the thing 6 months ago).

     

    In addition - printer can't connect either.  Very frustrating."

     

    Have you tried setting static ip for the wireless printer?

     

    Always found it curious why Windows PC's  want to get same ip address, that they had before shut down. However, every apple device takes first one available, creating a mess for wireless printer connections.

  • synaesthetic Level 1 (0 points)

    Update: after resetting my AirPort Extreme and creating a new network, I had the same problem. However, my cable modem finally gave up the ghost around the same time; it was older and it was not DOCSIS 3.0 compatible. I purchased and installed a Motorola SURFboard SB6121 at the recommendation of a friend who works in IT.

     

    After setting up the new cable modem, I reset the AirPort Extreme one more time, creating a new home network (and no guest network).

     

    This has fixed the problem, and now all devices are on the same network.

  • fromsouth Level 5 (4,430 points)

    So what your are saying that your cable modem was not ipv 6 compatable, right?

  • synaesthetic Level 1 (0 points)

    I'm sorry, I'm not sure what IPV 6 compatible is, but after a look at the definition on Wikipedia, I suspect you are correct. Either way, I'm not having this problem anymore.

  • sidejob Level 1 (0 points)

    I'm having the exact same problem. Have any of you found any resolution??

    JL

  • synaesthetic Level 1 (0 points)

    Replacing my (probably outdated) cable modem, resetting my AirPort to factory settings, and then creating a new home network (without a guest network) are the things that worked for me. You can find the whole story in the posts above.

  • sidejob Level 1 (0 points)

    Thanks for getting back. My problem started when i put in a new modem. I signed up for the xfininity triple play so my phone come in over the modem as well. I've already reset but have used prior settings, I'll try setting up a new network and see how it goes.

     

    JL