Previous 1 2 Next 15 Replies Latest reply: Oct 19, 2014 4:20 PM by CaelumLynx
swbranno Level 1 Level 1 (0 points)

Not sure what this generic error means! I am running iTunes on Windows 7 64bit and have tried all of the recomendations, nothing is working:

A required iTunes component is not installed. Please repair or reinstall iTunes. (-42404) iTunes Loads with this error and refuses to recognise my iPhone or the 2 iPads.


iTunes 64bit, Windows 7, A required iTunes component is not
  • christianfrombrea Level 1 Level 1 (0 points)

    Same thing happening to me.

    I am running iTunes on Windows 7 64bit and have tried all of the recomendations, nothing has worked.

    I've uninstalled and reinstalled 3x!  HELP!

     

    A required iTunes component is not installed. Please repair or reinstall iTunes. (-42404) iTunes Loads with this error and refuses to recognise my iPhone or the 2 iPads.

  • swbranno Level 1 Level 1 (0 points)

    Does Apple Help at all? this is not good.

  • NeedAnotherHoliday Level 1 Level 1 (0 points)

    Just had the same issue. Been installing, uninstalling and reinstalling that many times I lost count. Also tried all the recommendations and half of them have no bloody idea. During all this I also had an error about AVFoundationCF.dll missing or some ********. The recommendations all over the net are just the same ******** from people that don't know.
    Any way I discovered this file resides in C:\Program Files\Common Files\Apple\Apple Application Support.

    Now there is no permission on these files and/or folders.

    A little bit of researching led me to this webpage on taking ownership

    http://www.sevenforums.com/tutorials/1911-take-ownership-shortcut.html

    Downloaded the file from it at step 1, then followed the rest of the instructions.

    Then located the folder Apple (C:\Program Files\Common Files\Apple) and took ownership of everything in that folder. Rebooted the computer.

    Once this was acheived Itunes finally behaved itself.

     

    Hope this helps everyone else.

     

    The box said: "Requires Windows XP or better."
    So i installed Linux.

  • Fun4 Level 1 Level 1 (0 points)

    Just have the same issue. After update to iTunes 10.5.1.42 no download, no connection to iPhone 4. At the moment I am just short in time, so have you feedback whether this works in this conf.

    Thx

  • NeedAnotherHoliday Level 1 Level 1 (0 points)

    It worked as stated in my earlier reply.

    Just had the issue again and took ownership of C:\Program Files\Common Files\Apple.

    Uninstalled all Apple applications and reinstalled ITunes.

    Issue is with accessing this folder during update.

  • ngs2465 Level 1 Level 1 (0 points)

    I get the same error message, and my first reaction was to Uninstall and reinstall iTunes. It also cannot sync with my iPod. I went to the control panel to remove Itunes from the programs list, and alas, it was not there. How do Uninstall iTunes if its not on my computer, when it actually IS on my computer? I'm really stuck with this one.

  • NeedAnotherHoliday Level 1 Level 1 (0 points)

    Run iTunes installer and it will give you 2 options, 1 - Repair iTunes installation, 2 - Uninstall iTunes.
    If you have not got a copy of this you will need it anyway to re-install iTunes.

     

    Any way no matter what you will need to take ownership of the folder Apple before installation.

    I did it before uninstalling iTunes as the first step.

    The directory in Windows 7 is :- C:\Program Files\Common Files\Apple
    More than likely the same in Vista and possibly the same in XP, but XP shouldn't have the ownership issue.

     

    If you go to this webpage :- http://www.sevenforums.com/tutorials/1911-take-ownership-shortcut.html

    it has the explanation in 2 steps and you can download the file to take ownership.

     

    Once this has been done then the files and folders under Apple folder can be modified during the uninstall and/or installation.


    We pay good money for software that has major flaws, you would think Apple and Windows would know how to resolve it, instead they are more concerned about looking after themselves than serving customers.

  • davidfrommanteca Level 1 Level 1 (0 points)

    NeedAnotherHoliday, I thought you had this one nailed but it doesn't    work for me. I did everything exactly like you said (and I'm from    the DOS days) but I get the same results, "A required iTunes    component is not installed. Please repair or reinstall iTunes.    (-42404)" Then I discovered the "Apple Application Support" folder resides in C:\Program Files (x86)\Common Files\Apple\Apple Application Support, not C:\Program Files\Common Files\Apple\Apple Application Support. I took ownereship of the Apple folder in the Program Files (x86)\Common Files\Apple also. Same thing. iTunes gets the same error and it won't recognize my iPod touch or my iPad.

     

    If somebody figures this thing out. please, please post what's wrong with iTunes and this error (-42404). Obviously Apple doesn't know what's wrong, and I doubt they even know anything is wrong! I'm sick of the word "iTunes." It should be iHateAppleJunk!

  • NeedAnotherHoliday Level 1 Level 1 (0 points)

    davidfrommanteca, Sorry that it has not worked for you. I'm just a hobby computer user for the last 25 odd years.

    I know what you are saying. My wife refuses anything to do with Apple because of the issues with iTunes and Windows. I posted hoping the results I had worked out might help some one else,. instead of having the banging head against the wall for weeks on end episode I went through.

    The only other thing I could suggest is uninstall iTunes, search for all leftover files and folders installed. Once located take ownership of these and install again.
    It may not work, I can not promise anything but it is at least more than what I found when I was searching the internet for answers.

  • davidfrommanteca Level 1 Level 1 (0 points)

    NeedAnotherHoliday, thanks for your reply. I have never been an Apple fan but recently I got an iPad and an iPod touch. I'm very pleased with both. I was running iTunes on my Windows XP computer and it worked fine. I just got this Windows 7 64 bit computer a week or so ago. Like yourself, I have searched and searched for an answer but nobody I have found has a fix. I'm curious how many people (percentage-wise) are having the same problem as we are.

     

    In another weird installtion, last night I installed iTunes on my laptop. It's running Windows Vista 64 bit. When I went to download iTunes, I had a choice between 32 bit and 64 bit. I figured I would try the 32 bit version first. Right at the end of the installation I got an error from iTunes saying to use the 64 bit version. Then I noticed there was an iTunes icon on my desktop so I tried it and it works. I wasn't about to fool around with the 64 bit version! I tried the same thing with my Windows 7 64 bit computer but it won't even begin installing the 32 bit version. I get an error as soon as I try.

     

    So everything remains a mystery for now. I've been running a bunch of hardware and memory tests today but so far everything is good. I'll try again tomorrow using your method and see what happens. If it still doesn't work, I guess I'll use my laptop for iTunes.

     

    BTW, I don't really hate Apple, but I'm really frustrated with Apple/Windows compatibiliy issues. My brother has always been a Macintosh user and he had an iDisk for a while (now MobileMe). Apple's Windows app never did work very well with the iDisk on Windows 98 or Windows XP.

  • davidfrommanteca Level 1 Level 1 (0 points)

    I had to reinstall Windows to fix the problem. I started having other errors with some other programs, then I tried to restore to an earlier date, which failed. With over 500 GB of data, that's the last thing I wanted to do but I backed it up then reinstalled Windows. So it's fixed, but it wasn't an easy fix. Good luck to all.........

  • Signman3 Level 1 Level 1 (0 points)

    I have just read your solution for correcting the " ERROR MESSAGE -42404 - iTUNES COMPONENT NOT INSTALLED etc" problem.

    You are a genius - I got on to the SEVENFORUMS site as yopu suggested - took ownership of the APPLE folder in Common Files and now I no longer get the error message when opening iTUNES and it can sync with my iPOD.

    Many thanks once again

    Apple were unable or unwilling to give me this solution - you should charge them for your knowledge.

    Regards and best wishes.

  • Brenta93 Level 1 Level 1 (0 points)

    I finally got this to work after many goes.  It seems you have to be thorough and systematic about making sure the Apple folders under Common (I did Program Files and ProgramX86 to be sure) are shown as unlocked. I also then uninstalled iTunes and the other two programs it had loaded at the same time as the upgrade.  I checked there we no Apple folders left and re-installed iTunes. Finally no 42404 errors.  It reloaded the iPod driver and now appears to be working.  I think the problem was that my iPod was attached when I upgraded.  Not surprising as you connect, it launches ITunes, it asks is you want to upgrade and you obviously say yes. I'll be more careful next time.

  • PC User Hate Apple Level 1 Level 1 (0 points)

    Here is how I fixed problem. Download Itunes and save it to a folder. Go to the Apple Itunes Install file and right click "Run as Administrator". Next a screen will appear and state repair or remove. Click remove. Once this is done go to apple.com and download iTunes and save it to the same folder. Make sure you click "save as" to replace the original file. Once download is complete right click and "Run as Administrator" to install. This worked for me on two computers.

Previous 1 2 Next