3 Replies Latest reply: Dec 23, 2011 8:59 AM by pmullen
Stevepfmo Level 1 Level 1 (0 points)

I've tried to reinstall an app by downloading it again from the app store on the ipad2 but the "install" icon is greyed out so it won't let me download or install it again. How can I fix this?

I've also checked that the app is no longer on the iPad. Also I am downloading it through wifi.

Thanks :)


iPad 2, iOS 4.3.3
  • Demo Level 10 Level 10 (84,505 points)

    If Install is greyed out - that indiciates that iTunes "thinks" the app is on your iPad already. Try restarting the iPad.

     

    Restart the iPad by holding down on the sleep button until the red slider appears and then slide to shut off. To power up hold the sleep button until the Apple logo appears and let go of the button.

     

    If that doesn't work, sign out of your account on the iPad, restart again and sign back in.

     

    Settings>Store>Apple ID - tap your ID to sign out. Restart, and sign in again ... Settings>Store>Sign In.

  • King_Penguin Level 10 Level 10 (110,415 points)

    It's not already installed but possibly hidden via Settings > General > Restrictions (e.g. by an app age rating) ? And I assume that you've checked all your home screens and app folders for it, and searched for it via the spotlight search screen ( swipe your first home screen to the right). Also does the app now need a higher iOS version than you have on your iPad ?

  • pmullen Level 1 Level 1 (0 points)

    Morning

     

    I have this issue and have done the steps recommended above:

     

    1. restarted iPad

    2. logged out of the app store, restarted, logged back in

    3. Turned restrictions completely off

    4. App in question does not need a higher version

    5. Searched for app on device. Not there

    6. No icon for app on desktop

     

    So how does one give iTunes/the app store a dope slap to wake it up? Annoying.

     

    I deleted the app per the instructions on the apps support page if it wasn't performing properly.

     

    Thanks!