Previous 1 7 8 9 10 11 Next 182 Replies Latest reply: Apr 30, 2014 5:18 AM by mattyuk2013 Go to original post Branched to a new discussion.
  • mattyuk2013 Level 1 (0 points)

    The first time, Time Machine was active but not plugged in. The second time it was active and plugged in. Auto recovery was on both times.


    With regards to the logic board, somebody else in this thread mentioned that the issue arose after their logic board was changed. In any way related?


    I've just got to hope that my Time Machine backup is actually in a fit state for the second time around :(


    I too find it absolutely astonishing that a program used by millions is arguably causing problems on only a handful of computers. Millions of people must do very similar processes every day. Is there something else we are missing? Did any of you have firmware passwords enabled? Any other wacky pieces of OS X we use that no one else uses?

  • dill.sellars Level 1 (0 points)

    There is a good reason millions of people are not reporting this issue. It requires configuring 2 non-default options - Word auto-save, and time machine. It also requries a large Word file with embedded images. Finally, novice computer won't make the connection between Word, auto-save, and time machine and will blame themselves or grumpkins, etc.


    The next time someone is at the Genius Bar, this is what you do. If your Word doc doesn't have too much personal stuff in it, give it to the Genius and have them put it on their Mac (give them fair warning about what might happen). Have the Genius configure Word auto-save and have time machine fully setup and running. Tell them to play with the Word doc for an hour and keep saving the file every few minutes. Have Activity Monitor open and tell the Genius monitor /var/log/system.log. After the problem manifests, have the Genius reboot and repair disk to see all the errors it finds.


    I emailed my wife's dissertation to my work machine and had my MacBook going ape-**** crazy within 30 minutes.This is the best way to convince others of the problem - send the file to a completely different Mac and that will rule out your RAM / Logic Board / Hard Drive etc from the get-go.

  • ProfessorBen Level 1 (0 points)

    Exactly. I have also been able to recreate this bug on other machines. It is not common, but it is very real.


    On my Air I could often tell when things were going south because my fan would come on. This almost always meant that something is spilling madly into /var/log/system.log.


    If anyone ever gets wind that this gets fixed I hope they will post here -- I keep reading this extremely long thread looking for the post that says we can all go back to auto save and time machine without fear.

  • Scott Atchley Level 4 (2,225 points)

    What spills into the system.log?


    My wife's iMac exhibited odd behavior after she started using TimeMachine. The file system kept getting corrupted. Apple replaced the hard drive, but it turns out the iMac's memory was bad (see my previous post).


    Caveats: I am neither an Apple nor a Microsoft developer, but I do write a lot of low-level networking software. I have written networking software for distributed file systems, but I am not a file system developer. I have written some Linux kernel (operating system a.k.a OS) code for one of the distributed file systems, but I have only written user-space code for OSX.


    That said, OSX is built on the Unix specification. Applications can only access the file system through a well defined interface which calls into the kernel. Only the kernel is allowed to actually modify the file system. All modifications that the application requests are passed to the kernel, which executes them and returns the result. It is the responsibility of the kernel to first check if the modifications are allowable before doing any changes. If it encouters any errors during the process of making the modifications, it must clean up and leave things the way they were before the request and then return a suitable error to the application.


    The OS will allow an application to screw up the contents of a file (e.g. over-write a portion of the file with the wrong contents) because only the application should know what is in the file. The OS will allow an application to delete files by an application if user has the correct permissions. These are destructive from the user's point of view, but they are not file system corruption.


    What is being discussed here is file system corruption. The file system is a set of data structures that map a logical view of a file to a set of sectors on a hard drive. For example, where you want to view a movie, QuickTime will open the file, read the table of contents based on the movie file type, then read the first frame. The OS has to translate these requests to determine where on the disk each of these pieces are and fetch them for QT. These are the structures that the OS modifies in response to a request from an application. When the OS can no longer make sense of the data structures, then it stops modifying the hard drive (or SSD) and reports the file system is corrupted. Using Disk Utility to verify (or repair) a disk simply asks the OS to run a file system check (fsck) on the file system and determine the integrity of the file system.


    I do not know what Word's Auto-Save feature does specifically. I do know that the HDF+ file system keeps track of modifications to files and directories so that TimeMachine knows what to back up. TimeMachine adds a hard link to files that have not been modified and copies files that have been modified to the backup drive.


    In all likelihood, there is a bug in the OS that handles the file system that is triggered by very large Word files in combination with Word's Auto-Save and TimeMachine. This is not a bug in Word. To say it is means that Word (or any application) can alter the OS at will which means that OSX is fundamentally insecure and broken. That is not the case.


    Apple is not immune to OS bugs. I filed my first bug report a couple of months ago when the OS returned the wrong value from a simple call to select(). They fixed it in the Mountain Lion release. As far as I know, it is still broken in Lion.


    Edit: Now, assuming there is a bug in the OS file system code, I am not saying that the mitigation strategy of turning off Word's Auto-Save and/or TimeMachine is not needed (i.e. be careful and turn them off if needed). I am currently leaving them on, but I am running Disk Utility every hour or so when using Word.


    Message was edited by: Scott Atchley

  • ProfessorBen Level 1 (0 points)

    It was several months ago that I faced this. But...


    the log files fill up with a write access denied error. This seems to be a simple conflict between time machine and autosave. BUT - it is a persistent error and actually will fill up the entire hard drive leaading to all sorts of other issues.


    I think the reason so many MBA users first noticed this bug is that with the small SSD sizes the fill up happens faster. I was able to recover simply by editing the log. Which got back my disk space then going to an older version. But, I could recreate the error over and over unless I turned off auto save...

  • Scott Atchley Level 4 (2,225 points)



    Thanks for the reply.


    This is not file system corruption. This is an application requesting a write, the OS denies the request and logs the failure, and the application most likely keeps trying again hoping that it will succeed. The ballooning log consumes the storage, but the file system is not corrupt (i.e. other file systems requests to read or write succeed for this and/or other applications).


    Corruption means that the data structures that the OS relies on are no longer consistent. Using Disk Utility to repair attempts to fix the data structures with as little loss of data as possible. When it cannot, an erase and reinstall is the only option.

  • dill.sellars Level 1 (0 points)

    @Scott - it looks like this - hardlink errors. It is 100% reprodicuble with the right Word file, auto-save, and timemachine.


  • Scott Atchley Level 4 (2,225 points)

    Interesting and note that thread does not mention Word at all.


    There may be a race condition (i.e. a timing issue) in the hard link code between requests that leave things in a bad state.


    I wonder if Word's Auto-Save also uses hard links.



  • mattyuk2013 Level 1 (0 points)

    Quote @dill.sellars "There is a good reason millions of people are not reporting this issue. It requires configuring 2 non-default options - Word auto-save, and time machine. It also requries a large Word file with embedded images. Finally, novice computer won't make the connection between Word, auto-save, and time machine and will blame themselves or grumpkins, etc."


    Isn't Word auto-save pre configured to be active? Or are you talking about a modification from the default settings? I would also imagine that Time Machine is an extremely common Mac user setup, maybe not as common as Microsoft Word but I imagine a decent chunk of Macs probably use it.


    It seems people here seem to have a few variations on the same error:


    - Some suffer full file system corruption from hard link errors, like myself

    - Some suffer file system errors which Disk Utility manages to fix

    - Some suffer a balooning log file which fills up the system

  • mmweinstein Level 1 (0 points)

    I have encountered this issue twice.  Both times working on the same document and both times within one week.  Here is what I know thus far:


    I never had this problem working with this document on my old system, which is running snow leopard and office 2004.  My new system is running Mountain Lion and office 2011.  The document I'm working on is large (about 21 MB, with several embedded images).  The error seems to pop up at random times, I can't tie it to any specific action I take.  It could be linked to when autosave does its thing, since I don't monitor that.


    The first time this happened, I hadn't done a time machine backup of the system (my time machine drive was still in the hands of UPS).  I also don't have time machine set to backup at regular intervals; it only backs up when I plug my computer into the drive.


    In my opinion, this is unlikely to be an issue with hard drive defects.  I say this because the first time it happened, I was still in the exchange window for the computer, took it in to the store to be checked out, and they said that it had a bad drive and exchanged it for an entirely new computer.  The chance of getting two systems with bad drives that fail the same way with errors in the same file seems to be pretty low.


    The involvement of MS Word in the problem would seem to be likely, since the error always starts off with word failing at an autosave and crashing.


    The involvement of time machine in this error would seem unlikely, since mine isn't constantly backing up to the drive.  I won't rule it out, though, since it is possible that time machine is collecting data for the next backup even when it is not actively backing up the system.


    I also cannot say if this is a problem on Microsoft's end or Apple's.  It seems that something with Word's autosave function doesn't play nice with the Mac file system.


    Either way, since (from the other posts) it seems that this error is on large files, and I need to work with large files, I'm going to reformat my drive if the repair doesn't work (which it didn't last time), and restore from my last backup (which I did last night, so nothing too important should be lost here).


    Since I'm sure that neither Apple nor Microsoft are willing to accept any blame for this sort of issue, I don't hold out a ton of hope for either one of them making an attempt to repair it.

  • Russell0986 Level 1 (0 points)

    I know I am repeating some of the things in my earlier post, but to address a few of your issues. I think I can rule out time machine. The first time I came across this problem I was on a plane, with my wifi off and not attached to any external drives. Which rules out the time machine connection, at least for me.

    I the hard drives on two computers corrupted while working on the same file. One of which was brand new at the time, and the other which never had any other problems.

    Since encountering this problem I have been avoiding working with Word 2011 for Mac anytime I have a file that contains multiple photos embedded in it. At times this cannot be avoided, so I have learned to watch for some of the danger signs. Last week I was finalizing a document which contained several photographs, apparently large enough to start the problems discussed in this thread.

    The first warning sign that appeared was a message within Word that it could not complete spelling or grammar checking because of insufficient memory. (MacBook Pro 2.7 GHz i7 with 16 GB of Ram). The only other programs running at the time was Grab and Preview. System resources would not have been a problem. Ironically, despite the message, spell checker (auto correct) was still operating.

    The next message, which from my experiences is your final warning before Word corrupts the hard drive, is a message that Word cannot save the file because it is in use, then tells you to save it under a new name. When you do this you get an error message, but the file does save. Again, from my experiences, if you see this message get out of Word as quick as you can (at least the offending document). Then finish working on the document on a Windows machine (to include Parallels desktop) or open it in some other program, such as Pages, which is exactly what I did. Opened the offending document in Pages, finished my edits, then opened in Windows Word 2010 to make sure Pages did not change my formatting, and sent the document off, which had to be saved in a Word format.

    I know there have been many that doubt this is a real problem. But as stated earlier in this thread, Word corrupted two hard drives (1 twice) on two different machines. Both of which continue to work without incident, other than what has been described, since being restored.

    To reiterate, the problem seems to be limited to large Word files containing multiple photographs. Since the embedded photographs is what is making the files so large, I cannot say if it is just the files size that is the problem, or the photographs themselves.

  • Csound1 Level 8 (46,335 points)

    If you do a quick Google search you will find that Word for Windows has had this issue since Office 2003, Word for Mac since Office 2004. Screen Shot 2012-12-03 at 7.04.43 PM.png

    Turn AutoRecover off (from within Word).

  • Russell0986 Level 1 (0 points)

    Ironically, it has started again with a report I am presently working on. This report has 2 high resolution photographs in it, which has pushed the file size to over 35 MB. Warning that appeared when I just want to manually save the file.

    “This file is read-only. To save a copy. Click OK, and give the document a new name in the Save dialog box”. The problem is it is not a Read-Only file. I have been working in the file for the past few hours, having saved it multiple times.

    Compressing the photographs in Word reduced the file size down to just under 10 MB, allowing me more time to work. However, after adding more photographs, and compressing those, the file size has increased over 44 MB.

    Just tried to save the file, this time the following error message appears:

    “You cannot save while the file is in use by another process. Try saving the file with a new name.” (From past experiences, this is your warning to shut down Word before it trashes the hard drive)

    A few other observations since I was waiting for this to happen. The actual file I am working in no longer appears in Finder. There is a temp file in the folder, which I know is the file I am working on (I can preview it). This error did not appear as a result of the AutoSave, but as a result of me saving the file. 
My hard drive has more than 322 GB available. I can start any other application. (I am writing this in Pages)

    When I save the file with the new name the following error appears.

    “This is not a valid file name. Try one or more of the following:

    *Check the path to make sure it was typed correctly.

    *Select a file from the list of files and folders.”

    When you hit OK (the only choice) the file is created and saved despite the error message. (this is the typical pattern)

    A couple other observations. The Word temp created remains even after Word has been closed. The new file size is only 19.8 MB, consistent with the compress photographs, while the temp file is 43.4 MB, consistent with the photographs uncompressed. I can preview the temp file in Finder but cannot see or open it with Word. Nor can I delete the tmp file. When I try to drag to the trash.

    “The operation can’t be completed because one or more required items can’t be found. (Error code - 43).

    Having been through this before. If I attempt to work on this file (newly name file) any more in Word for Mac, my hard drive will be corrupted. I can open the file in Word for Windows 2010 without any issues.

    Finally, time machine is nor running.

  • Csound1 Level 8 (46,335 points)

    Is AutoRecover on or off (Not Autosave)

  • Reegor Level 1 (0 points)

    1. Russell0986 Remember that Time Machine on a laptop is active even when not connected to a backup device. It is building on-disk backups, that are later integrated into the main TM system.


    2. In this thread      delCavallo

    says he has found 2 solutions, which will recover a drive without reformatting. I have not tried either.


    3. My personal experience is similar to many of those here. The first sign of problems is a failure when I attempt to save my active document in Word. The error message can vary, but it is always an incorrect message.   When that happens, it also deletes the most recently saved file, and the Backup version of that file if there is one. Therefore, I now rename my file every few minutes.

    3b. The most common error is the same as Russell0986:

    “This is not a valid file name. Try one or more of the following:



    4. I am on an SSD, and I gather many others are also. (15 inch MPB retina, 512 GB drive.) Apple replaced the SSD a few days ago - no change in behavior. Is this only an SSD problem?


    5. One sometime-symptom is that I get 2 identical files showing up in the Finder window! I  attach a screen shot.

    6. Has anyone had success turning off MS Word Auto-Save? I will certainly try it.Voila_Capture84.png


    Message was edited by: Reegor. Added screen shot of "impossible" file duplication.

Previous 1 7 8 9 10 11 Next