Previous 1 8 9 10 11 12 13 Next 184 Replies Latest reply: Jan 4, 2016 10:19 AM by Allan Eckert Go to original post Branched to a new discussion.
  • Scott Atchley Level 4 Level 4

    Hi mmw,


    Would you be willing to run a memory checking test on the machine with the error? A common thread to most people's issues is large Word files. In a previous post, I describe the issues my wife's iMac had and Apple's replacement of the hard drive, which did not help. I finally checked the memory and it was bad. Apple replaced the memory and all is now well.


    See the thread with instructions for checking the memory at:




  • RequiredAliasOfDecentLength Level 1 Level 1

    Reegor, re: 6. Yes, switching off AutoSave solved the problem for me.

  • Russell0986 Level 1 Level 1

    Auto Save was still on. I believe I have had the error appear when it was off. Just not worth turning it off for everyday usage.


    I know in my case it is not a memory problem. It has occurred on two different machines. On one the RAM has been upgrade as well as the hard drive. The error has occurred both before and after the upgrades.


    When it did corrupt the hard drive there was nothing you could do. The system was locked up and they only thing you could do was reboot. When the computer was restarted there was nothing that could be done other than reformat the drive.


    When the issues appeared last night, it did not appear to have any other adverse effects on the system. However, I was not going to spend to much time trying other applications before I shut down Word.


    I was able to delete the Word temporary file after the system was rebooted.

  • Bob Bracalente Level 2 Level 2

    Yea, I have EXACTLY the same problems are you are with a large (80+MB) word doc that was apparently constructued by embedding a bunch of powerpoint slides with presenters notes. 


    I guess I'll be buying Pages tomorrow...

  • Reegor Level 1 Level 1

    Russell: Was your "hard drive" really a hard drive, or was it a solid state drive (SSD)?

    Because the "primary bug" (there may be others) appears to be specific to SSDs.


    It has been discussed on a Microsoft Word for Mac thread also. See: file-corrupts-whole-system/6f36243a-5d7f-4969-9030-bf75ede0cf7a


    Now the bad news: I had a recurrence today when Word "Save automatically every X minutes" was turned off! So it may be necessary to just shut off Time Machine.  Until now, it looked like the cause was the overlap of following:


    Mountain Lion (10.7 and 10.8):

    Big and complex (including multiple embedded docs) word doc file

    Time Machine running

    autorecover on [see caveat above]



    For tonight, I am going to attempt to use Disk Warrior and see if I can get my main system back without reformatting. DW appears to require a CD drive, though, so I may be unsuccessful.

  • mmweinstein Level 1 Level 1

    At least for me, it's a true HDD at 750 GB, they don't make SSD that size yet.


    I turned off autosave, which has stopped the hard drive corruption. Word still has problems saving files, and now I'm reformatting the drive and trying a clean install and migration by hand of my old files. Hopefully this gets the bug out.

  • Russell0986 Level 1 Level 1

    As to the type of hard drives, both. When I first became aware of the problem back in August, it first occurred on my Air with a SSD drive. While that was being restored started working working on the same file on my MacBook Pro, with a 1TB drive (thinking the drive in my Air had gone bad). My Pro was a new machine at the time, only about 2 weeks old. Word trashed that drive also, as well as the drive on my Air a second time.


    Since then I have replaced the drive in my MacBook Pro with a 500 GB SSD drive.  The instance I was describing the other day was on that machine with the new SSD drive.


    The type of drive does not seem to matter.


    I have taken the same files and started to work on them on my iMac and problem starts to appear there. Just have not let it go far enough to allow Word to corrupt its drive (don't have the desire to restore another computer)


    From what I have seen this is a software issue and is not hardware related.


    From what I have seen so far, once the Word file gets over about 20 MB is when the problem presents itself.  If the Word document contains only text you may never run into this issue. However, if you add a few photographs, the Word file gets large fast  and this problem appears.


    If you are going to work on a large Word file with embedded graphics or photos, you might want to consider working in the Windows version. (I can work on the same file, on the same computer, in the Windows version of Word within Parallels desktop with out incident)

  • Bob Bracalente Level 2 Level 2

    Actually, the physical media is a DVD. But you have a couple of other options to run DW against your boot drive, but they also require additional hardware.


    If you have another Mac running a recent version of OSX, you can connect the failed computer to that via a FireWire cable, and boot the failed computer into target disk mode by holding down the T key while booting the failed computer. This will allow you to access the failed disk from your working Mac. You can then go to the Alsoft site & download the DW dmg onto the other Mac and run it against the failed drive.


    Another option is to use your original install disks or Recovery Mode on your failed computer (depending how old it is) to install OSX on an external USB or FW drive. You can then boot from the external drive, install DW on the external drive and run it against the failed drive. I guess if you don't already have an external drive, it might cost about the same as an external DVD drive. If you don't think you'd get much other use out of a DVD drive, buying an external drive might be more useful if you end up having to buy something. Having an external bootable backup drive handy is useful for reasons that are now all too apparent to us.:)


    According to Alsoft, you cannot burn the downloaded dmg to a DVD yourself and use it. So unless you can find it locally somewhere, the quickest fix might be one of the options above unless your willing to wait for the the DVD to come in the mail.

  • Reegor Level 1 Level 1


    Thanks. I have gotten DiskWarrior to work, by getting the physical DVD from my IT person. But it has struck out. The directories were marked with a white bar on red circle - and sure enough, they were empty .  DiskWarrior is very fast - after reading the manual, it appears to be a "one trick pony" and if that trick is not the right one for a particular problem, it does nothing.


    Then I ran Data Rescue 3, which is on sale right now through It did much much better, once I ran the "deep scan" which took about 10 hours. But it's far from 100%. So I'm getting much of my data back.


    Russell - I think your suggestion is the safest. It appears that we are not sure what is causing this problem, since it's not just on SSDs and it's not just when "autorecover" (save every X minutes) is turned on. I have already subdivided my document to get the size down; I can't keep doing that indefinitely because there are too many pieces that need to fit together. Going to a virtual machine appears to be best.

       Unfortunately I never bothered to set one up on this macbook. But it can be done.



  • mmweinstein Level 1 Level 1

    Hope everybody here's having a good weekend.  I spent some time this weekend seeing what I could find out about this error.  To do this, I copied everything I wanted to keep to an external drive, formatted my laptop and started with a fresh OS installation.  Here is how it played out:


    • Reformat, reinstall OS
    • Run software update to the most current version of everything
    • Install Office
    • Copy a large word file (>20 MB) to my desktop as a tester
    • Run word and try to get it to have saving errors.  Cannot recreate file errors and everything works.
    • Reinstall everything I bought from the AppStore.  Still cannot recreate the file errors.
    • Install EndNote (it's a citation manager program that works closely with MS Word).  Still no errors.
    • Install Adobe Acrobat, Photoshop, and Illustrator.  Still no errors with word files.
    • Turn on TimeMachine functionality and run a system backup.  Wait a couple hours for that to sort itself out.
    • With TimeMachine still on, start up Word and load the tester document from the desktop.
    • Add a single word to the document and try to resave it (same as I was doing before to try recreating the error).
    • Now I have the error again.  Word says it's an invalid filename, the tester file disappears from my desktop and now there's one of those Word working temp files in its place.
    • At this point, I quickly turn off autosave because I don't want to start seeing that mess of hard drive errors again and have to reformat once more.
    • I shut down Word and try to delete the working file that was created.  Original testing file I put on my desktop has disappeared completely, not even in the trash can.  The working file claims it's still in use and can't be deleted.
    • Turn off TimeMachine functionality, reboot the computer, now the working file can be deleted.  I put another copy of the tester on the desktop.
    • Reopen Word and the tester file.  File saving works as it should again.  Also, autosave is reenabled and not causing any problems.


    It would seem at this point that (at least on my system) that running MS Word with a large file open and having TimeMachine enabled are necessary components for the problem.  I obviously can't say if they're sufficient, since I don't have other systems to try it out on and see if there isn't something specific to the OS or hardware.


    Now the fun part.  Since my computer is new, I still get free phone tech support from Apple.  I called them and gave them a rundown of what I've seen so far.  After a couple of transfers up the chain, ultimately to one of the senior advisors, they take a bunch of notes on what I've seen, and they come clean about this being a bug that they've known for a little while.  It is a conflict between MS Office and TimeMachine, since Office likes to keep constantly accessing the files while it's working on them and TimeMachine really doesn't like that.  They also told me that they are already working on a fix for the problem.  They said that they can't give me an ETA on the fix, but that I should keep my eye on software updates because they're most of the way done with it, and it should come out, "Sooner, rather than later."


    In the mean time, here are some possible workarounds.  I haven't completely tested any of these, so no guarantees.


    1. Keep TimeMachine turned off most of the time.  When backing up, close MS Office programs, run your backup, turn TimeMachine off again, resume use of Office.  This is what I've been doing and it's worked so far (knock on wood).  Since my backup drive uses a USB connection, it's only connected at the end of the day, so switching TimeMachine on and off isn't too much of an annoyance for me.  If you use a wireless time capsule, you may have issues with this idea.
    2. (I haven't tested this one, if you try it and it helps, please reply and let us know)  In your documents folder (or wherever else you want), create a subfolder (I'll call it "Working" for the sake of this reply).  In Word, set your autosave and default folders to this Working folder.  In TimeMachine preferences, exclude this folder from backups.  Now copy whatever documents you're working on to this folder and open/work with them in that folder.  Copy them out to your regular documents folder regularly so they can be included in routine backups.  Again, I haven't tried this solution, so I don't know how well it will work.


    Good luck, and watch the software updates.

  • thirdopticaltool Level 1 Level 1

    For what it's worth, I just ran into the same exact problem. Word gave some cryptic error about the drive being corrupt, everything else working fine, but then the fans kick in and Activity Monitor says syslogd is using 189% of the CPU, and gobbling up 8.9GB of Real Memory (and growing fast.) Console is logging hundreds of entries per second about the same hardlink error over and over. Eventually the machine becomes unresponsive, and after a hard boot, things seem okay. BUT, running disk utility says the disk requires repairs, and I need to restart holding command and R. And, just like others have mentioned, as soon as Disk Utility fails to repair the disk, it no longer boots at all.


    So I'm restoring from a time machine backup. I'll let you know if turning off auto-save works.


    Predictably, it's a MBPw/R, 16GB RAM, 500GB SSD drive. Word 2011, and Time Machine. So you know, more evidence to throw into the pile of "this is a real thing."


    (PS: What an insuferable prat "etresoft" going on some denial crusade. How on earth is that helpful? Sheesh.)

  • mmweinstein Level 1 Level 1

    What a place the world would be without numpties.  When I spoke with apple and they even said that this is a known bug that their engineers are working on.  We compared notes a bit, and it seems that the only thing you need to have this happen is time machine activated and word working on a large file.  They even said that it is a combination of microsoft office generally being "finicky" about files getting into a conflict with time machine constantly trying to monitor changes for the next backup.


    Rest assured, it is a real bug that you're dealing with (according to Apple) and they are working on a patch for it.  And that's regardless of what anybody on here says.

  • Reegor Level 1 Level 1

    While waiting for the bug repair, I have a new workaround:

    I switched to Nisus Writer Pro. It is amazingly compatible with Word - after some fiddling, it imported a 20MB document with footnotes, numbered captions, cross-links. The diagrams came across but "look funny." In any case, there  is life beyond Word without having to do copious hand correction.


    Thirdoptical tool: Turning off Word auto-save does NOT work reliably.  You must turn off Time Machine. (And it has to be turned fully off, not just "not spinning a current backup.") See mmweinstein #1 for this method.  This, or not using Word, are the only proven workarounds at this point.


    Finally, if Word starts to act funny, immediate Save, Quit, make manual copies of your Word files under new names, and run Disk Utility. Disk Utility will probably find errors.  If you catch it fast, you probably won't have to reformat the entire drive.


    If you really want to be safe, make sure you have a current backup (TMachine is ok as long as Word is off) before you run Disk Utility! About 10% of the time I ran Disk Utility, it told me I needed to reformat.  I accomplished this with Dropbox for my active folders but I still lost some mail.

      Anyway, I'm out of this game since I use Nisus now.

  • mmweinstein Level 1 Level 1

    I have to use word... the big documents that cause the problem are the exact ones I would be in trouble with if I moved them.  I would have to spend hours proofing to look for the little changes that happen when you port to a new processor.  I found that keeping autosave turned off prevented the drive-crashing hardlink errors from happening because of the time machine conflict.  The time machine conflict was still playing havoc witih file names and causing files to disappear and preventing me from saving to the same file name twice.  Keeping time machine turned off while word is running and vice versa is the only reliable way I've found to keep the error from showing up.


    Also, the time machine conflict sounds like something best dealt with on Doctor Who.

  • leefromkokomo Level 1 Level 1

    Thanks for your techical support.


    I quess that is the reason that I am sitting at my desk watching Time Machine completely restore my MacBook Pro (15.5" retinal).  Oh this is real, it happened to me about 8 months ago with my 13.5 MacBook Pro and Lion.  That time Apple replaced my hard drive.  The problem came back if not carefull with multiple saves and new file names.


    This time it was just erase my drive, reload the OS (that took about 12 hours of download time) and restore with time machine.


    If you do not believe the cause of the problem, view the error messages that show up during disk verify after a crash.  The first error messge states that the temp file from auto back up was corrupt.  From that numerious other error messages follow.  The final error message is "can not repair".....


    I should further suggest that even if auto back is turned off, the make backup file during file save can also crash the system.  That is what happened the second crash yesterday.


    This problem only seems to occur for me when I work on a large word document (greater that 30 Mb) with a very large number of JPEG photo images.


    This exact problem has happened with both a mechanical HD and flash HD with different operating system versions and two different computers.  It would seem that the probability of this failure on two different storage systems on two dfferent machines over an 8 month period being cause by HD failure is VERY low.