14 Replies Latest reply: Jan 1, 2014 7:09 PM by BDAqua
mac4mee Level 1 (0 points)

I bought a used iMac w/ OS X 10.5.8.  I need to change admin password to download software updates for Safari, itunes, etc.  I do not have installation disks.  I have internet connection working with firefox browser installed.  Assistance need to take another bite from the apple.  Thanks

iMac, Mac OS X (10.5.8)
  • Texas Mac Man Level 8 (46,565 points)

    Here's one method to reset the password without the install disc:


    1. boot computer and hold the "apple" key and the "s" key.

    2. wait for terminal show

    3. release keys

    4. type without the quotes: "/sbin/mount -uaw"

    5. press enter

    6. type without the quotes: "rm /var/db/.applesetupdone

    7. press enter

    8. type without the quotes: "reboot"

    9. press enter


    This will let you create a new admin account when you reboot your computer.


    Also, without the discs, look at Mac OS X Tip - No Password, No Root, No CD? No Problem.



    Without the discs, try this (OS 10.5 only). *How to Reset User Password via single user mode*

    http://macosx.com/forums/howto-faqs/300019-howto-reset-user-password-via-single- user-mode.html



    Here is a way to get around not knowing the admin password on Macs.


    To reset your OS X password without an OS X CD you need to enter terminal and create a new admin account:


       1. Reboot

       2. Hold apple + s down after you hear the chime.

       3. When you get text prompt enter in these terminal commands to create a brand new admin account (hitting return after each line):

              * mount -uw /

              * rm /var/db/.AppleSetupDone

              * shutdown -h now

       4. After rebooting you should have a brand new admin account. When you login as the new admin you can simply delete the old one and you’re good to go again!


     Cheers, Tom

  • mac4mee Level 1 (0 points)

    Hey Texas Mac Man

    I was successful with the admin password change!  I've updated software and am looking forward to a Mac experience.  Thanks

  • BDAqua Level 10 (122,242 points)

    Welcome to the forums & Macdom!

  • mikolajjj Level 1 (0 points)

    Maybe anyone can help me with similar problem. Somhow I lost administrator password. I managed to login into my account (I logged as a guest and changed password for my administrator account) but since then I can't make any changes to the system (i.e. can't change logging settings, time machine settings, etc.). I tried many solutions but none worked (Mac OS X install DVD doesn't work with my iMac when I press "C" on start up so I can't run Utilities to reset passwords). I also tried solution recommended by Texas Mac Man (the first one): I made a new administrator account but when logged in to this new account, again, I have no privileges to make any changes to the system. Does it make any sense? Please help

  • BDAqua Level 10 (122,242 points)

    After getting rid of /var/db/.applesetupdone, did the next bootup act like a brand new Mac that was never setup yet?

  • mikolajjj Level 1 (0 points)

    thanks for your reply. if you meant to do this:

    1) /sbin/mount -uaw

    2) reboot

    I did it and after that it was normal bootup and autologin to my account


    I hope it makes no difference that I have Snow Leopard. I coudn't find a relevant topic within its subforum so I decided to post my problem here. I should have mention it before

  • BDAqua Level 10 (122,242 points)

    I don't see if you did the important step...


    6. type without the quotes: "rm /var/db/.applesetupdone"


    Space between rm AND /var very important.

  • mikolajjj Level 1 (0 points)

    I did try following procedure:


    mount -uw /

    rm /var/db/.AppleSetupDone

    shutdown -h now


    (proper spaces etc.)


    The bootup was like for a brand new Mac (stars, universe, 'welcome' in many languages and music), and then setting up a new account. This account was administrator account which I can log in to but on which I cannot do any administrative tasks.

  • BDAqua Level 10 (122,242 points)

    OK, (feel free to start a new question if you wish, since it seems a different problem now & we may need more helpers on it).


    So, if you go to System Preferences>Accounts, you cannot unlock the lock there?

  • mikolajjj Level 1 (0 points)

    Exactly, I cannot unlock the lock. Even on the new account which I have just created. I can login with password I set but I cannot unlock the lock

  • bumblebeehouse Level 1 (0 points)

    ATTN: ANYONE SIMPLY WANTING TO CHANGE THE PASSWORD ON THEIR EXISTING COMPUTER WITH ALL THE DATA ON IT: I just did these steps and then had a momentary emotional breakdown when I thought I lost all 232 GB of my original data as I got the Welcome screen only with my wallpaper and finder all gone. Even the folks at SOS Apple prepared me for the worst. BUT the good new is that my data was NOT wiped out. I simply had to go through the steps of set up, punching in fake data, just to be careful not to override, and really it didnt wipe out, it simply created a new user. PHEW!!!!!!!! It was a huge relief. Very Important to use a different user name when it asks you. Therein was my key because when I typed in my original, it said "already in use" and then the relief set in. So I gave it a new name and then went in and chose my old admin account and simply changed my password there. I didnt even need to go through all the steps above.


    If this happens to you, and you need to get through the set up screen, choose the option "do not transfer data at this time"


    So if you already know your old password, simply go to System Preferences, Users, pick yourself, select change password. SIMPLE!!

  • BDAqua Level 10 (122,242 points)

    Good work, thanks for the post!

  • SP_NZ Level 1 (0 points)

    Hi.  I am not able to boot imac (10.5.8) in single user mode (I must have set up firmware protection when i got the imac years ago) - so I can't open terminal or the start up disc from the login screen. I have tried your instructions using terminal from the guest account (the only account I can get into as I have forgotten the administrator password) but terminal tells me that I do not have permission to do that. (Also, I have tried opening the reset password application from the startup disc within the guest account everytime it quits unexpectedly).


    At a loss as to what to do. Thanks for any help!

  • BDAqua Level 10 (122,242 points)

    Hello, if this doesn't work, start a new topic to get the most  help.




    Firmware password protection in Mac OS X ...




    It would block usage of all the startup keys, like C, N, T, D, CMD+s, CMD+Option+p+r, CMD +v, Option boot will show a lock, and Shift, as well as booting from anything but the Hard Drive.


    Force Removing Password Protection


    1) Add or remove DIMMs to change the total amount of RAM in the computer.


    2) Then, the PRAM must be reset 3 times. (Command + Option + P + R).