11 Replies Latest reply: Jul 27, 2013 11:35 AM by jeffallin79
TrueLife705 Level 1 Level 1 (0 points)

The menu bar at the top of iTunes window is not there. How can I get it back?

 

I tried reinstalling and nothing changed. An old, old post mentioned changing country, but where?n load.

 

I am on Windows 7 Home Premium, iTunes 10.5.1.

 

Plus, the iTunes Store do not even load within iTunes window.


PC, Windows 7
  • songwriterjim Level 1 Level 1 (0 points)

    Its the same way with me too. An HP, Win 7

    Moving the mouse over the menu locations will reveal the frop down menus but otherwise, nothings there.

    Its been this way through 3 upgrades of itunes!

  • polydorus Level 6 Level 6 (11,950 points)

    Normally I would suggest trying a repair install first, but if you uninstalled then reinstalled iTunes that should achieve the same thing.

     

    The next thing to try is removing the iTunes preference files, which makes iTunes create new ones with default values. i.e you lose any custom preferences.

    The following article about something else contains instructions under the heading "User specific troubleshooting".

     

    You could also try a safe mode start as described at the start of the article. This would check for plug-ins messing things up.

  • TrueLife705 Level 1 Level 1 (0 points)

    I have deleted the preference files in two or three locations, all TEMP folder data just in case, and when I opened iTunes, I was prompted with the license agreement.

     

    But the menubar still does not exist and the iTunes Store still does not load. I cannot access the Help menu to perform any connectivity tests. I found that (Control + ,) will open preferences for iTunes, but that's all that works.

     

    Anyone have any ideas how to restore the menubar?? I saw this goes back at least a year with no solution posted by Apple or another user.

     

    Maybe news reports are right - Google Music is severe competition?

  • AppleGivesMeHeadaches Level 1 Level 1 (0 points)

    I am having the exact same problem on my HP Pavilio dv7 laptop running on Windows 7 Home Premium.

     

    This has happened since the last few updates. Menu is missing but if I hover my mouse over the top left corner, small little black squares appear and drop down list shown.

     

    My search box is also not working correctly. Sometimes when I click in the search box, it does not me allow to or if I start typing to do a search for example Mxxxx it will jump straight back to Music on Library or Pxxxx it will jump to Ping. If I click exactly on the manifying glass icon, then it allows me to type in the search box. However, when I type a search word, nothing is shown (blank!) or a drop down list (I assume it's trying to show me a list of previous search words) appears but it's all blank. Can't see a single font! However if I hit enter, iTunes will search and give me the results correctly.

     

    I have tried uninstalling and removing every trace of iTunes and reinstalling but I still got the same problem!

     

    Anyone has a fix?

  • TrueLife705 Level 1 Level 1 (0 points)

    Okay.. after much searching for another issue, I had to use a Vista registry fix for fonts even though I use Windows 7.

     

    http://www.techsupportforum.com/forums/f217/problem-with-italic-fonts-everywhere -arial-233328.html

     

    I believe the third post has a registry download and once you run, then restart, your fonts in iTunes should re-appear - they did for me and I can now see and access menu.

     

    iTunes Store still doesn't load, but that's another day.

  • AppleGivesMeHeadaches Level 1 Level 1 (0 points)

    Thanks but there's no need to tinker with the registry.

     

    I found a solution by mhill64 on this link: https://discussions.apple.com/thread/2647111?start=30&tstart=0

     

    QUOTE:

     

    Re: iTunes 10.1 Missing Text                       

    17-Nov-2010 02:35 (in response to wlwbishop)                                            

     

    SUCCESS!!!

     

    The above posts were enough to give me a clue. I have another Win7 x64 machine, and I compared the installed Segoe UI fonts on both systems. Sure enough, there were 6 fonts installed on the 2nd machine, and only 4 on the one with the issue. I was missing Segoe UI (regular), and Segoe UI Bold.

     

    I copied the .ttf files from one machine to the other and right clicked on them and selected 'install'. Fired up iTunes and all text restored.

     

    I also found that I have only 2 types of Segoe UI fonts (there should be 6 all in total). I copied the missing 4 fonts from another Windows 7 computer, and installed them on the problem computer. I opened iTunes and success! Everything is back to normal and the search box problem is fixed too!

     

    Make sure you have these fonts installed: Segoe UI Bold, Segoe UI Bold Italic, Segoe UI Italic, Segoe UI Light, Segoe UI Regular and Segoe UI Semibold.

  • songwriterjim Level 1 Level 1 (0 points)

    Yeah! Installing those fonts fixed my menu problem!

    Many thanks!

  • andykeller20 Level 1 Level 1 (0 points)

    I have this problem.... where do you get the missing Segoe UI Bold and Segoe UI Regular fonts? I do not have another machine to pull from.

  • AppleGivesMeHeadaches Level 1 Level 1 (0 points)

    First stop is always Google search. There are sites who provide free fonts download.

  • andykeller20 Level 1 Level 1 (0 points)

    Found Segoe UI Bold - but cannot find Segoe UI Regular - Google keeps wanting to call it Light which I have...  I never knew that fonts were so powerful they crashed software!

  • jeffallin79 Level 1 Level 1 (0 points)

    Simple fix: try clicking the little box in the upper left corner, then click "show menu bar"...it took me half an hour to see it, I was looking right at it...hope this helps, it worked for me...