Previous 1 8 9 10 11 12 13 Next 193 Replies Latest reply: Jun 26, 2015 2:35 PM by Bangoman Go to original post
  • llngoc Level 1 Level 1 (0 points)

    It is not IPv6 from your ISP. It is IPv6 on your PC which is running iTune for Home Share which is the problem. I had the exact same problem. I reinstalled iTune and it worked for 5-10 minutes and failed. But after I have disabled IPv6 on my PC's network controller, everything started working perfectly since then without a hitch. (See attached image for where IPv6 is disabled on the PC)

     

    Capture.JPG

  • eordonez Level 1 Level 1 (0 points)

    Thanks, thats exactly how it looks since I started to have the problem, it was one of the first fixes I tried. I think this problem has the same sympthoms for many users, but doesnt mean that is the same issue, for me what triggered was the itunes update to 10.6.1.7, before that it was working ok (by ok i mean that the atv disconnected from my home share and internet every now and then, i assigned static ips and that seemed to fixed that particular issue).

     

    Regards from Mexico

     

    Eduardo

  • eordonez Level 1 Level 1 (0 points)

    Well, heres an update, i gave up and bought a 25 ft ethernet cable, plugged it in, home sharing between pc and atv is running stable now for about an hour, cant say my problem is entirely solved, since now my iphone cant see my atv, so it must be a)problem with router b)problem with windows and c)problem with itunes, im gonna try and rule them out in that order.

     

    anyone has a  linksys cisco router so we can compare specs?

     

    Regards

     

    Eduardo

  • Tweety_germany Level 1 Level 1 (0 points)

    Hello All,

     

    Well since the last Apple updates (Mac-OS, iPad (5.1.1), ATV (5.0.1 [4224])) - and I think the plural is important here - it worked fine for me.. during the last two weeks my family looked dozends of hours of Videos and TV shows without any problem.

     

    So the last updates solved it all for me...

     

    BUT: I keep the "old" tries to fix the problem also, so I still

    - have fix IP adresses for the ATV

    - have switched off IP V6

    - have switched off dolby surround

    don't know if this is nesseccary but just don't want to put any risk in here ;-))

     

    And as everybody can see on the eviroment list (see below), we have a very complex landscape, most wireless. I'm very sure, that this issue was not a network issue or something else outside the Apple products. The above mentioned updates came out all together. I think they found something and had to fix it it in all devices. Probably not a big thing, but it they had  to fix it ... and luckily they did ;-)

     

    Our family enviroment contains the following Apple products:

    - iTunes on a Win7 32 bit Noname PC (all content)

    - second iTunes on a iMac with OS 10.6.8 (all content)

    - third iTunes on a MacBook Pro with OS 10.6.8 (daughter, only selected content)

    - fourth iTunes on a Win7 32 Samsung Notebook (son, only selected content)

    - all iTunes sharing the same Home Sharing ID

    - 2 Apple TV second generation

    - 1 Apple TV first generation

    - 2 iPod touch (bought last year)

    - 2 iPads (second generation)

     

    The ATV, ipods, iPads and the Notebooks are connected wireless

    - 1 Airport extrem

    - 2 Airport Express (in WiFi repeater mode)

    except the old ATV first generation. This device is connected with a pair of Powerline adapters

     

    the IMac, the win7 machine and the printer are connected by a gigabit Ethernet switch - this also connects the Airport Extreme.

     

    OK that all for me... good luck to everybody....

  • bcassels12 Level 1 Level 1 (0 points)

    So weird but this worked for me too for now!  Odd that that was part of the problem.

  • vahan1 Level 1 Level 1 (0 points)

    Disabling IPv6 seems to have done the trick here.

     

    Win7 x64.

     

    -v

  • bbdigital Level 1 Level 1 (0 points)

    Thank you llngoc your suggestion to disable the IPv6 adapter worked for me. 

     

    I'm using a Win7 x64 PC.

     

    Cheers

  • Eediot Level 1 Level 1 (0 points)

    Wish I'd found this link sooner. Would have saved the last 2 hrs with(one-off paid) Apple Support and my ISP- neither of whom could solve the problem. disabling IPv6 was the answer.

     

    How come Apple Support didn't know this...

     

    Thanks AJH!

  • Mattamattica Level 1 Level 1 (0 points)

    worked here too.

  • Trevor289 Level 1 Level 1 (0 points)

    Thanks so much! This fixed me up too.  I've been fighting this for a while now.  Ipv6 turned off in windows fixed it instantly.  Didn't even have to reboot!

  • smuready Level 1 Level 1 (10 points)

    WOW! Thanks for the tip, seems to be working for all of us now as disabling IPv6 also made the Home Sharing feature pop up on all 6 of my ATV 3rd Gens and iPad and iPhone!  This was some great information and saved me a major headache....

  • Marisafromwa Level 1 Level 1 (0 points)

    Unfortunately, I'm not very tech savvy.......could you please tell me how to get to the "Local Area Connection 4 Properties" tab?  I'm having a similar problem with homesharing.....my daughter's music library won't connect to my laptop. 

     

    Windows 7 64 bit

    iTunes 10.6.3.25

     

    Thank you!

  • Marisafromwa Level 1 Level 1 (0 points)

    Ok, I finally figured out what was preventing my homesharing from working.......Comodo Firewall.  I uninstalled this firewall and everything is working fine.  I just switched back to the firewall on Windows 7.  Thanks everyone for your troubleshooting comments/suggestions here......I've learned alot about homesharing. 

  • Big Robs Level 1 Level 1 (0 points)

    FYI, thanks to another thread, the real bug is iTunes not releasing network connections.  You can see via netstat -a that when the problem occurs, there is more than the allowed 100 connections.  Any more than 100 will show as closed wait, which means that you get the spinning circle on your ATV, while the connection just sits there.  Moving to wireless, rather than wired, has helped a lot of people, because I think it forces the release of unused connections more often.  There are even some ruby scripts out there to monitor and restart iTunes, if you get more than 100 connections, and iTunes locks up.

  • zSi Level 1 Level 1 (0 points)

    Hi, thanks to everyone for the helpful suggestions.

     

    After trying everything - like turning off all firewalls, restarting computers and routers and ipV6 etc - I managed to get home sharing working properly on one computer. But frustratingly two weeks later not on the other two...

     

    A work-around for people who are similarly frustrated. Orb (orb.net.au) will let you play itunes content to an Orb wireless streamer. This works perfectly, showing the iTunes libraries from all three computers, and letting you play the music using tablets or computers as the controllers to your stereo. As a bonus the set up worked perfectly first time.... (oh if that were only true for itunes home sharing :-()

     

    I hope this is useful for people who may want to stream wireless music from multiple itunes accounts, and itunes purchases, at home (and no, I am not in the slightest bit in any way connected with the company!)