Previous 1 9 10 11 12 13 Next 193 Replies Latest reply: Jun 26, 2015 2:35 PM by Bangoman Go to original post
  • glenn43 Level 1 (0 points)

    Thanks SDBonez, you are certainly no idiot


    I have a Win7 64 Dell Laptop and Gen 3 Apple TV...worked then stopped....nothing fixed it all the standard apple tv stop, restart, computer stop start, router stop start, IPV6 disable , de-authorize and reauthorized itunes...hours of wasted effort.


    Your solution was simple and worked perfectly for me.


    For others just to be clear.


    a) Start itunes if not already started

    b) Start windows task manager (right click on action bar) or ctrl-alt-deltask.png


    c) Find and kill itunes process.


    d) Restart cleans up libraries or whatever interally is facked up and magically appletv will be able to see your library once again

  • MBeo Level 1 (0 points)

    I just upgraded to 6.1 on my iPhone from 5.1, and that's when Home Sharing with my iPhone stopped working. I've tried all the suggestions I coud find in these forums; apparently the problem is common, and the proposed solutions quite varied. I'm going to try to revert my iPhone to 5.1, which was better in many respects anyway. I sure am not fond of Apple support.

  • I_Like_Pizza Level 1 (0 points)

    Thanks Awadd


    Disabling IPv6 solved the problem


    Even after creating Windows Firewall exceptions for the ports and protocols as detailed from Apple; plus removing Home Sharing, changing passwords, upgrading iTunes etc etc etc - it ended up being quite a simple fix, disable and reboot, job done - but glad to have solved this for my brother's set up (Vista Home Premium, and iTunes 11, Apple TV v3) - now to get him onto Win8



  • Utrecht33 Level 1 (0 points)

    i finally have it solved! no more interruptions or not being able to my two apple tv's with the latest updates!


    My situation: 2 apple tv 3's with the latest firmware on them being served by a shared iTunes library (also the latstest version at this time) on a mac mini.


    I had the problem that i needed to restart both my apple tv's in order for them to see the itunes library i have setup on my mac mini. After they went to sleep for a while they would wake up and at that time they could not see the shared itunes librarby; only restarting them helped. It all worked fine untill i updated to the last available firmware for the apple tv's.


    Been trying eversince to get it working again. But now, i have it all working normally again.


    What did i do? 2 things:

    1) i re-updated the apple tv's with the same firmware that was on there for the last few days/weeks and


    2) they both had fixed ip-adresses in my network. Now i left everything default so they will get an ip from the dhcp server on my router.


    Voilá! working!


    Hopefully this will help someone else, this is why i post it here. I had been crazy why this problem started to appear all of a sudden and looked everywhere on the internet. Couldn't find any sollution.

  • eugeneyk Level 1 (35 points)

    Sorry for re-igniting an old thread but Apple still hasn't fixed it. Restarting iTunes did not help but disabling IPV6 worked for me here, let's see if it sticks.

  • eugeneyk Level 1 (35 points)

    Now iTunes is showing high CPU usage (25~30%), but I'll take it over not working at all. Stupid iTunes, the shittiest software since Flash.

  • dudeman618 Level 1 (0 points)

    I am still having problems.  Upgraded from windows 7 64-bit to Windows 8.  iTunes and Apple TV3 both up to the current version.  I still have the problem where the ATV device nearly always fails to connect to itunes.  When it does connect, it will play one video podcast, then fails to connect to itunes for any following play.  ATV3 works for streaming from the internet, but has all the problems connecting to itunes.


    I tried the ipv6 fix, turned on/off windows sharing.  I made sure the harddrive and desktop does Not go to sleep, no password on windows sharing, and tried everything else I know to do.  This is all with wired ethernet.


    I keep trying every couple of months, but having given up and have been using PLEX to stream movies, podcasts, and music from my pc via PS3 to my TV.  It always works, and is on the same system with itunes.

  • VJinOK Level 1 (0 points)

    Disabling the IPv6 worked for me, but oh my goodness why is this still a problem??

  • webtech5466 Level 1 (0 points)

    We are having the same problem, kind of.  I have an iMac which is the main home sharing computer. My husband has a PC running Windows 7 64 bit. On Home sharing he can see and access my libraries and I can see his on the left side menu under Sharing, but whan I click on it it just spins for a while and then disappears. He also cannot connect to ATV. Same thing happens.  Any suggestions?

  • czechpls Level 1 (0 points)

    For the Windows 7 users out there, disabling iPv6 kills home networking which relies on it to talk and authenticate. My solution for iTunes 11 usage in general is to connect via USB cable to update all 4 of my apple devices, sold my ATV2 (for more than I paid for it) and bought a Roku 3, and use Genius as a curiousity and not a necessity. Oh...and not expect any solution document to come out of Apple support.

  • Boabee Level 1 (0 points)

    My airplay only works from my iphone to my appletv (version 5.3). My itunes (version can see the appletv as the airplay icon appears in itunes. but when i try to play music through appletv it says it has connection issue or it has timed out. Also if i try to connect to my itunes library from my appletv i get another error about connections.


    I have noticed that for example : if my iphone is currently playing music through appletv and i try to play music from my itunes library to the appletv...when i press play with airplay switched on (icon turns blue) it actually turns off my music playing from my iphone. It as if itunes is attempting to connect but is unable to do so.


    This all began when appletv was updated!! Im in Australia! APPLE SORT IT OUT!!!!!!!


    Am i not the only one having this problem?!?!?!?


    P.S Apple Admins...... please stop sending us links to the most obvious troubleshooting pages! the reason we are on here typing comments like this is because we have TRIED EVERYTHING!!!!!!

  • AlgernonHH Level 1 (0 points)

    Hi All,


    This has become a severe problem for myself as well. I am highly experienced with MS and Mac environments and cannot come right here. My problem is related to trying to Wifi sync my iPad3 and iPhone 4S. I have tried all the standard iTunes Wifi sync troubleshooting


    I am running Windows 7 64bit Ultimate with iTunes v11.0.5.5

    I can't get this fixed. I have tried:


    1) Re-installing / restarting Bonjour services and setting permissions for mDNSResponder.exe based in c:\Program Files x86\mDNSresponder.exe  (Using commands - remove - install - start)


    - I have also disabled IPv6 on all the interfaces and also attempted to disable my VMware adaptors


    2) When starting mDNS responder through either using the .exe or restarting the service I get an error in Application event viewer either TCP


    Client application bug: DNSServiceResolve(e0:b9:ba:99:04:dc@fe80::e2b9:baff:fe99:4dc._apple-mobdev._tcp .local.) active for over two minutes. This places considerable burden on the network.


    ERROR: mDNSPlatformReadTCP - recv: 10053

    ERROR: handle_resolve_request bad interfaceIndex 21


    3) Checked all Firewall settings. I am confident that these errors on this forum are not related to a firewall at all as long as you are running a NAT and also trying to Wifi sync or Home sharing on the LAN. If you need to home share remotely then you would either need to use a DMZ setting on the Firewall / NAT policies for the regular ports or give your computer a public IP address (provided by your ISP)


    Anyone made any progress since the last post with this issue? At the moment I am going to remove all apple services and applications and try install a 32bit version of iTunes


    EDIT: The only two causes I can think of at the moment are iTunes bug with Windows 7 64bit setup or some conflicting application. I've checked ports using MS Sysinternals TCPView and cannot see anything else running 5353 or 5354 but there might be something on the UDP side causing mDNS to fail

  • FixedIt Level 1 (0 points)

    I have had success by switching from WPA2 wireless security to WEP. Resetting my router always seemed to fix the problem so I figured it might have something to do with the WPA2 key renewal. I know it's not as secure, but it has solved the problem for me. I haven't had an issue for over 6 months now.


    I was given an ATV3 for fathers day, and it seems to be functional except for one glitch. I'm hoping this was just a teething problem, as it hasn't happened again. I guess this will be the real test because the ATVs seem to be notorious for home sharing problems.


    I hope this is helpful to somebody, I remember how frustrated I was when I first encountered problems with home sharing. I'd appreciate if someone with a deeper understanding of router security settings can shed some light on why this fix has worked for me. I'd like to swithc back to WPA2 for the added security, perhaps there is a setting that will allow me to do this.

  • CortneyLodge Level 1 (0 points)

    THIS! this is awesome. I've been weeks waiting for someone to tell me how to fix this.

  • knubbel Level 1 (0 points)

    works perfectly for me! Thanks!