1 2 3 4 5 6 Previous Next 192 Replies Latest reply: Jun 15, 2014 5:56 PM by Onairek Go to original post
  • 45. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    Brad5153 Level 1 Level 1 (0 points)

    I think it is important to note that there could be more than one issue here...

     

    I mentioned earlier that I had the intermittent problems with Home Sharing dropping out while viewing content from my Windows 7 PC on my ATV2.  The only resolution is to close iTunes and restart it, at which time Home Sharing reappears on the ATV2.  Yet I seem to be able to Sync wirelessly and I can stream content from my iTunes via Airplay to my Apple TV or my Airport Express with no really issues or interuptions.  I have checked the power settings on my PC and the NIC and PC in general is not using any power saving modes.

     

    This is not the same as: "I can never connect to Home Sharing" or "My IOS device cannot sync Wirelessly", which I will concede could very well be a port/firewall setting as it is constent.

     

    Just an observation and clarification.

     

    I will be trying the possible workaround to turn off the Wireless Sync on our iPod Touch units in order to see if it is just a conflict between the two functions (Home Sharing & WIreless Sync).  This could be a viable temporary solution as the isse really began with the introduction of the wireless sync feature.

     


  • 46. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    brucefromnj Level 1 Level 1 (0 points)

    I had bought a new router about the same time I upgraded to 10.5.1.

    It was then that I noticed Home Sharing was not working with my ATV2 (or at all).

    Didn't know if it was due to router change or upgrade, but saw some posts here and began to lean towards the upgrade causing the problem.

    Waited for 10.5.2

    When 10.5.2 was installed, Home Sharing started working again.

    This was fine for a couple days.

    Then I received notice of an upgrade for ATV2 and installed it.

    Ever since then Hone Sharing stopped working again on ATV2 or with any other device (see it appear briefly in iTunes when I turn Home Sharing off and on within iTunes (in an lame attempt to fix), then disappears - like reported in other posts.

    Very frustrating!

  • 47. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    jalperin Level 1 Level 1 (10 points)

    turning off wifi sync in iTunes for iPhone and iPad did the trick for me also, but of course, that's only a workaround, not a solution.

  • 48. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    Kev_WeLearn Level 1 Level 1 (0 points)

    Thank you so much for the easy yet troubling fix! I was having the same problem as many people in these forums- access to the internet was fine on Apple TV2 but no access to Home Sharing.  After disabling wireless syncing for my iPads, Apple TV came up loud and clear. 

     

    Why would Apple push out a software version that has two important services (Apple tv, wireless syncing) share a port?  I expect more from Apple and their products.  Still, well done dgande and at least now I can actually use my Apple TV like it was supposed to be used.

  • 49. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    El Steve Level 1 Level 1 (0 points)

    I found that uninstalling Bonjour and installing an earlier version cleared up all my problems. Not sure where to find earlier versions of Bonjour - I used one from the Air Display software package from Avatron.

  • 50. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    aprxd Level 1 Level 1 (0 points)

    I followed your suggestion and uninstalled both Bonjour and Bonjour print services in Windows 7 (64bit). Closed iTunes, downloaded Bonjour Print Service from http://support.apple.com/kb/dl999, let it run install and updates. Started Home Share in iTunes and used Apple Remote on the iPhone to connect...and it worked!

  • 51. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    deckard71 Level 1 Level 1 (5 points)

    At last !!!

     

    What worked for me was to change the wifi passowrd encryptation from WPA-PSK to WEP. Immediately after that, both the Apple TV and iTunes showed up on the Remote app.

  • 52. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    Daniel - Calgary AB Canada Level 1 Level 1 (0 points)

    Yes I have the same issue. Can you be more specific as to how to do this. I am not that tech. savvy - Thanks

  • 53. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    ZenFury Level 1 Level 1 (0 points)

    Thank you so much, this fixed my issue instantly.  And I haven't been able to get home sharing to work for months, after hours and hours and hair pulling.  Why isn't this in the apple help section???

  • 54. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    carol110 Level 1 Level 1 (0 points)

    I hope this helps someone. I originally had 2 computers connected via home share. One an HP, connected to the router wired, the second a PowerMac, connected to the router wireless.

     

    Home sharing worked flawlessly between the two.

     

    The problem arrived when I added a third computer, a Dell, also connected wirelessly. The HP and Mac still worked fine, but neither could see the Dell, and vice versa. I played around for hours with the settings on the Dell, and the router, with no luck.

     

    Then, something occured to me. I went into preferences on Itunes on the Dell (the "new computer") and turned on Sharing (shared my entire library). The Dell still couldn't see the HP or Mac, but viola, both the Mac and HP could see the Dell.

     

    So I then turned on Sharing on the Mac and the HP, and sure enough the Dell could then see them too.

     

    So it seems that for some set ups, turning on Sharing in preferences isn't necessary (ie, between my Mac and HP...original set up), but for others, turning on Sharing in preferences IS necessary (ie between my Dell and MAC and Dell and HP).

     

    Again, I hope this helps.

  • 55. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    carol110 Level 1 Level 1 (0 points)

    Ok, so I lied! Well, not really. But now it stopped working again! I had to restart my (new) computer and when I did, back to the drawing board. I also tried enabling home sharing on my daughters Ipod Touch, and it doesn't see anything.

     

    Every once in a while the (new) computer (Dell) will appear on the Mac, but not on my other PC (HP). Again, the HP and the Mac work flawlessly, despite my trying to get it to stop working.

     

    I read somewhere to check the "multi-casting" settings on the router, but I'm not sure exactly where that is (I have a Uverse Home Gateway), so I'll have to do some more poking around when I get home.

  • 56. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    jf_pha Level 1 Level 1 (0 points)

    I first changed my wifi to wep based off of other suggestions but that didn't work. So I tried uninstalling bonjour and installing the bonjour print link suggested. After downloading bonjour I logged out of home share and logged back in and thankfully it finally worked. Hope it works for others.

  • 57. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    ZenFury Level 1 Level 1 (0 points)

    I take mine back. Got apple tv to work, but no home sharing between computers, or any other device with computers. Stupid stupid stupid. And the Apple silence continues...

  • 58. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    carol110 Level 1 Level 1 (0 points)

    Ok, well for now, I've got mine working. I was having trouble with my TV Service for Uverse, so they came out and replaced my Residential Gateway. When I reconnected everything to the new gateway (router), everything seemed to be working, then it all dropped out.

     

    So I decided to literally "start over". I logged into the apple website and reset my password to a new, completely different password (on some machines, my password had a capital letter, on others it didn't..yet still logged in fine).

     

    Then, I deauthorized all the computers, then reauthorized them all. Then I signed-in to the Apple Store in Itunes, and then I turned on Home Sharing.

     

    So far, even after several restarts of each computer, and turning on and off Itunes on each, Home Sharing finally seems to be working.

     

    I've even gotten my daughters IPod Touch to "see" all the shared music as well!

     

    I think part of the issue might be that at some point my password may have changed (did Apple do an update to passwords at some point?), and so my older computers were still "signed in" perfectly fine, but the newer computer (and the Ipod Touch) weren't signing in to the Itunes Store properly, causing home sharing not to work properly. Might be worth trying for those who haven't had any luck trying anything else.

     

    I also think that  at least one of the computers (and maybe even two) were authorized on more than one Itunes Account. My wife also changed her name when she married me, and the account we use is hers, and I think at least one machine may have even been logged-in to the account she had in her maiden name.

  • 59. Re: iTunes 10.5.1 Home Sharing not working (Windows 7 64 Bit)
    AJH205 Level 1 Level 1 (5 points)

    I guess it goes without saying, nothing improved for anyone after the 10.5.2.xxx updates and I see a regular stream of homesharing not working threads appearing!

     

    Some great suggestions on this thread so far, yet none have worked for me.  In my particular case I do NOT use WiFi between my Apple TV and Window 7 machine and for the heck of it I've also unplugged my broadband router to eliminate this somewhat ridiculous suggestion by Apple - and homesharing still did not work across my gigabit switches between the ATV2 and Windows 7 machine.  I tried removing all Bonjour installs and removing iTunes completely with a fresh install - no luck.

     

    Great if the WPA to WEP fixes work for some, but I recommend against downgrading your WiFi security as a fix for this.  It certainly isn't a fix for me though.

1 2 3 4 5 6 Previous Next