Previous 1 4 5 6 7 8 Next 193 Replies Latest reply: Jun 26, 2015 2:35 PM by Bangoman Go to original post
  • DavisGTP36 Level 1 Level 1

    same problem here airplay icon is gone in iTunes but I can still use it with all my iPhones and iPads.

  • mimis_munchies Level 1 Level 1

    Had the same problem  but finally found the fix:


    Go to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings


    Go to File sharing connections (In your current Profile)


    Click on "Enable file sharing for devices that must use 40 or 56 bit encryption"


    Save Changes


    Try your remote ... My Iphone 4 "Remote" program would not work on a 64 bit Win 7 machine until I tried this ... Now it works great!

  • jpiszcz Level 1 Level 1



    As mentioned earlier:


    1. Turn off wireless sync on all of the devices and sync each device:

        What I found to fix it quickly after performing #1..

    2. Deauthorize your computer.

    3. Authorize your computer.

    4. Turn on Home Sharing (step 2,3) should leave it disabled by default.

    5. Open YouTube on your iPhone/iPad/etc and play a movie to the Apple TV.

    6. Let it play for a few minutes.

    7. Close iTunes.

    8. Open iTunes, play a movie/tv show or MP3 and then you now have the option to play to the Apple TV.

    9. Likewise, on the Apple TV you now can see the computer and iTunes library.


    Weird number of steps to get it working, but it seemed to do the trick; recently I wanted to try wifi-sync and then this problem cropped up again, best to keep it off.



  • Darincmr Level 1 Level 1

    I have been having this same issue that so many have been talking about with my Apple TV2s since installing the newer iTunes software in the fall of 2011.  I am frustrated like everyone else.  I have wasted countless hours trying new ideas to fix this issue.  I am extremely surprised that Apple has not effectively addressed this issue with a fix. 


    I have tried your fix jpiszcz and no luck.  I have also tried all of the other previous ones.  I can get one of my Apple TV2s to work (unplugging the other 2) for about 5 minutes after turning off home sharing, but then it just stops.  This home sharing feature sounds great, if it only worked again (initially, after buying my first Apple TV2 it worked for a few months).  It seems clear to me that there are many many people having the same issue with Apple TV2 and home sharing, yet it is has gone unresolved for so long. Does anyone know of a real and definitive fix for this issue?  If not, shame on you Apple for not resolving this. 

  • melodyfromnewbury Level 1 Level 1

    Thank you so much!

    I always look on forums and just pick the easiest looking answer first, and this worked!


    Thank you loads!

  • dabean Level 1 Level 1

    Hi everyone, I had the problem and fixed it.


    I could see the my library through home sharing on the Apple TV, but it wouldn't connect until now.


    I'm running an imac 10.6.8 with apple tv second generation. I am a hobby photographer using aperature and wanted to share my thousands of photos through homesharing on my apple tv and couldn't figure it out.


    Fix: Go to System Preferences, Security, Firewall...

    Leave firewall on, BUT in "Advanced" settings UNCHECK "block all incoming connections"




    Hope that helps,

    da Bean

  • rayarg Level 1 Level 1

    After reinstalling iTunes 10.6 for Windows 7 and turning off wifi sync in iTunes for my iPhone and iPad, home sharing now works.  It's definitly a conflict between wifi sync and home sharing.

  • ProtocolGeek Level 1 Level 1

    Firebind has a test that can let you know whether the Bonjour TCP and UDP ports listed in the Apple Support FAQ are being blocked or not.



    It wil test TCP 5297 and 5298 as well as UDP 5298 and 5353 to confirm there is no firewall blocking them.


    - ProtocolGeek

  • AWadd Level 1 Level 1

    I struggled with this problem for a long time, but I think I have finally resolved it.  My home sharing would only work sparodically on my Win7 PC, only after fiddling with a bunch of settings, rebooting various devices, restarting bonjour, crossing my fingers and standing on my head.  Finally I looked at the event viewer, found several errors that were happening in Bonjour, and looked at some windows sites.  I discovered that itunes does not play well with TCP/IPv6 ( the latest internet protocol).  I went to Control Panel -> Network and Sharing Center.  Clicked on Change adapter settings, right-clicked on the network icon, seleted properties, unchecked Internet Protocol Version 6 (TCP/IPv6) ( I left version 4 checked).  Then I hit okay, and rebooted my PC.  When it came back up, Home Sharing was working perfectly, and all my devices showed up under wifi syncing.  I have rebooted my PC several times, and have not had the problem again!


    Hope this helps!


    My Setup

    Window 7 64bit PC


    2 Windows 7 64bit Laptops

    Cisco LinksysE4200 router

    (2) iPhone 4

    Apple TV 2

    Ipad 2

    2 ipod Touches (4th Gen)

  • jpiszcz Level 1 Level 1

    Do you use Wireless Sync?

  • AWadd Level 1 Level 1

    Yes.  And it is working now.  Sometimes I have to reboot my devices so iTunes will see them (I get messages sometimes that iTunes can't find this [device]), but it's working much better than it was.

  • Nikhil Kumar Level 1 Level 1

    Just wanted to confirm, disabling iPv6 for the connection fixed my home sharing as well on Windows 7, iTunes 10.6.


    Thanks Awadd!

  • thebigstoat Level 1 Level 1

    Thank you topmanpaf! That sorted my problem

  • rgalla1 Level 1 Level 1

    Thanks AWadd, that fixed it for me.  But, why would I need to make that change?  That *****.

  • AJH205 Level 1 Level 1

    Yes!  Thanks AWadd, disabling IPv6 solved the problem for me as well.  Looks like Apple definitely need to do some work here on Windows 7 compatibility and IPv6.  No big loss on my local network not having IPv6 - so happy to disable it to work around this ignored bug!  Thanks for sharing AWadd! 

Previous 1 4 5 6 7 8 Next