Previous 1 2 3 Next 42 Replies Latest reply: Jul 1, 2006 2:28 AM by kev fr Go to original post
  • Blue Moon Level 1 (0 points)
    I wouldn't bother at this stage even trying. Try speaking to someone at HP support to see if they have a suitable driver first. You never know you may get lucky!!
  • Carl Chamberlain Level 1 (135 points)
    I have installed 2 HP Laserjet 1020s on 2 Intel iMacs now. Both times I had to install it a couple of times and 'poke around' changing things and restarting the Mac - and both times it eventually worked. I wish I could be more specific - but there didn't seem any logic to it at the time. They have both worked solidly and without problems since though.
  • tivoboy Level 1 (10 points)
    how? How did you do the install?
  • J Morris Level 1 (5 points)
    I got an epson cx4200, and HP PSC 1610 to work on my Core Duo. I had to install the drivers several times, but on about the third time, it worked. If you manually install the printer you may have to look up and down the list, because it created more than one HP folder for my drivers.
  • WebSailor Level 2 (310 points)
    Take a look at this apple info page. ...


    ... http://docs.info.apple.com/article.html?artnum=301175



    I find it interesting that this list of supported printers also includes my old Epson Stylus 500 - which has parallel and serial ports only. But I was happy to find my old Epson Stylus 740 is still being supported in Tiger.
  • iMacfly Level 1 (25 points)
    "Evidently, there is a problem with printing on an Intel Mac that has nothing to do with the OS." That sounds right. I had my Deskjet 812C working on a new Mac Mini with the latest OSX build and it worked very good with the drivers OSX installs. On my MaciNtel I get garbled text. It looks like it identifies my printer but it doesn't print well. If I do a cartridge cleaning all of the text looks normal. Well, we are the beta testers;)

    iMac 17" Intel Core Duo   Mac OS X (10.4.4)  
  • rogerdee123 Level 1 (0 points)
    In another forum someone had no problem installing my printer model but after some discussion it was determined that he was connecting via ethernet.

    So it would be useful to know if those who are having these printer problems are only using USB connected printers or are the problems also being encountered while using ethernet? i.e. does the problem lie with the USB port perhaps?

    My problem is connecting the 20 inch dual intel iMac via USB to a HP2550 color laserjet.
  • Carl Chamberlain Level 1 (135 points)
    I ran the install program - and the printer didnt show up as a choice - but ran install again and messed about trying diffent HP models that did show - eventually 1020 showed up there. Vague i know, but it worked twice. Absolutely no problem in use
  • Rod Assassa Level 1 (20 points)
    I had problems with both directly connected via USB and Ethernet connected via Airport Extreme. Same results.
  • iMacfly Level 1 (25 points)
    My problem is with a USB connected printer.
  • Mark@Holliers Level 1 (5 points)
    Both my printers are connected via USB

    Having dug around in the "HD/Library/Printers" folder it does appear that most of the drivers which install with the OS are marked as "Universal" (both on the icon and in the "Show Info"). The drivers from the printers I install are marked as "PowerPC" - I guess this would imply that the drivers do need to be rebuilt for Intel Processors; this is certainly reinforced by the messages in this thread.

    I have posted a support call to Lexmark and am hoping for a reply in the next day or so - when (if) I get it I will report back.

    The scanner on the Lexmark, and all the status stuff (like cartridge info) works fine - it's just that the printer does not appear in the list of printers in the config app and the driver hasn't installed.

    I suspect we're going to be waiting (and hoping) for manufacturers to re-issue new drivers

    iMac Intel   Mac OS X (10.4.4)  
  • Hans-Joachim Fabry Level 1 (15 points)
    Had that problem on my iMac 17" Core Duo. After a couple of installation/de-installation attempts i found out that the printer drivers ARE installed correctly (a HP LaserJet 6P IP printer in may case), but for some reason didn't show up in the printer preference pane until i closed the system preferences and restarted them again. Printing works from all applicatons.

    cu/

    Hans-Joachim
  • Carl Chamberlain Level 1 (135 points)
    Yes - this bears out my experience too. I wasn't quite sure what I did that got it to work - but it was quite possibly the same thing.
  • Mark@Holliers Level 1 (5 points)
    Hi

    I have found this on the Kodak web site

    http://www.kodak.com/eknec/PageQuerier.jhtml?pq-path=3924/4547/7269&faqKnowledge base=157en&faqTopic=6&faqQuestionId=240&pq-locale=en_US&requestid=8586

    Seems that drivers will need to be re-written for Intel processors

    iMac Intel   Mac OS X (10.4.4)  
  • rogerdee123 Level 1 (0 points)
    On another forum, someone was able to get their USB HP Printer working on the intel iMac using gimp-print drivers.

    I haven't tried it yet.