9 Replies Latest reply: Nov 22, 2011 9:34 PM by Topher Kessler
multiplryan Level 1 Level 1

Apologies if this question has been repeated (I did try to search for it but no luck).

 

I saw a property in Onyx or Cocktail for "single application mode" which will hide all other application windows besides the one that just got focus. This is irritating me to no end and I immediately reverted the config change. While I seem to recall it worked at the time, my OSX 10.7 (early 2011 MBP) acts like this all the time. I've tried to set/unset this option but it just won't go away. I hate it! My questions are:

 

  1. What is the actual defaults property is that sets this behavior?
  2. How do I make this stop happening?
  3. Has anyone else experienced 10.7 refusing to cooperate on this issue? Am I doing something wrong or is there a problem with the software?

 

Ok.. thank you. It seems like Apple Support Forums should have an easy-to-update FAQ functionality.


Mac OS X (10.7.2)
Solved by multiplryan on Nov 22, 2011 7:04 PM Solved

Finally.. it was Quicksilver. An option under 'Extras' about hiding apps while switching apparently does what I described. I don't know why it wouldn't be more clear in the preferences but... oh well. Fixed! Thanks, folks..

  • sig Level 8 Level 8
    expertise.macosx
    Mac OS X

    You've mucked up your Mac using third party apps and now you're upset. Why do you think you need these to begin with?

  • Pondini Level 8 Level 8

    On the OnyX Dock panel:

     

    Screen Shot 2011-11-19 at 9.51.08 PM.png

     

    If you remove the check, it should revert to normal (you may have to Restart).

  • captfred Level 7 Level 7

    The dock must be relaunched for the change to take effect.  Logoff/Login.

  • multiplryan Level 1 Level 1

    Running apps of any kind is sort of why humanity invented the operating system. Besides, as I wrote, I could have done the same thing with defaults, which is an Apple app. If you know of anyone who is familiar with Apple apps, maybe send them to this support board, huh?

  • multiplryan Level 1 Level 1

    Thanks for taking the time but that's what I meant by "I've tried to set/unset this option but it just won't go away." I couldn't remember whether it was Onyx or Cocktail but I had turned on the mode, then turned it off, and this might not even be related to me doing that -- it's just the easiest way to describe what's happening (it is behaving exactly like it did in single app mode).

     

    I thought maybe someone would know off-hand. I can look it up. I'll post here the solution.

  • multiplryan Level 1 Level 1

    It's much faster to killall -9 Dock from the shell when you want to restart the Dock (instead of logging out and back in).

  • multiplryan Level 1 Level 1

    Hm, well, I was hoping this wasn't the case. It's easy to disable the single-app mode from Onyx with defaults:

     

    defaults write com.apple.dock "single-app" -bool false

     

    So.. now I gotta figure out what other property is out there that hides all app windows except for the windows from the app with focus. Any ideas?

  • multiplryan Level 1 Level 1

    Finally.. it was Quicksilver. An option under 'Extras' about hiding apps while switching apparently does what I described. I don't know why it wouldn't be more clear in the preferences but... oh well. Fixed! Thanks, folks..

  • Topher Kessler Level 6 Level 6

    Running apps of any kind is sort of why humanity invented the operating system.

     

    I love that response!