Previous 1 2 Next 17 Replies Latest reply: Nov 22, 2013 9:58 AM by noelty-kay
Adamgs Level 1 (0 points)

Hey guys.


Long time buyer, first time complainer.


Ive had problem free Macs for years, but this new iMac has been nothing but problems software wise. I STILL have to turn my wifi on and off to re-estabilish a connection.


Anway, the problem today is my Magic Trackpad. Its just decided to start clicking and selecting everything. I move it across my screen and it tried to click everything. It wont stop!


Ive connected a Magic Mouse and that works fine so its definetly the trackpad. Ive restarted my Mac, ive repaired permission, Ive re-paired the Trackpad and replaced the batteries but still no luck.


Any tips guys!!??

Magic Trackpad, Mac OS X (10.7.2), iMac 2.5ghz Quad Core (2011)
  • X423424X Level 6 (14,215 points)

    Try smc reset.

  • izumpriz Level 1 (0 points)

    I had the same problem.  My magic Trackpad all of the sudden started selecting everything.  I tried everything.  Turned off wifi, resetted my router thinking it was interferring, switched computers, reset PRAM, changed batteries.  Nothing helped.  I took it into the genius bar where they usually are no help to me.  But this time the guy who helped me said he never seen this and replaced it for free.  My advice is to bring it in and see what they say. 

  • Audrey Lepere Level 1 (0 points)

    Hi guys, I came in search of this issue having encountered it today to an extent that has effectively rendered my machine useless to me. I saw there is an archived issue on the same subject called "Trackpad keeps selecting everything!" I can tell you that the problem is not with new macs alone- as the archived thread shows, but no solution was confirmed on that archived thread so I'm none the wiser. I agree with the first poster, I has never had cause to approach this forum until recently and since installing lion os on my machine I've has no end of instability problems- mostly unpredictable apps crashing (mail notably) when doing minimal tasks. I'm not sure if this issue is software / trackpad related or if it as per some suggestions in previous threads, the result of a battery issue/ swollen battery causing a physical hardware issue. The only notable changes to my machine have been a battery and a lion upgrade. I'm not supposing to blame either, but I'm unable to work at present. My trackpad selects everything the cursor comes into contact with, drawing rectangles when it comes into contact with nothing.. I can't get to my dock because it's "drawing", and when i can things get hazardous, apps get removed accidentally (harmless i know) and files on my desktop get dragged around. I can't use any programs and restart doesn't help. Connecting a mouse gives me more control but when typing i seem to also be encountering strange frustrating behaviours that make using my machine presently impossible. I've really no idea the cause of this but im keen to find out the cause and the fix for a problem that has definitely and obviously been encountered before. My machine is a macbook pro 2007 so interestingly not the sane machine as the other user in this thread but the same as some in previous threads on this issue. I'm also working in Argentina where we do not have Apple stores or trustworthy support, so before purchasing the solution- be it a mouse/ trackpad/ battery/ repair, I'd love to know what that might be! If anyone can confirm from experience please let me know. If your advice is restore related, im not keen since this developed immediately as of this morning with no recent changes to roll back. But if it's a guaranteed/ known fix im happy to do it though i must say my machine is (except for adding Photoshop etc unmodified in terms of its settings (I dont change anything i dont need to - precisely to avoid these issues but ive been pretty disappointed with everything these past weeks using Lion os) Please help (via iPhone!)



  • cdiehl Level 1 (0 points)

    Same here..




    If you tap the Trackpad and hold for a few seconds then either text gets selected or underlying options of GUI widgets get activated. The tap to click option is deactivated in the preferences.


    Example: Move your cursor over an Application in the Dock, tap the Trackpad and hold a few seconds. The Context menu of the Application will open.


    This means in usual day to day routines (when you need to move the cursor from position A to position B) that the Trackpad driver executes a click/tap behavior somewhere on the way to position B. This leads than to a strange behavior of moving files around, selecting text, clicking buttons or other GUI widget elements etc. etc.


    That's what I have personally observed, can't speak for the rest of the people in this thread. Although, everything sounds familiar.


    Best, Christoph

  • michelle918 Level 1 (0 points)

    I have the same exact problem, down to every last detail, except my MBP is a 2010 model.   

  • Audrey Lepere Level 1 (0 points)

    Hi Michelle, Christoph,


    You can see that I wrote a long post just before you on this thread. I found a solution which in my case has been working since, although I can't be sure if it would help you but I'd like to let you know incase you can try it. I read in a previous post on one of these threads regarding the trackpad that this could be the result of a swollen battery so having battled with the problem all day on a useless machine, I took out my battery, performed a PMU reset by holding the power button down, and then turned the machine back on without a battery in it. This then resolved the problem and I have since replaced the battery and not experienced any problems. I can tell you that my battery was indeed visually swollen, so I am almost certain that, in my case, this was the cause of my sudden and chronic problem, and makes sense due to the location of the battery on the underside of the trackpad. As I said, I can't promise this would resolve your problem,and if you are not experiencing the problem to the extent that I was (I was not able to do anything at all on my machine from the point of this problem emerging onwards!) then perhaps you could try your machine without the battery or with a replacement battery. I'd be interested to know how you get on though! I hope you can resolve all your issues.


  • RioGator Level 1 (0 points)

    Hey guys, same problem here.  I'm on a Mini and my trackpad has gone crazy.  The trackpad is about a year old so it's out of warranty and I'm also in Brazil where there's no Apple stores.  I've tried everything that has been suggested, but no dice.  If anyone has any other suggestions I'd appreciate it.  I guess it's back to a mouse for now.

  • RedBrown Level 1 (35 points)

    My TrackPad has been working perfectly fine until today. It continuously clicks everything everywhere. Magic Mouse and MacBook Pro's trackpad work fine so something is wrong with TrackPad for sure, either software or hardware.

  • Jerry Peters Level 1 (60 points)

    I called Apple after trying all the suggestions and the last thing they had me try was to clean it with Windex!  Apparently over time an invisible film can accumulate from skin oils.  I tried it and it worked!

  • uuseverson Level 1 (0 points)

    Exact same problem. I removed the battery and am now operating only on corded power, and all is well. Thank you!

  • clintcarter1999 Level 1 (0 points)

    Just started having this problem on a 2008 MacBook Pro.

    Happened with either the trackpad or a wireless mouse.


    Powered Down

    Removed the Battery

    Booted up and the problem was solved.

    Powered down

    Added the batter again and booted up

    Problem was back.


    The battery is new and haven't had the problem until recently.

    So I guess I'll work without a battery until I can take this in...

  • uuseverson Level 1 (0 points)

    Yes, it is the battery. I had the same problem after about five years. Apparently the battery swells and warps over time, pressing against the underside of the trackpad. Bought a new battery and problem solved.

  • barefootin Level 1 (0 points)

    I had the same problem.  One of the people who responded to this thread had the anser for me, and possibly for you as well.  Go to your System Preferences, then to Track Pad, and make sure the "tap to click option is deactivated" in the preferences.  If it's not checked, try checking it and see if checked or unchecked solves the problem.   Checking worked for me.

  • noelty-kay Level 1 (0 points)

    I have the same problem.  My trackpad started selecting everything this morning.  I tried everything listed in this thread to trouble shoot the issue.


    *Changed the batteries

    *Reset the SMC

    *Reset the PRAM

    *Cleaned the trackpad with Windex

    *Removed the Trackpad from the the bluetooth devices under system preferences and then re added it.

    *Connected a USB mouse to my iMac and I did not have the problem


    After all the trouble shooting I contacted Apple support and they setup an appointment at my local Apple Store to replace the trackpad.  The CSR from Apple said that this is a known issue and the trackpad will be replaced under Apple Care.

Previous 1 2 Next