Previous 1 2 Next 23 Replies Latest reply: Apr 12, 2014 7:33 PM by halimfromqld
MarkRHolbrook Level 1 Level 1 (135 points)

Hi all...

 

I two of the earlier generation Apple TV units with the built in HD.  I have a small movie collection.  My wife still like to have that physical DVD but I'm trying to get her excited about the idea of downloading movies.

 

So early yesterday I purchased Harry Potter and the Deathly Hallows, Part 2.  I purchased in my MacPro system as I've done with many other movies.  My apple TV is set to sync with the library on my MacPro.

 

So last night with the kid out of the house my wife and I sit down to enjoy dinner and a movie and I pull up the movie on Apple TV which shows the opening menu and plays the theme music.  The menu has options for play move, scenes, extra etc.   So I select play movie and the screen clears and I get the whirling little network activity thing in the middle of the screen.  Normally a short time later the movie starts but this time it says:

 

Your Apple TV is not authorized to play this content.

 

So I exit and try again.  Same thing.  I went to the MacPro and re-synced.  Same thing.  Basically my Apple TV would not play the movie.  To no spoil our night I went ahead and rented the **** thing (another $5 spent) and it downloaded and played. 

 

But what would cause the purchased movie to give that error?  Any help would be much appreciated.

  • Winston Churchill Level 10 Level 10 (90,185 points)

    This problem seems to have started around October 28, it appears to affect content purchased only on other devices but played on the Apple TV 1.

     

    There have been other workarounds suggested from time to time, but I have found the simplest solution is to purchase something on the Apple TV 1 directly (There may be free content in some locations and this appears to work just as well).

     

    Once the content has been purchased, it will not only play as normal, but will also allow all other content purchased on other devices after October 28 to play as well.

     

    Some have reported that it's necessary to restart the Apple TV before and/or after purchase, but I found it worked without.

  • limbery Level 1 Level 1 (25 points)

    I've recently bought one series and a few other TV episodes from itunes on my imac and get the same message when trying to stream them to my 1 gen. ATV....all my other purchases still stream fine but I bought them around the time period that Winston C. was mentioning....so now I guess I've either got to re-purchase them on the ATV or just be content watching them on my imac...I'm beginning to wonder if it's getting necessary to buy the ATV2?....or since I've held out this long, maybe there will be an ATV3 in the near future?

  • Winston Churchill Level 10 Level 10 (90,185 points)

    You don't need to repurchase them, purchasing something else will resolve the problem with the files you have already purchased.

     

    if you don't wish to purchase anything, you could unpair and re-pair your library to the Apple TV and de/re authorise your computer, in some cases this might be a preferable option but for those with lots of synced content it's a pain, I suggest a new purchase because it's the simplest solution.

  • Alley_Cat Level 6 Level 6 (18,785 points)

    Try a free TV Show purchase if you can find one or unpair/repair as Winston suggests.

     

    I would also urge you to send feedback to Apple as we should not have to purchase something to get other content to play or be inconvenienced by resyncing the whole device.

     

    http://www.apple.com/feedback/appletv.html

     

    AC

  • Winston Churchill Level 10 Level 10 (90,185 points)

    I brought it up AC and haven't had a response, my feeling is it's an issue that's here to stay.

  • Alley_Cat Level 6 Level 6 (18,785 points)

    Well, I think they should at least have an advisory on the support pages if this is the case.

     

    Admittedly ATV1 is over 4 years old but was on sale until just over a year ago.

     

    Apple's tendency to drop support for older products will lose them customers if they continually do this kind of thing.

     

    We're not asking for new features just for the device to be able to continue to do what it should without jumping hoops even if it's an intermittent need - will this problem recur every month/year ?

     

    AC

  • MarkRHolbrook Level 1 Level 1 (135 points)

    Thanks everyone for the time you took to respond.  That is what makes these forums useful.

     

    I did post a feedback response and I will try some of the other suggestions here.  I think I will also contact apple care and complain as well.

  • limbery Level 1 Level 1 (25 points)

    I repurchased 2 episodes on the ATV which still play only on th ATV...the other (and duplicate files) on the computer still won't play... I guess I'll just be sure to buy any future shows from the ATV interface....funny that I hadn't had this problem before and it only happened this one time when I bought a series and several other individual shows at once from the iTunes store...

  • AlanG SPF Level 1 Level 1 (0 points)

    Hello Folks,

     

    I ran into this problem this morning when my kids where unable to play content purchased yesterday on my MacBook Pro.

     

    I tried resyncing the TV shows, signing out and in on to the Apple Store from Apple TV, and even rebooting AppleTV 1.  Nothing seemed to work and perviously purchased content was playing just fine.

     

    I tried the suggestion earlier in this thread to purchase something from the Apple Store from Apple TV 1 and it did work.  I "purchased" a free TV short and my perviously unauthorized content started playing as expected.

     

    I hope that this thread helps others who run in this problem in the future.

     

    Thank you everyone for your suggestions.  You've made my kids happy that they can watch their TV shows on Apple TV 1.

     

    Alan

  • sueinphx Level 1 Level 1 (0 points)

    Just want to share what I did in my Apple TV 2 situation similar to the above which fixed the problem for me.

    Situation:  downloaded purchased itunes movies to my iPad (original), using Airplay with Apple TV connected with regular HDMI cable from non-internet connected router to the TV [iPad airplay to Apple TV viaTrendNet travel router (AP mode) to a HD TV].  Router not connected to internet on-purpose as I want to play the movies while staying at the sand dunes over the holidays.  When I tried playing the videos I downloaded I got the message about the Apple TV not authorized to play this content.  In reviewing the different steps some folks had tried, I decided the downloading a free movie through a router connected to the internet directly to my Apple TV seemed most logical (to my IT brain).  So I reconnected the Apple TV to my regular house router which is connected to the Internet, purchased/downloaded the freebie Ice Age Christmas clip (so funny, btw) and played it just fine.  This apparently kicked something internally in the Apple TV "into gear", as I then disconnected the Apple TV from the house router (internet connected) and connected to my travel router (not connected to the Internet), connected the wifi connection on my iPad to the travel router (for the configuration above in brackets}, tried playing my purchased videos on the iPad through Airplay again and now they all play just fine through the HD TV.  Success is sweet and took less than 10 minutes without all the deauthorizing and reauthorizing mentioned above as possible solutions.  I will note that I had the latest Apple TV update done a couple days before and I have only had the Apploe TV for about a week.  I had also recently updated iTunes to the latest version but don't think that had anything to do with any problem.  My strong suspicion is that the issue lies within the Apple TV software (IMHO).  So if you are trying to work out a similar situation, give it a try and I hope it works for you as well.

  • limbery Level 1 Level 1 (25 points)

    Well I've just re-purchased the content on the ATV to get it to work and will no longer buy on another device...

    BTW...I've got ATV 1 (the old one) and can't be bothered playing with routers and trying to re-set devices to sync with one another...

  • Apocolypse37 Level 1 Level 1 (0 points)

    I had the same problem with a Movie I had Purchased.  I then went from the Apple TV and downloaded a free tv show episode, and I can now watch the movie I downloaded on My Computer!

     

    Thanks for the help!

  • Brendan Bellina Level 1 Level 1 (125 points)

    Had the same problem tonight with a movie I purchased on my Mac last weekend. To solve I went to TV shows on the Apple TV, searched for Ice Age and downloaded the Scrat's Continental Crackup part 2 which is free. As soon as I got the pop up dialog that said that I could watch it now or go to menu I went to the menu and then went to My Movies and the movie I purchased last week started playing fine.

     

    Thanks to Apple for screwing this up (along with so many others things lately unfortunately). Thanks to the community for posting about how to fix it.

  • SoCal Mark Level 1 Level 1 (0 points)

    I've been a huge AppleTV advocate since it launched, own a few, and have given them as gifts on numerous occasions.  I appreciate this discussion, because I ran into this problem two weeks ago and was really frustrated that new downloads from two season passes that have automatically dowloaded for months and worked, all of a sudden stopped playing with the infamous "This AppleTV is not authorized..." message.  I sent Apple a detailed description of the problem, timing, etc. and on the first attempt received a canned "cut n paste" response to my issue.  When I responded to the first round support that felt like an insult, they refunded my account for the episodes that wouldn't play.  I will use the work around from this dialog, because I actually love the product and want to watch the content, but I think everyone needs to go after refunds so they actually fix the problem.   Unlike some electronics, where the years since release is a major part of the support/no support 'selling model' Apple's model is built around the content and they will continue to make them less expensive and practically give them away if it means more downloads.  Thus, Apple, help those who have supported this great, but poorly marketed product, by fixing this strange issue that could change the trajectory of my historically strong spending pattern on iTunes.

Previous 1 2 Next