3 Replies Latest reply: Mar 18, 2012 1:17 PM by zaurav
Christopher_Hull Level 1 (5 points)

Greetings fellow Mac geeks. I am stumped.


Problem: When I open "Videos" on iPad, I do not see my shared library

Problem: When I turn on ATV and go to "Computers" I do not see my shared library


Until today, I've had no problem accessing my shared library from my Apple TV or my iPad. Today, all of a sudden, neither ATV nor iPad can see my shared library. Here's my set up:


-iMac is sharing my itunes library "Share my library on my local network" is on in preferences

-My iMac, iPad, and ATV are all connected to the same network via wifi


The only thing I've changed is that I added iTunes match. But that was a couple days ago, and I did not have problems until today.


Please help if you can-



iMac, Mac OS X (10.7.2), 2.8GHz i7-16GB-2TB/4TB EXTERNAL
  • ckuan Level 7 (29,548 points)

    Reboot your router.


    Log out of shared and log back in.

  • Christopher_Hull Level 1 (5 points)

    I did. No luck. Oddly, even though home sharing was turned on in preferences, That wasn't enough. I went to the advanced toolbar>turn on home sharing and then entered my password. That fixed it. Why I had to do this is beyond me. My home sharing has been working like a charm for months, maybe years. All of a sudden it disconnected. Either way, it's fixed now.

    Thanks for the response.

  • zaurav Level 1 (0 points)



    Not sure if I'm late to answering your questions, but I had a similar frustrating experience where none of my iDevices' home sharing functionality worked. It drove me nuts as I like keeping my songs on my desktop and listening to them from my idevices. However none of my idevices showed my desktop on the 'shared' tab.


    A temporary solution was to restart my router every now and then. I even bookmarked (my wireless router's admin page) so I could have easy access to the router reset functionality from there.



    It did the job but I wasn't fully satisfied.


    Two months down the line, a new roommate moved in and along with him came his new wireless router. Suddenly all my problems were fixed. Consistent home sharing without any interruptions.


    So it turned out that my old router (BELKIN) was incompatible (in a sense) with the home sharing functionality of iOS and OSX. My new router (DLINK) works flawlessly!


    Hope this helps at least identify the source of your problem. If you own a Belkin wireless router, that might be the culprit.


    Have a great day!