7 Replies Latest reply: Jan 17, 2012 10:25 AM by LotusDome
jbwhitt74 Level 1 Level 1

I've gone to settings, safari, turned on autofill and set to my name in contacts.  Please help


iPhone 4S, iOS 5.0.1
  • stevejobsfan0123 Level 8 Level 8
    expertise.iphone
    iPhone

    It may need to be shut down and restarted in order for the change to take effect.

  • LotusDome Level 1 Level 1

    Same problem:

     

    iPhone 4S, iOS 5.0.1

     

    AutoFill Names & Passwords and Use Contact Info are both turned on. It does nothing and hasn’t since I got the iPhone.

     

    I want the username and password remembered for my email server (http not https). The text field keyboard has an active AufoFill button. Clicking it does nothing. I have never gotten a prompt asking if I want to save my username and password. Auto-filling of fields is not prohibited on this site.

     

    Needed data is entered into the Notes field of my contact info. and Safari does not remember any data from one session to another. What do I need to do to get this to work?

     

    Thanks!

  • godfreyc Level 1 Level 1

    Same here. It worked fine on my iPhone 4 but is broken on the 4S.

  • LotusDome Level 1 Level 1

    Greetings, godfreyc!

     

    I found the following in another Apple Discussion forum:

     

    To Get Safari to Remember AutoFill:

    Settings > Safari > Autofill > Names & Passwords > ON (mine was already on)

    Settings > Safari > Accept Cookies > From Visited (mine was already set)

    Settings > Safari > Private Browsing > OFF (I believe that this was the problem, as I had it turned on.)

    Settings > Safari > Clear Cookies and Data (may not be necessary)

     

    Good luck!   ;-)

  • godfreyc Level 1 Level 1

    Brilliant! That worked, thanks. Odd though, as Private Browsing was turned on on my iPhone 4 and Autofill worked.

  • godfreyc Level 1 Level 1

    In fact I've now turned Private Browsing back on (and also cleared History and Cookies and Data), and Safari still remembers the website login details I told it to save. So the solution seems to be to turn off Private Browsing, tell Autofill to save your login info, then turn Private Browsing on again.

  • LotusDome Level 1 Level 1

    Indeed! Turning Private Browsing back on worked here as well: login details were properly autofilled. Thank YOU!   :-)