1 2 3 4 5 Previous Next 94 Replies Latest reply: May 13, 2014 12:07 AM by poorbrokefella Go to original post
  • 30. Re: External drive doesn't work
    quanganhzero Level 1 Level 1 (0 points)

    Hey Guyssss

     

    I got the External Hard drive from Toshiba 1 TB today and it could not on my 2011 mac air, but it worked on my gf's 2010 mac air and my friend 2010 mac pro. WEIRD!!!!!!

     

    Then I found the solution.At first I found out the usb 3.0 and macbook (air and pro 2011) can not be compatible each other. Then I thought I could use external USB Hub (mine is 4-port USB hub) as a bridge that connect from external hard drive to laptops. And it worked like CHARM !!!!!

     

    Let me know if it works on your laptop

  • 31. Re: External drive doesn't work
    izildur Level 1 Level 1 (0 points)

    Well.. unfortunately  I bought this drive from Staples during a thanks giving sale and I'm suffering from the same problem mentioned in this thread. I've read that Lion could be blamed for this however I have 2 laptops one Aluminum MacBook from late 2008 and one MacBook Pro 17"  early 2011, both were upgraded from Snow Leopard to Lion though the same process  (clean install, etc).

     

    After getting this drive I tried connecting it to the MBP and it won't show up in Disk Utility however I'm able to see and work with the drive using the MacBook.

     

    The problem might have to do with the USB ports in these new laptop models..

     

    I guess I'm returning this drive to Staples.

  • 32. Re: External drive doesn't work
    amcg01 Level 1 Level 1 (0 points)

    I've heard word through a friend that there might be a hack for this - it was described as a problem similar to Region-specific DVD players?

     

    Am following up on it.

  • 33. Re: External drive doesn't work
    ankurbs Level 1 Level 1 (0 points)

    I just bought the 750GB version had a weird problem as well, though slightly different than what has been described in this thread. I have an older Macbook (white cira 2008 with leopard installed) and it mounts, but when I go to reformat it for use with Time Machine, I get a weird partition error from Disk Utility (the drive no longer appears mounted, but I can see it via Disk Utility). I am able to reformat it to FAT, which I thought was weird.

     

    I then plugged it into my wife MBA (2011 version, about a month old) and it mounted and reformated without issues (quite quickly actually). I went back and plugged the drive into my older Mac and the drive worked fine (though, another odd thing is when I get info on the drive on the older Mac is says around 700GB free, where as on the MBA is says around 749GB free. I am assuming that has to deal with the Mac software).

     

    In any case, I went ahead and started copying my itunes movies over to the drive (whole point was to move my movie collection to external drive) and then linked it to itunes (which worked). Finally, i performed an itunes sync with my ipad and the drive connected (also made sure to copy a bunch of movies from the drive to the ipad) and it worked just fine. Not sure if it is a power issue, as if it was, I would assume supplying power to the drive and the ipad would have caused some sort of the error during the sync.

  • 34. Re: External drive doesn't work
    Arbynav Level 1 Level 1 (10 points)

    I used a micro, not mini, a micro USB connector on one side and my Macbook Pro (2011) recognized the drive and reformatted it for Time Machine.  Prior to that the drive (brand new Toshiba Canvio 1TB USB 3.0 and 2.0) didn't show on the Macbook but did immediately show on a older Windows machine

  • 35. Re: External drive doesn't work
    EliasE Level 1 Level 1 (5 points)

    Using the MicroUSB Drive from my Jawbone Jambox worked! Disk Utility recognized it! (Running MacBook Pro 13" 2011 i5 2.4 GHz)

    Screen Shot 2011-12-14 at 12.53.00 AM.PNG

  • 36. Re: External drive doesn't work
    MDanihy Level 1 Level 1 (0 points)

    Yup, that is the workaround.  Seems the issue affects Macs with Thunderbolt and isn't an issue with Lion.  I tried a couple of Micro-USB connectors and the third one worked.  Seems some of the cables I have only support power and not data.  Grabbed a Blackberry cable from Staples and the drive shows, it is most probably a communication issue wich is a result of the Thunderbolt technology on Macs.  I for one am OK with the cable change as a 3.0 connection is moot for me.

  • 37. Re: External drive doesn't work
    zeitlerd Level 1 Level 1 (0 points)

    Good to know that not all micro-USB cables will work. I'll have to try a couple more. The first cable I tried didn't work. Like many, USB 3.0 is a moot issue, so the standard micro-USB should be fine.

  • 38. Re: External drive doesn't work
    Art Level 1 Level 1 (115 points)

    So, for those who might still be confused, the USB 3.0 micro connector is really an extension of standard micro-USB. By using a standard USB 2.0 micro-B cable on the USB2 half, you can get it to work. Here is a picture (1-5 are standard USB2 micro-B, 6-10 are the USB3 extension):

    /___sbsstatic___/migration-images/170/17024136-1.png

  • 39. Re: External drive doesn't work
    Jaresbell Level 1 Level 1 (0 points)

    I had that issue with my Toshiba Canvio and my Mac Book Pro+Lion.

    The cheapest solution In my case was buy a belkin USB hub "powered" (it comes with a power supply).

    Lion os limits the voltaje in USB ports and it isn't enough to this device.

  • 40. Re: External drive doesn't work
    Jaresbell Level 1 Level 1 (0 points)

    I posted the solution below.

  • 41. Re: External drive doesn't work
    MDanihy Level 1 Level 1 (0 points)

    Jaresbell,

     

    You are incorrect in your assumption that Lion is controlling the voltage.  The MBA using the external CD-ROM drive can draw up to 1100 mA from the from the computer.  The cheaper solution is to actually buy a cheap MicroUSB cable that supports data transfer.

     

    In all cases it looks like the Canvio doesn't work well with Thunderbolt, that is the only common denominator.

  • 42. Re: External drive doesn't work
    amcg01 Level 1 Level 1 (0 points)

    Hold on, people are trying to use the drive with Thunderbolt, not USB?

     

    I'm trying to use my Toshiba USB drive with the MBA's USB port...

     

    *confused*

     

     

  • 43. Re: External drive doesn't work
    Jaresbell Level 1 Level 1 (0 points)

    My drive is USB (not thunderbolt), and is working now,just using an USB hub in the middle.

  • 44. Re: External drive doesn't work
    MDanihy Level 1 Level 1 (0 points)

    amcg01 & Jaresbell,

     

    Read the entire thread.  The issue is with Macs with Thunderbolt, the Canvio drive works with all other Macs prior to Thunderbolt.

     

    And yes, the drive is USB.

1 2 3 4 5 Previous Next