Previous 1 2 3 4 5 6 7 Next 98 Replies Latest reply: Dec 27, 2014 10:10 PM by KHAANNN Go to original post
  • amcg01 Level 1 (0 points)



    I understand the issue is with "Macs with Thunderbolt", i.e. mid-2011 Macs, which is what I have.


    Am confused because you said the following:


    "Upon further Google searches, it seems the Macbook air cannot accomodate USB3 devices plugged into it's USB2 ports.  Must be a power issue.  The drive spins up but disk utility never shows the drive."


    That's exactly what my issue appears to be, which is why I'm following the thread.

  • scootermafia Level 1 (5 points)

    I can guarantee that these drives will work if you use a MICRO usb cable, it plugs into part of the weird proprietary connector that it uses (the part that's shaped like a micro usb, consequently).  The cable to my Kindle did the job.  Popped up and ran fine in usb 2.0 on my macbook air once I used that cable.

  • Art Level 1 (115 points)

    No, the issue *appears* to be mainly a problem with newer Macs that have thunderbolt ports, not that the drive itself is being plugged into the thunderbolt port. The thunderbolt port is merely an indicator of the type of machine that is having a problem.


    Unfortunately, it may not be as simple as that. I tested one of these drives on an old Quicksilver 2002 (G4 933MHz) running 10.5.8 with an Adaptec Firewire/USB2 card, and it still wouldn't mount. Now I know the ports on that card have plenty of power, so, combined with the fact that the drive seems to work when using a micro-USB2 cable (that's micro, not mini, as some posters have mistakenly stated) on some machines, means there's something going on in regards to backwards compatibility from USB3 to USB2 and/or the bridge chipset on the drive is incompatible in some way.


    I also must note that my 1TB Western Digital My Passport Essential USB 3.0 drives mount on the same machines that the 1TB Toshiba Canvio drives do not. They work with the included USB 3.0 cable. No need for any hacks there.


    I've also just ordered a 1TB Seagate FreeAgent GoFlex USB 3.0 portable drive, and if that mounts OK, then I have no reason to conclude anything other than that the Toshiba drives are defective/incompatible, and it's not Apple's fault.

  • SP Forsythe Level 5 (5,370 points)

    Art wrote:


    I've also just ordered a 1TB Seagate FreeAgent GoFlex USB 3.0 portable drive, and if that mounts OK, then I have no reason to conclude anything other than that the Toshiba drives are defective/incompatible, and it's not Apple's fault.

    My 1.5 TB Seagate FreeAgent GoFlex USB 3.0 portable drive works just fine on my mid 2011 MBA 13". Not a single glitch.

  • cortek Level 1 (0 points)

    I just purchased this same drive (except the 500GB version) and should have done more research first. It worked on my iMac (Snow Leopard), but not on the MacBook Pro (Lion) I'm trying to get Time Machine set up for. After a call to Apple Support we discovered that if I plug the Toshiba Canvio into a powered USB hub on the MBP, the drive is recognized just just requires more wattage than the MBP is putting through either USB port.


    I plan on returning this Toshiba Canvio b/c I don't want my user to have to always plug it into a powered hub to get it to work.

  • MDanihy Level 1 (0 points)

    Oviously you didn't read the entire thread.  It has nothing to do with power but with the compatability between the Toshiba circuitry and Macs with Thunderbolt.  If you had read the entire thread you would have seen that using a microUSB cable capable of data transfer will work with the drive.

  • Art Level 1 (115 points)

    Well, I just got my 1TB Seagate FreeAgent GoFlex USB 3.0 portable. I plugged it in to my mid-2011 Mac Mini with Thunderbolt, mounts! No problems, no log errors, no sudden dismounts or disconnects.


    That proves it. Western Digital and Seagate USB 3.0 portable drives work just fine with any and all Macs. Toshiba portable drives do not.


    So, this is definitely a problem with the Toshiba drive and/or compatibility with the chipset/bridge in their enclosure.


    On a related note, I have seen reports of people using Windows PCs having similar problems with Toshiba portable drives. It isn't just us.

  • Arbynav Level 1 (10 points)

    I suspect some cross talk between the USB 2.0 connections and the USB 3.0 connections at the Canvio end. If the USB 3.0 connections are receiving noise from the USB 2.0 connections at the computer end (It could be the USB cable is leaking signal and I think but can't confirm that the computer end contacts physically close, possibly overlapping?), it may react same as if it was data signals on the USB 3.0 and replies to the MB as a 3.0, which the MB can't see.  The Canvio would probably respond randomly trying to interpret the signals.  I don't know why it would happen consistently for Thunderbolt equipped models and not others, maybes there's more signals/noise on the USB, or if it's happening with other computers as the previous poster mentioned, it's just serendipity.  Using just a USB 2.0 micro connect means the additional connectors get no signal, the pins will drive to high and the systems only sees true USB 2.0.  The reason other brands don't have the problem is they may have a better noise rejection circuitry/protocol or come with a better USB 3.0 connect cable.  I saw that some people swapped USB 3.0 cables, if they went to another brand (which worked with another drive) and the Canvio failed, then it's at the hard drive end.  Just my theory.


    Message was edited by: Arbynav to add material on other drives

  • Art Level 1 (115 points)

    I tested the Toshiba Canvio with the USB 3.0 cable from my Western Digital My Passport, but it still didn't mount, so it's not the cable (in fact, my Seagate GoFlex works with the cable from the My Passport, so I know this is a good cable).

  • chikyc Level 1 (0 points)

    It's really a weird issue. My TOSHIBA CAVINO USB 3.0 1TB works fine with MBA 13" Lion upgraded from Leopard, works on all my Windows systems, but doesn't work with the MBA 11" came with Lion. I just tried the cable from my Seagate Expansion 3TB USB 3.0 (this Seagate dirve works great with my MBA too) and the TOSHIBA drive finally works. Now I'm backing up the system to the TOSHIBA drive with Time Machine without any problem, but I still don't the know issue is from the cable, or both the calbe and Lion.

  • aplindsay Level 1 (0 points)

    THANK YOU! No joy with my blackberry USB cable, but the Kindle one worked a treat.  Spread the word!  Long live books!

  • Arbynav Level 1 (10 points)

    Based on the discussions above, I think there's more interplay going on with the cable, Apple's hardware, and Toshiba's Canvio circuitry.  Regarding power, the Canvio drive should be able to run just with 2.0 power and apparently does on other machines.  One blogger, Christopher Price, is posting ( rives-18699 )that this situation is because the Toshiba draws more power than the USB 3.0 specs allow.  Then when it connects to an Apple system, the Apple system refuses to supply more power because Apple won't let anything but another Apple device (like an iPad) draw excess power.  The MacBook system is supposed to enforce this through some Apple proprietary protocol handshake.  One of the proofs of this theory is that using a powered hub works.  While possible, my outside guess is there's a bit more going on here than that.  That explanation totally sidesteps why USB 2.0 connections work - they supply a max of 500ma, but work okay (except Apple).  Also, if a powered hub resolves the issue, unless they're working with an extremely new hub, it's a USB 2.0 spec hub.  What a powered hub will due is provide extra isolation between the Apple connection and the hard drive, as it has components that process and split signals between the USB receptacles.   Since other USB 3.0 drives (reportedly) work with the MB, and the Toshiba Canvio only hiccups with Apple, if this happened in one of my programs I'd haul in both parties and demand to know what non-standard signals Apple was sending down the line and why the Canvio couldn't recognize none of the USB 3.0 connections were functioning and automatically drop to 2.0.  Another possibility is also that the Toshiba has it exactly right, and the other USB 3.0 drives that work with MBs aren't really fully 3.0 capable and miss the signaling.  I'd love to see reports out there of trying to connect other USB 3.0 drives to an MB.  I think Toshiba models were the first ones up because they were heavily promoted/discounted over the holidays.  If all the others work flawlessly with USB 2.0 connections (including MBs), and run full up at USB 3.0 speeds on 3.0 connections, then it's Toshiba and Apple.  I've seen notes about connecting other drives, but no specific mention on systems that have 3.0 capability.

  • iliesaya Level 1 (0 points)

    I recently buyed the USB3 “toshiba store.e Canivo” 2,5″ hard drive.

    It work on PC, on the 2010 iMac , but not on the mid 2011 macbook air 11″.

    It seems to be a power issue.


    The original USB3 cable : Don’t Work


    Another micro usb cable (from a smartphone) : Don’t Work


    USB Extension cord (from the imac keyboard) : Don’t work


    USB Extension cord (from a cheap USB Hub) : WORK :)


    The USB hub WITH it’s USB Extension cord : WORK . But it didn’t work without the extension usb cord (directly to the mba usb port, it make the finder crash)

    biggest picture here the-macbook-air-11-mid-2011/

  • Arbynav Level 1 (10 points)

    Illiesaya, that's a pretty good experimentation and check pointing straight to power drain.  Which would blast my theory - some interplay between a later model Apple system or OS.  A power issue would mean that Apple exactly controls the power at each USB outlet to no more than 500ma and Toshiba exceeds the allowable USB 2 draw (500ma) or Apple limits power (for non-Apple devices) at the USB connections to less than the USB standard.  I know that iPod USB cords had (and I think they still have) a resistor bridge between two of the USB connections which apparently signals at both ends this is an Apple device.  The odd item is that I and others successfully used (and I still use) a micro-USB connector.  Plus the Canvio runs great on other PCs.  Other PC systems may have relatively unrestricted power at the USB port - they could simply strap all the ports in parallel almost directly to a 5VDC line from the power supply, which usually supplies 20-30 amps in a regular PC.  That's more than enough to easily tolerate something more than USB 2.0's 500ma requirement if they don't have some limiting circuit.  I'll have to see if I've got the parts to do a breadboard USB test jig and actually measure the hard drive's current draw.

  • L.J.S Level 1 (0 points)

    I also had problems with my Toshiba Canvio hard drive when I first got it. I have a 2010 MacBook Pro running Snowleapord, and it worked fine with that. I also have a 2011 iMac running Lion which did not even reconise the hard drive when I plugged it in. I think it is a problem with the newer macs with Thunderbolt, which seems to effect the USB power. I tried using a micro USB cable, but I think the connection was a bit dodgy because it didn't really work. I then bought a new micro USB cable with was data enabled and that works fine with both of my macs.
    btw, don't enable the hard drive for Timemachine when it asks because then the hard drive can only be used as a back-up. I also formatted the hard drive as Mac OX Extended (case sensitive).