Previous 1 3 4 5 6 7 Next 98 Replies Latest reply: Dec 27, 2014 10:10 PM by KHAANNN Go to original post
  • Filda Level 1 (0 points)

    I really needed 1TB drive for my other half so I took it apart and installed it to different enclosure. Drive works 100%. So I think it is controller what is the problem.

  • jrzd7000 Level 1 (0 points)

    I've had a very similar experience on my new 15" retina MBP.  Using the 4 ft micro USB 3.0 cable from a 3TB Seagate GoFlex Desk, I was able to get a 1TB Toshiba Canvio USB 3.0 drive to mount and work perfectly on my rMBP.  I was also able to get the Toshiba Canvio working (with the original Toshiba micro USB 3.0 cable) by using a powered USB 3.0 4-port hub.


    It's really strange how the provide cable does not work, but the Seagate cable does.  If, it really is a power issue with Thunderbolt Macs, why does the Seagate cable work?

  • JonathanA88 Level 1 (0 points)

    I was having the same issue with my mac pro (2011) and since the toshiba needs more power in order to run I purchased an OEM usb power adapter Y extension cable YC150B on ebay and reformated the drive to FAT32 in order to be used on the mac osx lion 10.7.4.





  • djdan23323 Level 1 (15 points)

    Had same issue with MBA 11' 128GB.  Have reported to Apple Care.  Gone all the way up to engineers.  No resolution yet. My issue was with a Verbatim 64GB USB 3.0 flash drive.  Verbatim pointing at Apple.  And yes, this same flash drive worked in 2010 MBP.  Waiting and waiting... gotta be a firmware upgrade coming at some point.

  • Gavin Eadie2 Level 1 (10 points)

    Plugged 1TB Toshiba (HDTB110EK3BA .. bought in Europe, which doesn't matter for this discussion, though I can't easily return it!) into new 15" retina.  It didn't appear on the Desktop (or in Disk Utility, or on the USB bus).


    And, after plugging this drive in, the USB sockets wouldn't accept ANY disk, rotating or flash. I had to reboot to get control back.  Worse still, if I let the laptop sleep, it wouldn't wake and needed a power key forced shutdown.


    I talked to a Toshiba tech rep and they said they're waiting for a firmware upgrade (and don't know when it'll arrive) that they'll post on the Support pages of the web site.  I don't think I believe them -- time will tell.  The pesky thing is too small to use for a doorstop.

  • Kitchentea Level 1 (0 points)

    My Toshiba Canvio 3.0 500 GB Go works on my 2011 MacBook Air to back up my files. I plugged it in and time machine took over. No problems really. It probably runs at USB 2.0 speed though since my 2011 Air does not have a USB 2.0 port.

    All the posts here have had a problem with the 1 TB Toshiba canvios. I wonder if that is a factor.

  • plcosta Level 1 (0 points)

    Works with usb hub and additional power on my 2011 Mid Macbook Air.



  • plcosta Level 1 (0 points)

    I had same problem with a Toshiba Canvio External 1TB drive, 2.5 USB 3.0. I SOLVED using a usb extension of about 1ft.



  • JackPot62 Level 1 (0 points)

    I've tried a few cables. The 1 TB shows up even with the USB 3 Cable.

    It also shows up with Micro USB and a USB 2 extension. So far it is



    I have a macbook pro 13", Mid 2010. So far the drive works find. BUT:


    Every morning it says: cannot write to external hard disk, error -50.

    But the format is ok and the macbook goes not into sleep modus…


    Would really appreciate ideas how to solve this error…

  • Arbynav Level 1 (10 points)

    Which cables have you tried overnight?  Have you used just the USB 3 or have you tried overnight both micro USB and the USB 2 extension?

  • JackPot62 Level 1 (0 points)

    I have tried:

    Micro USB from Kindle

    USB 2 Extension (3 different cables)


    The Hard Disk show up but after some time, it

    gives me suddently error -50

  • Kalan Vryce Level 1 (0 points)

    Ok, so here is what worked for my Toshiba 1TB external drive on the early 2011 MBP -- other drives work fine but this one requires 1A vs the 500mA that many others do however even using the cable from an early USB 3.0 drive with the extra connection for power didn't work UNTIL I connected the power cable to the USB port closest to the back of the computer (the one right next to the thunderbolt port as seen below) and BINGO works great now! I just had to move my mouse to a different slot


    So it would seem it is just a power issue and the one port closest to the thunderbolt has a bit more juice than the other two which is why the guys using a powered USB hub are getting results as well.


  • Art Level 1 (115 points)

    BTW, I'm not sure if this was posted before in this thread, but it gives a lot of insight as to why using USB3 devices with USB2 ports on a Mac can have issues:



    It also shows that for the same drives we're having problems with now, with USB3 ports there won't be a problem.


    One trick I gleaned from the doc is that you should plug the drive you're having problems with into the first USB2 port, because that one gets priority for power usage over the others. It looks like @Kalan Vryce's experience, which is posted just above, confirms this.

  • Art Level 1 (115 points)

    Yes, I decided to try a 500GB Canvio Basics that was on sale for Black Friday, and lo and behold, it mounts without any problems. Either the issue has been fixed, or, it was most prominent with the 1TB drives.

  • bertiebirdman Level 1 (0 points)


    Toshiba 1TB 2.5 inch External StorE Art HDD doesn't show up in Finder.

    The light is on and it hums. Has always worked perfectly and now this. Using it on a 2010 Mac with Snow Leopard 10.6.8

Previous 1 3 4 5 6 7 Next